Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » XML Schema Definition (XSD) » Help with XSDAnnotation
Help with XSDAnnotation [message #30530] Mon, 29 September 2003 20:21 Go to next message
Lance Phillips is currently offline Lance PhillipsFriend
Messages: 210
Registered: July 2009
Senior Member
I'm calling XSDSchemaBuildingTools.addUserInformation on an
XSDSimpleTypeDefinition passing in null for the sourceURI and some text for
the documentation. However, when I come out of the method my newly created
Annotation has null for the value of the documentation. In debug mode I get
to the
userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text)) line
and everything seems OK. I'm unable to step into the DOM code as I don't
have source... but the resulting userInfo does NOT have my text as a child.

Any ideas?

thanks,

lp
Re: Help with XSDAnnotation [message #30565 is a reply to message #30530] Mon, 29 September 2003 20:33 Go to previous messageGo to next message
Lance Phillips is currently offline Lance PhillipsFriend
Messages: 210
Registered: July 2009
Senior Member
BTW.... yes the DataType has already been added to a Schema.

thanks,

lp
"Lance Phillips" <lphillips@metamatrix.com> wrote in message
news:bla45i$l81$1@eclipse.org...
> I'm calling XSDSchemaBuildingTools.addUserInformation on an
> XSDSimpleTypeDefinition passing in null for the sourceURI and some text
for
> the documentation. However, when I come out of the method my newly
created
> Annotation has null for the value of the documentation. In debug mode I
get
> to the
> userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
line
> and everything seems OK. I'm unable to step into the DOM code as I don't
> have source... but the resulting userInfo does NOT have my text as a
child.
>
> Any ideas?
>
> thanks,
>
> lp
>
>
Re: Help with XSDAnnotation [message #30600 is a reply to message #30530] Mon, 29 September 2003 20:58 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Lance,

This looks to be a DOM question. ;-)

I'll try to have a look at it when I have some time, but it seems to me that the
code either works, or has a null pointer exception; either way, it's DOM that's
involved.


Lance Phillips wrote:

> I'm calling XSDSchemaBuildingTools.addUserInformation on an
> XSDSimpleTypeDefinition passing in null for the sourceURI and some text for
> the documentation. However, when I come out of the method my newly created
> Annotation has null for the value of the documentation. In debug mode I get
> to the
> userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text)) line
> and everything seems OK. I'm unable to step into the DOM code as I don't
> have source... but the resulting userInfo does NOT have my text as a child.
>
> Any ideas?
>
> thanks,
>
> lp
Re: Help with XSDAnnotation [message #30670 is a reply to message #30600] Tue, 30 September 2003 11:59 Go to previous messageGo to next message
Lance Phillips is currently offline Lance PhillipsFriend
Messages: 210
Registered: July 2009
Senior Member
Thanks Ed... I seem to be having problems editing Annotations in the
XSDEditor. I can't do anything with them in the properties panel. I was
hoping to create a valid example in the editor that I could then steal from
;) Is there a bug? We have not rolled up to the latest driver yet.

thanks,

lp

"Ed Merks" <merks@ca.ibm.com> wrote in message
news:3F789D08.5132DF03@ca.ibm.com...
> Lance,
>
> This looks to be a DOM question. ;-)
>
> I'll try to have a look at it when I have some time, but it seems to me
that the
> code either works, or has a null pointer exception; either way, it's DOM
that's
> involved.
>
>
> Lance Phillips wrote:
>
> > I'm calling XSDSchemaBuildingTools.addUserInformation on an
> > XSDSimpleTypeDefinition passing in null for the sourceURI and some text
for
> > the documentation. However, when I come out of the method my newly
created
> > Annotation has null for the value of the documentation. In debug mode I
get
> > to the
> > userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
line
> > and everything seems OK. I'm unable to step into the DOM code as I
don't
> > have source... but the resulting userInfo does NOT have my text as a
child.
> >
> > Any ideas?
> >
> > thanks,
> >
> > lp
>
Re: Help with XSDAnnotation [message #30743 is a reply to message #30670] Tue, 30 September 2003 12:04 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Lance,

The editor has a number of shortcomings. It doesn't have the ability to create
anything within an XSDAnnotation (because those things are DOM and not EMF
objects).


Lance Phillips wrote:

> Thanks Ed... I seem to be having problems editing Annotations in the
> XSDEditor. I can't do anything with them in the properties panel. I was
> hoping to create a valid example in the editor that I could then steal from
> ;) Is there a bug? We have not rolled up to the latest driver yet.
>
> thanks,
>
> lp
>
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:3F789D08.5132DF03@ca.ibm.com...
> > Lance,
> >
> > This looks to be a DOM question. ;-)
> >
> > I'll try to have a look at it when I have some time, but it seems to me
> that the
> > code either works, or has a null pointer exception; either way, it's DOM
> that's
> > involved.
> >
> >
> > Lance Phillips wrote:
> >
> > > I'm calling XSDSchemaBuildingTools.addUserInformation on an
> > > XSDSimpleTypeDefinition passing in null for the sourceURI and some text
> for
> > > the documentation. However, when I come out of the method my newly
> created
> > > Annotation has null for the value of the documentation. In debug mode I
> get
> > > to the
> > > userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
> line
> > > and everything seems OK. I'm unable to step into the DOM code as I
> don't
> > > have source... but the resulting userInfo does NOT have my text as a
> child.
> > >
> > > Any ideas?
> > >
> > > thanks,
> > >
> > > lp
> >
Re: Help with XSDAnnotation [message #30813 is a reply to message #30743] Tue, 30 September 2003 14:40 Go to previous messageGo to next message
Lance Phillips is currently offline Lance PhillipsFriend
Messages: 210
Registered: July 2009
Senior Member
Ed,
Any plans to improve the editor? We were planning on borrowing heavily
from it for an editor we are creating.

thanks,

lp
"Ed Merks" <merks@ca.ibm.com> wrote in message
news:3F79713F.46E56CB2@ca.ibm.com...
> Lance,
>
> The editor has a number of shortcomings. It doesn't have the ability to
create
> anything within an XSDAnnotation (because those things are DOM and not EMF
> objects).
>
>
> Lance Phillips wrote:
>
> > Thanks Ed... I seem to be having problems editing Annotations in the
> > XSDEditor. I can't do anything with them in the properties panel. I
was
> > hoping to create a valid example in the editor that I could then steal
from
> > ;) Is there a bug? We have not rolled up to the latest driver yet.
> >
> > thanks,
> >
> > lp
> >
> > "Ed Merks" <merks@ca.ibm.com> wrote in message
> > news:3F789D08.5132DF03@ca.ibm.com...
> > > Lance,
> > >
> > > This looks to be a DOM question. ;-)
> > >
> > > I'll try to have a look at it when I have some time, but it seems to
me
> > that the
> > > code either works, or has a null pointer exception; either way, it's
DOM
> > that's
> > > involved.
> > >
> > >
> > > Lance Phillips wrote:
> > >
> > > > I'm calling XSDSchemaBuildingTools.addUserInformation on an
> > > > XSDSimpleTypeDefinition passing in null for the sourceURI and some
text
> > for
> > > > the documentation. However, when I come out of the method my newly
> > created
> > > > Annotation has null for the value of the documentation. In debug
mode I
> > get
> > > > to the
> > > >
userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
> > line
> > > > and everything seems OK. I'm unable to step into the DOM code as I
> > don't
> > > > have source... but the resulting userInfo does NOT have my text as a
> > child.
> > > >
> > > > Any ideas?
> > > >
> > > > thanks,
> > > >
> > > > lp
> > >
>
Re: Help with XSDAnnotation [message #30845 is a reply to message #30813] Tue, 30 September 2003 14:47 Go to previous message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

Lance,

No, the editor is very low on the list of priorities. It's just meant as a full
scale example from which others can beg, borrow, and steal. ;-)


Lance Phillips wrote:

> Ed,
> Any plans to improve the editor? We were planning on borrowing heavily
> from it for an editor we are creating.
>
> thanks,
>
> lp
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:3F79713F.46E56CB2@ca.ibm.com...
> > Lance,
> >
> > The editor has a number of shortcomings. It doesn't have the ability to
> create
> > anything within an XSDAnnotation (because those things are DOM and not EMF
> > objects).
> >
> >
> > Lance Phillips wrote:
> >
> > > Thanks Ed... I seem to be having problems editing Annotations in the
> > > XSDEditor. I can't do anything with them in the properties panel. I
> was
> > > hoping to create a valid example in the editor that I could then steal
> from
> > > ;) Is there a bug? We have not rolled up to the latest driver yet.
> > >
> > > thanks,
> > >
> > > lp
> > >
> > > "Ed Merks" <merks@ca.ibm.com> wrote in message
> > > news:3F789D08.5132DF03@ca.ibm.com...
> > > > Lance,
> > > >
> > > > This looks to be a DOM question. ;-)
> > > >
> > > > I'll try to have a look at it when I have some time, but it seems to
> me
> > > that the
> > > > code either works, or has a null pointer exception; either way, it's
> DOM
> > > that's
> > > > involved.
> > > >
> > > >
> > > > Lance Phillips wrote:
> > > >
> > > > > I'm calling XSDSchemaBuildingTools.addUserInformation on an
> > > > > XSDSimpleTypeDefinition passing in null for the sourceURI and some
> text
> > > for
> > > > > the documentation. However, when I come out of the method my newly
> > > created
> > > > > Annotation has null for the value of the documentation. In debug
> mode I
> > > get
> > > > > to the
> > > > >
> userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
> > > line
> > > > > and everything seems OK. I'm unable to step into the DOM code as I
> > > don't
> > > > > have source... but the resulting userInfo does NOT have my text as a
> > > child.
> > > > >
> > > > > Any ideas?
> > > > >
> > > > > thanks,
> > > > >
> > > > > lp
> > > >
> >
Re: Help with XSDAnnotation [message #578737 is a reply to message #30530] Mon, 29 September 2003 20:33 Go to previous message
Lance Phillips is currently offline Lance PhillipsFriend
Messages: 210
Registered: July 2009
Senior Member
BTW.... yes the DataType has already been added to a Schema.

thanks,

lp
"Lance Phillips" <lphillips@metamatrix.com> wrote in message
news:bla45i$l81$1@eclipse.org...
> I'm calling XSDSchemaBuildingTools.addUserInformation on an
> XSDSimpleTypeDefinition passing in null for the sourceURI and some text
for
> the documentation. However, when I come out of the method my newly
created
> Annotation has null for the value of the documentation. In debug mode I
get
> to the
> userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
line
> and everything seems OK. I'm unable to step into the DOM code as I don't
> have source... but the resulting userInfo does NOT have my text as a
child.
>
> Any ideas?
>
> thanks,
>
> lp
>
>
Re: Help with XSDAnnotation [message #578795 is a reply to message #30530] Mon, 29 September 2003 20:58 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31346
Registered: July 2009
Senior Member
Lance,

This looks to be a DOM question. ;-)

I'll try to have a look at it when I have some time, but it seems to me that the
code either works, or has a null pointer exception; either way, it's DOM that's
involved.


Lance Phillips wrote:

> I'm calling XSDSchemaBuildingTools.addUserInformation on an
> XSDSimpleTypeDefinition passing in null for the sourceURI and some text for
> the documentation. However, when I come out of the method my newly created
> Annotation has null for the value of the documentation. In debug mode I get
> to the
> userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text)) line
> and everything seems OK. I'm unable to step into the DOM code as I don't
> have source... but the resulting userInfo does NOT have my text as a child.
>
> Any ideas?
>
> thanks,
>
> lp


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Help with XSDAnnotation [message #578831 is a reply to message #30600] Tue, 30 September 2003 11:59 Go to previous message
Lance Phillips is currently offline Lance PhillipsFriend
Messages: 210
Registered: July 2009
Senior Member
Thanks Ed... I seem to be having problems editing Annotations in the
XSDEditor. I can't do anything with them in the properties panel. I was
hoping to create a valid example in the editor that I could then steal from
;) Is there a bug? We have not rolled up to the latest driver yet.

thanks,

lp

"Ed Merks" <merks@ca.ibm.com> wrote in message
news:3F789D08.5132DF03@ca.ibm.com...
> Lance,
>
> This looks to be a DOM question. ;-)
>
> I'll try to have a look at it when I have some time, but it seems to me
that the
> code either works, or has a null pointer exception; either way, it's DOM
that's
> involved.
>
>
> Lance Phillips wrote:
>
> > I'm calling XSDSchemaBuildingTools.addUserInformation on an
> > XSDSimpleTypeDefinition passing in null for the sourceURI and some text
for
> > the documentation. However, when I come out of the method my newly
created
> > Annotation has null for the value of the documentation. In debug mode I
get
> > to the
> > userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
line
> > and everything seems OK. I'm unable to step into the DOM code as I
don't
> > have source... but the resulting userInfo does NOT have my text as a
child.
> >
> > Any ideas?
> >
> > thanks,
> >
> > lp
>
Re: Help with XSDAnnotation [message #578936 is a reply to message #30670] Tue, 30 September 2003 12:04 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31346
Registered: July 2009
Senior Member
Lance,

The editor has a number of shortcomings. It doesn't have the ability to create
anything within an XSDAnnotation (because those things are DOM and not EMF
objects).


Lance Phillips wrote:

> Thanks Ed... I seem to be having problems editing Annotations in the
> XSDEditor. I can't do anything with them in the properties panel. I was
> hoping to create a valid example in the editor that I could then steal from
> ;) Is there a bug? We have not rolled up to the latest driver yet.
>
> thanks,
>
> lp
>
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:3F789D08.5132DF03@ca.ibm.com...
> > Lance,
> >
> > This looks to be a DOM question. ;-)
> >
> > I'll try to have a look at it when I have some time, but it seems to me
> that the
> > code either works, or has a null pointer exception; either way, it's DOM
> that's
> > involved.
> >
> >
> > Lance Phillips wrote:
> >
> > > I'm calling XSDSchemaBuildingTools.addUserInformation on an
> > > XSDSimpleTypeDefinition passing in null for the sourceURI and some text
> for
> > > the documentation. However, when I come out of the method my newly
> created
> > > Annotation has null for the value of the documentation. In debug mode I
> get
> > > to the
> > > userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
> line
> > > and everything seems OK. I'm unable to step into the DOM code as I
> don't
> > > have source... but the resulting userInfo does NOT have my text as a
> child.
> > >
> > > Any ideas?
> > >
> > > thanks,
> > >
> > > lp
> >


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Help with XSDAnnotation [message #578994 is a reply to message #30743] Tue, 30 September 2003 14:40 Go to previous message
Lance Phillips is currently offline Lance PhillipsFriend
Messages: 210
Registered: July 2009
Senior Member
Ed,
Any plans to improve the editor? We were planning on borrowing heavily
from it for an editor we are creating.

thanks,

lp
"Ed Merks" <merks@ca.ibm.com> wrote in message
news:3F79713F.46E56CB2@ca.ibm.com...
> Lance,
>
> The editor has a number of shortcomings. It doesn't have the ability to
create
> anything within an XSDAnnotation (because those things are DOM and not EMF
> objects).
>
>
> Lance Phillips wrote:
>
> > Thanks Ed... I seem to be having problems editing Annotations in the
> > XSDEditor. I can't do anything with them in the properties panel. I
was
> > hoping to create a valid example in the editor that I could then steal
from
> > ;) Is there a bug? We have not rolled up to the latest driver yet.
> >
> > thanks,
> >
> > lp
> >
> > "Ed Merks" <merks@ca.ibm.com> wrote in message
> > news:3F789D08.5132DF03@ca.ibm.com...
> > > Lance,
> > >
> > > This looks to be a DOM question. ;-)
> > >
> > > I'll try to have a look at it when I have some time, but it seems to
me
> > that the
> > > code either works, or has a null pointer exception; either way, it's
DOM
> > that's
> > > involved.
> > >
> > >
> > > Lance Phillips wrote:
> > >
> > > > I'm calling XSDSchemaBuildingTools.addUserInformation on an
> > > > XSDSimpleTypeDefinition passing in null for the sourceURI and some
text
> > for
> > > > the documentation. However, when I come out of the method my newly
> > created
> > > > Annotation has null for the value of the documentation. In debug
mode I
> > get
> > > > to the
> > > >
userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
> > line
> > > > and everything seems OK. I'm unable to step into the DOM code as I
> > don't
> > > > have source... but the resulting userInfo does NOT have my text as a
> > child.
> > > >
> > > > Any ideas?
> > > >
> > > > thanks,
> > > >
> > > > lp
> > >
>
Re: Help with XSDAnnotation [message #579026 is a reply to message #30813] Tue, 30 September 2003 14:47 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31346
Registered: July 2009
Senior Member
Lance,

No, the editor is very low on the list of priorities. It's just meant as a full
scale example from which others can beg, borrow, and steal. ;-)


Lance Phillips wrote:

> Ed,
> Any plans to improve the editor? We were planning on borrowing heavily
> from it for an editor we are creating.
>
> thanks,
>
> lp
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:3F79713F.46E56CB2@ca.ibm.com...
> > Lance,
> >
> > The editor has a number of shortcomings. It doesn't have the ability to
> create
> > anything within an XSDAnnotation (because those things are DOM and not EMF
> > objects).
> >
> >
> > Lance Phillips wrote:
> >
> > > Thanks Ed... I seem to be having problems editing Annotations in the
> > > XSDEditor. I can't do anything with them in the properties panel. I
> was
> > > hoping to create a valid example in the editor that I could then steal
> from
> > > ;) Is there a bug? We have not rolled up to the latest driver yet.
> > >
> > > thanks,
> > >
> > > lp
> > >
> > > "Ed Merks" <merks@ca.ibm.com> wrote in message
> > > news:3F789D08.5132DF03@ca.ibm.com...
> > > > Lance,
> > > >
> > > > This looks to be a DOM question. ;-)
> > > >
> > > > I'll try to have a look at it when I have some time, but it seems to
> me
> > > that the
> > > > code either works, or has a null pointer exception; either way, it's
> DOM
> > > that's
> > > > involved.
> > > >
> > > >
> > > > Lance Phillips wrote:
> > > >
> > > > > I'm calling XSDSchemaBuildingTools.addUserInformation on an
> > > > > XSDSimpleTypeDefinition passing in null for the sourceURI and some
> text
> > > for
> > > > > the documentation. However, when I come out of the method my newly
> > > created
> > > > > Annotation has null for the value of the documentation. In debug
> mode I
> > > get
> > > > > to the
> > > > >
> userInfo.appendChild(userINfo.getOwnerDocument().createTextN ode(text))
> > > line
> > > > > and everything seems OK. I'm unable to step into the DOM code as I
> > > don't
> > > > > have source... but the resulting userInfo does NOT have my text as a
> > > child.
> > > > >
> > > > > Any ideas?
> > > > >
> > > > > thanks,
> > > > >
> > > > > lp
> > > >
> >


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Weird namespaces when moving objects between XSD schemas
Next Topic:Help with reader adapter extension
Goto Forum:
  


Current Time: Tue Aug 04 18:30:36 GMT 2020

Powered by FUDForum. Page generated in 0.02502 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top