Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » eclipse RCP Migration 3x to 4x
eclipse RCP Migration 3x to 4x [message #1615440] Fri, 13 February 2015 23:26 Go to next message
prem rai is currently offline prem raiFriend
Messages: 1
Registered: February 2015
Junior Member
I am migrating my eclipse RCP 3.4.2 application to Luna 4.2. I did below steps for that:

1. imported source code in Luna and resolve all compilation error.
2. updated plug in in plugin.xml

able to make build but when started the application getting below error:

!SESSION 2015-02-13 14:31:07.975 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_51
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product com.mywells.edf.core.RWProduct
Command-line arguments: -product com.mywells.edf.core.RWProduct -dev file:C:/Users/CANDVLPTP-1/workspace_tech_upgrade/.metadata/.plugins/org.eclipse.pde.core/NDUSA/dev.properties

!ENTRY org.eclipse.ui.workbench 4 0 2015-02-13 14:31:10.175
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.workbench [4]
Unresolved requirement: Import-Package: javax.annotation; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.mywells.edf.plugin.iadc.reviewreports 4 0 2015-02-13 14:31:10.185
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.mywells.edf.plugin.iadc.reviewreports [9]
Unresolved requirement: Require-Bundle: org.eclipse.ui
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
org.eclipse.ui [14]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [4]
Unresolved requirement: Import-Package: javax.annotation; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ui 4 0 2015-02-13 14:31:10.195
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui [14]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [4]
Unresolved requirement: Import-Package: javax.annotation; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ui.browser 4 0 2015-02-13 14:31:10.195
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.browser [78]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
org.eclipse.ui [14]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [4]
Unresolved requirement: Import-Package: javax.annotation; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.core.databinding 4 0 2015-02-13 14:31:10.205
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.core.databinding [80]
Unresolved requirement: Require-Bundle: org.eclipse.core.databinding.observable; bundle-version="[1.3.0,2.0.0)"; visibility:="reexport"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.mywells.edf.plugin.highfrequency 4 0 2015-02-13 14:31:10.215
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.mywells.edf.plugin.highfrequency [84]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="3.106.0"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
org.eclipse.ui [14]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [4]
Unresolved requirement: Import-Package: javax.annotation; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.mywells.edf.plugin.iadc.bha 4 0 2015-02-13 14:31:10.215
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.mywells.edf.plugin.iadc.bha [85]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="3.106.0"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
org.eclipse.ui [14]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [4]
Unresolved requirement: Import-Package: javax.annotation; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.mywells.edf.plugin.costcenter 4 0 2015-02-13 14:31:10.225
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.mywells.edf.plugin.costcenter [86]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="3.106.0"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
org.eclipse.ui [14]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [4]
Unresolved requirement: Import-Package: javax.annotation; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.mywells.edf.plugin.iadc.equipment 4 0 2015-02-13 14:31:10.235
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.mywells.edf.plugin.iadc.equipment [87]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="3.106.0"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.106.0.v20140812-1751"; singleton:="true"
org.eclipse.ui [14]
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.106.1.v20140827-1737"; singleton:="true"
org.eclipse.ui.workbench [4]
Unresolved requirement: Import-Package: javax.annotation; version="1.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)



Please let me know if you have some better steps for migrating 3.x to 4.x .or let me know how I can resolve this issue.
Re: eclipse RCP Migration 3x to 4x [message #1701819 is a reply to message #1615440] Thu, 16 July 2015 02:18 Go to previous message
Linh Chau is currently offline Linh ChauFriend
Messages: 2
Registered: July 2015
Junior Member
hello, did you fix this problem already?
Previous Topic:Starting Jetty server 9.3 from command line to server static content
Next Topic:Mars: How to change highlighted text color (Annotations > Occurrences not working properly)
Goto Forum:
  


Current Time: Thu Jul 18 00:55:28 GMT 2019

Powered by FUDForum. Page generated in 0.03321 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top