Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » SysML error model validation
SysML error model validation [message #1606689] Sun, 08 February 2015 10:24 Go to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
Hi,

Although I asked it before, I do not have a solution (yet).

I need a probabilistic activity diagram. I have drawn a diagram but if I
validate the model I get the following error (twice):

The required feature 'sysml::activities::Probability::base_ParameterSet'
of 'Probability' must be set

The element is: <<Probability>><Control Flow> trueEdge

Whatever I do I cannot get ride of the error. Does anyone have an idea
what the error message is trying to say?

Is there anyone who had a probabilistic activity diagram in Papyrus that
can be validated without any errors and who is willing to share it?

Attached is my Papyrus project (Luna SR1) that contains the error in a
tar.gz file. It can be imported by Eclipse without problem.

TIA

Joost


Cheers,

Joost
Re: SysML error model validation [message #1608636 is a reply to message #1606689] Mon, 09 February 2015 16:58 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi Joost,

It is a bug in the SysML profile in Papyrus. There's not much you can do about it Sad

The multiplicity of the base_X properties of the Probability stereotype are invalid. They will be fixed in Papyrus 1.1 (We'll provide a new version of the SysML profile)

Regards,
Camille


Camille Letavernier
Re: SysML error model validation [message #1616220 is a reply to message #1608636] Sat, 14 February 2015 12:07 Go to previous messageGo to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 09-02-15 17:58, Camille Letavernier wrote:
> Hi Joost,
>
> It is a bug in the SysML profile in Papyrus. There's not much you
> can do about it :(
OK thanks. Then I can stop searching ;-)


>
> The multiplicity of the base_X properties of the Probability
> stereotype are invalid. They will be fixed in Papyrus 1.1 (We'll
> provide a new version of the SysML profile)

I looked at Mars M5 and it appears that it not fixed yet. Is that correct?

TIA

Joost

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlTfOpgACgkQ0VJKUkHcX7/FVwCdH1yJ5blf7phUTZpbm+fXpikQ
2CkAoKJTRYu6+edLfngBqJJ0fPsgiKWi
=7zHv
-----END PGP SIGNATURE-----


Cheers,

Joost
Re: SysML error model validation [message #1619572 is a reply to message #1616220] Mon, 16 February 2015 17:26 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi,

Mars M5 (And Nightly builds) still ships SysML 1.1. SysML 1.4 is currently a separate plug-in, with a separate set of diagrams, and has not been promoted. However, SysML 1.4 properly fixes this issue.

Regards,
Camille


Camille Letavernier
Re: SysML error model validation [message #1620387 is a reply to message #1619572] Tue, 17 February 2015 06:35 Go to previous messageGo to next message
Joost Kraaijeveld is currently offline Joost KraaijeveldFriend
Messages: 247
Registered: July 2009
Senior Member
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 16-02-15 18:26, Camille Letavernier wrote:
> Hi,
>
> Mars M5 (And Nightly builds) still ships SysML 1.1. SysML 1.4 is
> currently a separate plug-in, with a separate set of diagrams, and
> has not been promoted. However, SysML 1.4 properly fixes this
> issue.

Is the separate plug-in available somehow? I *really* would like to
have a working probabilistic activity diagram as part of my master thesis

TIA

Joost
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlTi4TQACgkQ0VJKUkHcX79xuACeNfPF/UkVEovc+04+rBPQ6dif
690An0Um0s384y+DP/DRkB7IyHtr7ogb
=XJ6S
-----END PGP SIGNATURE-----


Cheers,

Joost
Re: SysML error model validation [message #1620951 is a reply to message #1620387] Tue, 17 February 2015 14:59 Go to previous message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi,

You can pick the SysML 1.4 plug-ins from the source repository:

http://git.eclipse.org/c/papyrus/org.eclipse.papyrus.git
git://git.eclipse.org/gitroot/papyrus/org.eclipse.papyrus.git

Note that these plug-ins are work-in-progress, and are not deployed. They may not work, they may not be compatible with your existing models. We're currently planing a complete and transparent migration from SysML 1.1 to SysML 1.4 this year, but it is not available yet.

HTH,
Camille


Camille Letavernier
Previous Topic:Requirement ID validation
Next Topic:Papyrus Plugin
Goto Forum:
  


Current Time: Sat Jul 04 06:20:47 GMT 2020

Powered by FUDForum. Page generated in 0.01985 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top