Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » remove ColorDecorator on Connection after deselection
remove ColorDecorator on Connection after deselection [message #1602442] Thu, 05 February 2015 15:12 Go to next message
Abhishek Chakraborty is currently offline Abhishek ChakrabortyFriend
Messages: 68
Registered: July 2009
Location: Cologne, Germany
Member

HI , I have a feature in which I have Nodes A B C connect to each other using two connection A --> B --> C.

I want to highlight B and C and the conections when I select A.

I have found a solution using DefaultToolBehaviorProvider , on selection of a Node, i collect all the PEs and put them into a ArrayList, and using getSelection().
and then using getDecorators(), I have created BorderDecorator for shape and colordecorator for Connections.
But when i call getDiagramTypeProvider().getDiagramBehavior().refreshRenderingDecorators(PEInstance) only the shape's borderDecorators disappears where as the colordecorators remains until the next selection of node shape.

Is there any callback method there to resolve this. and refresh the connection decorators ?



Regards,
Abhishek Chakraborty

[Updated on: Thu, 05 February 2015 15:13]

Report message to a moderator

Re: Highlight Connection which are in transient [message #1604014 is a reply to message #1602442] Fri, 06 February 2015 15:20 Go to previous messageGo to next message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1883
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Good point. I just checked the coding of refreshRenderingDecorators; it just
loops over the shapes not the connections. Would you please file a bug
against Graphiti for this?

Thanks,
Michael
Re: Highlight Connection which are in transient [message #1607140 is a reply to message #1604014] Sun, 08 February 2015 17:41 Go to previous message
Abhishek Chakraborty is currently offline Abhishek ChakrabortyFriend
Messages: 68
Registered: July 2009
Location: Cologne, Germany
Member

I have filled a bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=459386 for the same.

Regards,
Abhishek Chakraborty
Previous Topic:Add Pictorial Element inside Diagram for model EObject
Next Topic:GMF Layout Algorithm for Graphiti
Goto Forum:
  


Current Time: Wed Jan 24 12:01:52 GMT 2018

Powered by FUDForum. Page generated in 0.01728 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software