Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Add Pictorial Element inside Diagram for model EObject
Add Pictorial Element inside Diagram for model EObject [message #1597799] Mon, 02 February 2015 15:13 Go to next message
Abhishek Chakraborty is currently offline Abhishek ChakrabortyFriend
Messages: 68
Registered: July 2009
Location: Cologne, Germany
Member

I have this requirement in which I will only get the EMF model part for the Editor,
I can create the diagram file using template and add my model and initial diagram element .Then I have to create the Diagram PEs on the fly/load based on the Domain Model.

I can use the AddContext and AddFeature for specific Model but , where should I add this code, should I add it,should i override the DiagramEditor.setInput() or DiagramBehaviour.loadDiagram().


Regards,
Abhishek Chakraborty

[Updated on: Mon, 02 February 2015 15:18]

Report message to a moderator

Re: Add Pictorial Element inside Diagram for model EObject [message #1599373 is a reply to message #1597799] Tue, 03 February 2015 15:35 Go to previous messageGo to next message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1883
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Abhishek,

not sure about your complete scenario. An option could be to do this outside
the actual editor in e.g. an action you trigger to open the editor/create a
diagram.

Michael
Re: Add Pictorial Element inside Diagram for model EObject [message #1602433 is a reply to message #1599373] Thu, 05 February 2015 15:05 Go to previous message
Abhishek Chakraborty is currently offline Abhishek ChakrabortyFriend
Messages: 68
Registered: July 2009
Location: Cologne, Germany
Member

Thanks Micheal , I have found out the solution in Tutorial example , CreateDiagramWithAllClassesHandler does the same thing that I was looking for.

Regards,
Abhishek Chakraborty

[Updated on: Thu, 05 February 2015 16:31]

Report message to a moderator

Previous Topic:[Spray] Error: PackageImpl cannot be cast to org.eclipse.emf.codegen.ecore.genmodel.GenModel
Next Topic:remove ColorDecorator on Connection after deselection
Goto Forum:
  


Current Time: Thu Jan 18 12:08:01 GMT 2018

Powered by FUDForum. Page generated in 0.01643 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software