Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » java.lang.LinkageError: loader constraint violation
java.lang.LinkageError: loader constraint violation [message #1583648] Sun, 25 January 2015 09:02 Go to next message
bunny new is currently offline bunny newFriend
Messages: 3
Registered: January 2015
Junior Member
Hi
I have installed hudson3.2.1.war in weblogic 10.3.6. Everything was fine for than 1 month.
Few days back I tried to enable security in Hudson. I encountered with Internal Server Error.

So, I completely undeploy from weblogic & tried with new deployment but still I am having below error -

MESSAGE : [ServletContext@1571474132[app:hudson module:hudson.war path:/hudson spec-version:2.5]] Servlet failed with Exception
java.lang.LinkageError: loader constraint violation: when resolving field "logger" the class loader (instance of weblogic/utils/classloaders/ChangeAwareClassLoader) of the referring class, org/springframework/web/filter/GenericFilterBean, and the class loader (instance of sun/misc/Launcher$AppClassLoader) for the field's resolved type, enericFilterBean, have different Class objects for that type
at org.springframework.security.web.authentication.AnonymousAuthenticationFilter.doFilter(AnonymousAuthenticationFilter.java:101)
..


How to resolve the issue ?
Re: java.lang.LinkageError: loader constraint violation [message #1584984 is a reply to message #1583648] Mon, 26 January 2015 03:13 Go to previous messageGo to next message
Kaz Nishimura is currently offline Kaz NishimuraFriend
Messages: 89
Registered: December 2014
Member
As far as I know, redeploying Hudson without a server restart may leave previous undeployed class code on the server. Did you try to restart your application server before redeployment?

Kaz Nishimura
Re: java.lang.LinkageError: loader constraint violation [message #1585088 is a reply to message #1584984] Mon, 26 January 2015 04:38 Go to previous messageGo to next message
bunny new is currently offline bunny newFriend
Messages: 3
Registered: January 2015
Junior Member
Yes, I had also restarted the Weblogic but issue was still there. However, I able to resolve the issue by deleting .hudson folder having all setup and plugins files.

So, hudson is up now. But I tried to enable the security again and found Internal Error Again.
So again clearing the files from .hudson made it up.

I need to enable the security but everytime hudson is crashing. What could be possible solution for this?

Thanks.
Re: java.lang.LinkageError: loader constraint violation [message #1612070 is a reply to message #1585088] Wed, 11 February 2015 20:19 Go to previous message
Winston Prakash is currently offline Winston PrakashFriend
Messages: 534
Registered: August 2011
Location: Fremont, CA USA
Senior Member
This looks like issue between Spring libraries loaded by weblogic and that are included in Hudson. Spring libraries are upgraded in 3.2.*

I would highly recommend to run Hudson with its bundled Jetty server. Deploying in high end servers like weblogic does not offer any additional advantage.


Winston Prakash
Eclipse Hudson team
Previous Topic:How does Hudson know a configuration change with a cascading job?
Next Topic:NullPointerException in Hudson
Goto Forum:
  


Current Time: Sat Jun 24 16:00:37 GMT 2017

Powered by FUDForum. Page generated in 0.04550 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software