Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » BIRT » rptdesign not waiting until all datasets have been retreived(datasets)
icon8.gif  rptdesign not waiting until all datasets have been retreived [message #1562425] Tue, 13 January 2015 17:59
Dianne Young is currently offline Dianne YoungFriend
Messages: 1
Registered: January 2015
Junior Member
I have a rptdesign that uses 6 datasets (oracle procedure calls). One dataset is used by a cube and 2 charts. One of the charts filters the results. Report renders correctly while viewing in eclipse, but once it is deployed to the Birt server, the report has 2 issues. While in eclipse, the dataset is populated once and used by all three components. Once deployed, the dataset is sometimes called four to five times and second, the report is rendered before all the data is retrieved from the database.

Does anyone know how to a) specify dataset sharing to limit DB call to one and b)tell the report to WAIT until all data has been retrieved before rendering.

I am using Birt 4.3.2v20140218-1056.

Thank you

I have uploaded a newer rptdesign. Still experiencing the issue when using one account rather than multiples. One account returns much quicker on some of the DB proc calls, but the report does not WAIT to render until ALL proc results sets are in.

[Updated on: Fri, 30 January 2015 00:45]

Report message to a moderator

Previous Topic:Invalid javascript expression: dataSetRow and/or row
Next Topic:Daylight Savings Time issue in BIRT
Goto Forum:
  


Current Time: Fri Jul 19 21:22:15 GMT 2024

Powered by FUDForum. Page generated in 0.02976 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top