Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Troubles with eclipse.buildScript and versions of dependent plugins
Troubles with eclipse.buildScript and versions of dependent plugins [message #281348] Fri, 18 February 2005 23:27 Go to next message
Larry is currently offline LarryFriend
Messages: 26
Registered: July 2009
Junior Member
In 3.1.0_200409240800, I'm using this:

<?xml version="1.0" encoding="UTF-8"?>
<project name="ant" default="buildOne" basedir=".">
<property name="bootclasspath" value=""/>
<property name="basews" value="${ws}"/>
<property name="baseos" value="${os}"/>
<property name="basearch" value="${arch}"/>
<property name="basenl" value="${nl}"/>
<property name="javacFailOnError" value="true"/>
<property name="javacDebugInfo" value="on"/>
<property name="javacVerbose" value="true"/>
<property name="javacSource" value="1.4"/>
<property name="javacTarget" value="1.4"/>
<property name="compilerArg" value=""/>
<!-- advance this manually, with the manifest version -->
<target name="buildOne">
<eclipse.buildScript buildDirectory="c:/workspace/RUNTIME"
elements="plugin@RUNTIME" buildingOSGI="true"/>
</target>
</project>

to generate a build script from this:

<plugin
name = "%pluginName"
id = "runtime"
version = "1.0.0"
provider-name = "%providerName">

<requires>
<import plugin="org.eclipse.core.runtime"/>
<import plugin="org.eclipse.emf.codegen.ecore"/>
<import plugin="org.eclipse.emf.ecore"/>
<import plugin="org.eclipse.emf.ecore.edit"/>
<import plugin="org.eclipse.emf.ecore.xmi"/>
<import plugin="org.eclipse.ui"/>
<import plugin="org.eclipse.ui.ide"/>
<import plugin="org.eclipse.xsd"/>
<import plugin="org.eclipse.core.resources"/>
</requires>

<runtime>
<library name="runtime/runtime.jar">
<export name="*"/>
</library>
<library name="commons-jxpath-1.1.jar">
</library>
</runtime>

<extension point="org.eclipse.emf.ecore.generated_package">
<package
uri = "http://www..com//2005/runtime"
class = "runtime.RuntimePackage" />
</extension>

<extension point="org.eclipse.emf.ecore.generated_package">
<package
uri = "http:////runtime/adapter.ecore"
class = "runtime.adapter.AdapterPackage" />
</extension>

</plugin>

and I get this:

!ENTRY org.eclipse.pde.build 2 1 Feb 18, 2005 15:14:08.456
!MESSAGE Some inter-plug-in dependencies have not been satisfied.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.core.runtime_0.0.0.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.emf.codegen.ecore_0.0.0.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.emf.ecore_0.0.0.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.emf.ecore.edit_0.0.0.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.emf.ecore.xmi_0.0.0.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.ui_0.0.0.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.xsd_0.0.0.
!SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
!MESSAGE Missing required plug-in org.eclipse.core.resources_0.0.0.

These plugins exist in eclipse/plugins, but they have 3.x version #'s
attached.

Question: where is it getting 0.0.0? How do I get past this?
Re: Troubles with eclipse.buildScript and versions of dependent plugins [message #281501 is a reply to message #281348] Mon, 21 February 2005 00:58 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: pascal.ibm.canada

To use this mechanism makes sure your plugins are in a plugins folder
and features in a feature folder.

Larry Stevens wrote:
> In 3.1.0_200409240800, I'm using this:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <project name="ant" default="buildOne" basedir=".">
> <property name="bootclasspath" value=""/>
> <property name="basews" value="${ws}"/>
> <property name="baseos" value="${os}"/>
> <property name="basearch" value="${arch}"/>
> <property name="basenl" value="${nl}"/>
> <property name="javacFailOnError" value="true"/>
> <property name="javacDebugInfo" value="on"/>
> <property name="javacVerbose" value="true"/>
> <property name="javacSource" value="1.4"/>
> <property name="javacTarget" value="1.4"/>
> <property name="compilerArg" value=""/>
> <!-- advance this manually, with the manifest version -->
> <target name="buildOne">
> <eclipse.buildScript buildDirectory="c:/workspace/RUNTIME"
> elements="plugin@RUNTIME" buildingOSGI="true"/>
> </target>
> </project>
>
> to generate a build script from this:
>
> <plugin
> name = "%pluginName"
> id = "runtime"
> version = "1.0.0"
> provider-name = "%providerName">
>
> <requires>
> <import plugin="org.eclipse.core.runtime"/>
> <import plugin="org.eclipse.emf.codegen.ecore"/>
> <import plugin="org.eclipse.emf.ecore"/>
> <import plugin="org.eclipse.emf.ecore.edit"/>
> <import plugin="org.eclipse.emf.ecore.xmi"/>
> <import plugin="org.eclipse.ui"/>
> <import plugin="org.eclipse.ui.ide"/>
> <import plugin="org.eclipse.xsd"/>
> <import plugin="org.eclipse.core.resources"/>
> </requires>
>
> <runtime>
> <library name="runtime/runtime.jar">
> <export name="*"/>
> </library>
> <library name="commons-jxpath-1.1.jar">
> </library>
> </runtime>
>
> <extension point="org.eclipse.emf.ecore.generated_package">
> <package uri = "http://www..com//2005/runtime" class =
> "runtime.RuntimePackage" />
> </extension>
>
> <extension point="org.eclipse.emf.ecore.generated_package">
> <package uri = "http:////runtime/adapter.ecore" class =
> "runtime.adapter.AdapterPackage" />
> </extension>
>
> </plugin>
>
> and I get this:
>
> !ENTRY org.eclipse.pde.build 2 1 Feb 18, 2005 15:14:08.456
> !MESSAGE Some inter-plug-in dependencies have not been satisfied.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.core.runtime_0.0.0.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.emf.codegen.ecore_0.0.0.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.emf.ecore_0.0.0.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.emf.ecore.edit_0.0.0.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.emf.ecore.xmi_0.0.0.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.ui_0.0.0.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.ui.ide_0.0.0.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.xsd_0.0.0.
> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
> !MESSAGE Missing required plug-in org.eclipse.core.resources_0.0.0.
>
> These plugins exist in eclipse/plugins, but they have 3.x version #'s
> attached.
>
> Question: where is it getting 0.0.0? How do I get past this?
>
Re: Troubles with eclipse.buildScript and versions of dependent plugins [message #281543 is a reply to message #281501] Mon, 21 February 2005 16:57 Go to previous messageGo to next message
Larry is currently offline LarryFriend
Messages: 26
Registered: July 2009
Junior Member
Thanks for responding.

The required plugins are in c:\eclipse\plugins (with the 3.x version
suffixes. RUNTIME is a plugin project for which I am trying to generate a
build script. Are you saying that I need to put the RUNTIME project files
in a plugins directory?

Pascal Rapicault wrote:

> To use this mechanism makes sure your plugins are in a plugins folder
> and features in a feature folder.

> Larry Stevens wrote:
>> In 3.1.0_200409240800, I'm using this:
>>
>> <?xml version="1.0" encoding="UTF-8"?>
>> <project name="ant" default="buildOne" basedir=".">
>> <property name="bootclasspath" value=""/>
>> <property name="basews" value="${ws}"/>
>> <property name="baseos" value="${os}"/>
>> <property name="basearch" value="${arch}"/>
>> <property name="basenl" value="${nl}"/>
>> <property name="javacFailOnError" value="true"/>
>> <property name="javacDebugInfo" value="on"/>
>> <property name="javacVerbose" value="true"/>
>> <property name="javacSource" value="1.4"/>
>> <property name="javacTarget" value="1.4"/>
>> <property name="compilerArg" value=""/>
>> <!-- advance this manually, with the manifest version -->
>> <target name="buildOne">
>> <eclipse.buildScript buildDirectory="c:/workspace/RUNTIME"
>> elements="plugin@RUNTIME" buildingOSGI="true"/>
>> </target>
>> </project>
>>
>> to generate a build script from this:
>>
>> <plugin
>> name = "%pluginName"
>> id = "runtime"
>> version = "1.0.0"
>> provider-name = "%providerName">
>>
>> <requires>
>> <import plugin="org.eclipse.core.runtime"/>
>> <import plugin="org.eclipse.emf.codegen.ecore"/>
>> <import plugin="org.eclipse.emf.ecore"/>
>> <import plugin="org.eclipse.emf.ecore.edit"/>
>> <import plugin="org.eclipse.emf.ecore.xmi"/>
>> <import plugin="org.eclipse.ui"/>
>> <import plugin="org.eclipse.ui.ide"/>
>> <import plugin="org.eclipse.xsd"/>
>> <import plugin="org.eclipse.core.resources"/>
>> </requires>
>>
>> <runtime>
>> <library name="runtime/runtime.jar">
>> <export name="*"/>
>> </library>
>> <library name="commons-jxpath-1.1.jar">
>> </library>
>> </runtime>
>>
>> <extension point="org.eclipse.emf.ecore.generated_package">
>> <package uri = "http://www..com//2005/runtime" class =
>> "runtime.RuntimePackage" />
>> </extension>
>>
>> <extension point="org.eclipse.emf.ecore.generated_package">
>> <package uri = "http:////runtime/adapter.ecore" class =
>> "runtime.adapter.AdapterPackage" />
>> </extension>
>>
>> </plugin>
>>
>> and I get this:
>>
>> !ENTRY org.eclipse.pde.build 2 1 Feb 18, 2005 15:14:08.456
>> !MESSAGE Some inter-plug-in dependencies have not been satisfied.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.core.runtime_0.0.0.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.emf.codegen.ecore_0.0.0.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.emf.ecore_0.0.0.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.emf.ecore.edit_0.0.0.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.emf.ecore.xmi_0.0.0.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.ui_0.0.0.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.ui.ide_0.0.0.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.xsd_0.0.0.
>> !SUBENTRY 1 RUNTIME 2 2 Feb 18, 2005 15:14:08.456
>> !MESSAGE Missing required plug-in org.eclipse.core.resources_0.0.0.
>>
>> These plugins exist in eclipse/plugins, but they have 3.x version #'s
>> attached.
>>
>> Question: where is it getting 0.0.0? How do I get past this?
>>
Re: Troubles with eclipse.buildScript and versions of dependent plugins [message #1783583 is a reply to message #281543] Wed, 14 March 2018 11:36 Go to previous messageGo to next message
Shivendra Prakash Shukla is currently offline Shivendra Prakash ShuklaFriend
Messages: 4
Registered: January 2018
Junior Member
I am also getting the same issue, but I make sure my plugins are in a plugins folder and features in a feature folder.

[java] [eclipse.buildScript] Bundle org.eclipse.emf.codegen.ecore.ui:
[java] [eclipse.buildScript] Missing required plug-in org.eclipse.emf.codegen.ecore_[2.14.0,3.0.0).
[java] [eclipse.buildScript] Bundle org.eclipse.emf.common.ui:
[java] [eclipse.buildScript] Another singleton version selected: org.eclipse.emf.common.ui_2.13.0.v20171102-0636

Re: Troubles with eclipse.buildScript and versions of dependent plugins [message #1783587 is a reply to message #1783583] Wed, 14 March 2018 12:06 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29653
Registered: July 2009
Senior Member
This thread is very very old. No one at Eclipse uses PDE build anymore. Better use to Tycho to do production builds. Likely you've installed using the installer and this script is pointing into the bundle pool where there are likely by now many versions of each bundle.
Re: Troubles with eclipse.buildScript and versions of dependent plugins [message #1783631 is a reply to message #1783587] Wed, 14 March 2018 17:28 Go to previous messageGo to next message
Shivendra Prakash Shukla is currently offline Shivendra Prakash ShuklaFriend
Messages: 4
Registered: January 2018
Junior Member
Hi Ed,

Yes, I understand it's very old post, This type issue I am facing eclipse 4.7.2 and I verified all plugins are available, but still, i am facing this issue. Please give some suggestion. Thanks in Advance...
Re: Troubles with eclipse.buildScript and versions of dependent plugins [message #1783650 is a reply to message #1783631] Thu, 15 March 2018 05:34 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29653
Registered: July 2009
Senior Member
I'd suggest not trying to use Ant to do your build. This is Eclipse projects generally do builds: https://wiki.eclipse.org/CBI You could look at how EMF itself has such a build: https://ci.eclipse.org/emf/ and can reproduce that build locally, as described on that page, to try to apply the same concepts to your project.
Previous Topic:Fuzzy letters, small icons
Next Topic:Getting java.lang.RuntimeException: No application id has been found. on running product file
Goto Forum:
  


Current Time: Mon Nov 19 04:54:51 GMT 2018

Powered by FUDForum. Page generated in 0.03914 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top