Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed
ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1524860] Tue, 23 December 2014 18:14 Go to next message
Juan Cadavid is currently offline Juan CadavidFriend
Messages: 59
Registered: July 2009
Location: Paris, France
Member

Hello, I'm trying to use Oomph to set up a dev environment for the Papyrus project, but I get the following error:
[12:39:25] ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:217)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$1.commit(ProfileTransactionImpl.java:438)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:311)
  at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:692)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2585)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2541)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2531)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2461)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:532)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:620)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
  ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__Users_jc236769_OomphRoot_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.rcp.configuration_root.win32.win32.x86_64 1.0.100.v20141210-1822, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.ChmodAction).
  ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed - file C:\Users\jc236769\OomphRoot\eclipse\eclipse.exe does not exist

[12:39:25] ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:217)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$1.commit(ProfileTransactionImpl.java:438)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:311)
  at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:692)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2585)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2541)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2531)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2461)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:532)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:620)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
  ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__Users_jc236769_OomphRoot_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.rcp.configuration_root.win32.win32.x86_64 1.0.100.v20141210-1822, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.ChmodAction).
  ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed - file C:\Users\jc236769\OomphRoot\eclipse\eclipse.exe does not exist

[12:39:25] Took 41 seconds.
[12:39:25] There are failed tasks.
[12:39:25] Press Back to choose different settings or Cancel to abort.


Well, Knowing that I'm on Windows it's akwkard to see it trying to perform a chmod Smile. I'm using build 719.

Any ideas? Thanks !
Re: ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1524899 is a reply to message #1524860] Tue, 23 December 2014 18:42 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6394
Registered: July 2009
Senior Member
Hi Juan,

I've just set up a Papyrus environment myself on Windows and had absolutely no problems. Have you checked that the file
C:\Users\jc236769\OomphRoot\eclipse\eclipse.exe does exist?

I'm already packing for my christmas travel so it might take a couple days until I can try to analyze your problem.
Merry christmas to you and

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Am 23.12.2014 um 19:14 schrieb Juan Cadavid:
> Hello, I'm trying to use Oomph to set up a dev environment for the Papyrus project, but I get the following error:
> [12:39:25] ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
> at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:217)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$1.commit(ProfileTransactionImpl.java:438)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:311)
> at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:692)
> at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2585)
> at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2541)
> at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2531)
> at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2461)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:532)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:620)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
> ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__Users_jc236769_OomphRoot_eclipse,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null -->
> [R]org.eclipse.rcp.configuration_root.win32.win32.x86_64 1.0.100.v20141210-1822,
> action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.ChmodAction).
> ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed - file
> C:\Users\jc236769\OomphRoot\eclipse\eclipse.exe does not exist
>
> [12:39:25] ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
> at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:217)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$1.commit(ProfileTransactionImpl.java:438)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:311)
> at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:692)
> at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:2585)
> at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2541)
> at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2531)
> at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2461)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:532)
> at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:620)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
> ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__Users_jc236769_OomphRoot_eclipse,
> phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null -->
> [R]org.eclipse.rcp.configuration_root.win32.win32.x86_64 1.0.100.v20141210-1822,
> action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.ChmodAction).
> ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed - file
> C:\Users\jc236769\OomphRoot\eclipse\eclipse.exe does not exist
>
> [12:39:25] Took 41 seconds.
> [12:39:25] There are failed tasks.
> [12:39:25] Press Back to choose different settings or Cancel to abort.
>
>
> Well, Knowing that I'm on Windows it's akwkard to see it trying to perform a chmod :). I'm using build 719.
>
> Any ideas? Thanks !
Re: ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1528299 is a reply to message #1524899] Thu, 25 December 2014 17:14 Go to previous messageGo to next message
Juan Cadavid is currently offline Juan CadavidFriend
Messages: 59
Registered: July 2009
Location: Paris, France
Member

Hi Eike,

Err, well this is even more akwkard. You're right, I left my user.dir variable unchanged when copying my user.setup from another machine.
Thanks and sorry I wasted some precious packing up time!

Enjoy your holidays!

Juan
Re: ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1600566 is a reply to message #1524860] Wed, 04 February 2015 10:22 Go to previous messageGo to next message
Johan Hardy is currently offline Johan HardyFriend
Messages: 47
Registered: December 2012
Member

I often have this problem too when performing setup task (update) ... A bit annoying !

[Updated on: Wed, 04 February 2015 10:23]

Report message to a moderator

Re: ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1600570 is a reply to message #1600566] Wed, 04 February 2015 10:25 Go to previous messageGo to next message
Juan Cadavid is currently offline Juan CadavidFriend
Messages: 59
Registered: July 2009
Location: Paris, France
Member

True. Maybe a validation rule that is missing in Oomph after prompting for user.dir?
Re: ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed [message #1791696 is a reply to message #1524860] Wed, 04 July 2018 09:56 Go to previous message
Ladislav Jech is currently offline Ladislav JechFriend
Messages: 1
Registered: July 2018
Junior Member
This happened to me as well and the reason was my drive was full :-)
Previous Topic:Basic Setup still Accessing outside world
Next Topic:headless oomph?
Goto Forum:
  


Current Time: Mon Sep 24 16:24:48 GMT 2018

Powered by FUDForum. Page generated in 0.05042 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top