Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Errors on creation diagram editor (Eclipse Luna 4.4.1)(Some classes wasn't generated)
icon4.gif  Errors on creation diagram editor (Eclipse Luna 4.4.1) [message #1513593] Tue, 16 December 2014 17:25 Go to next message
Rom A is currently offline Rom AFriend
Messages: 3
Registered: December 2012
Junior Member
I tried to follow some tutorials like

gmfsamples.tuxfamily.org - gmf_tutorial7

(gmfsamples.tuxfamily.org/wiki/doku.php?id=gmf_tutorial7)

in order to create diagramm editor on Eclipse Luna 4.4.1.

But the last step: "generate diagram editor" was done multiple times with the same errors:

1)Many exceptions were in the dialog, which was open during generation
All of them like Exception (Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18) while generating code Boolean expected (was: org.eclipse.ocl.ecore.internal.OCLStandardLibraryImpl$1)!:in CodeStyle, line 18

2)Generated diagram editor plugin was without manifest file and also without dependencies. I manually added dependencies

3) The last type of problems were because not all code was generated, some classes referenced to another which wasn't generated at all: jfb.examples.gmf.school.model.diagram.edit.policies.ClassroomClassroomStudentsCompartmentCanonicalEditPolicy; jfb.examples.gmf.school.model.diagram.part.SchoolVisualIDRegistry; jfb.examples.gmf.school.model.diagram.providers.SchoolElementTypes; jfb.examples.gmf.school.model.diagram.edit.policies.ClassroomItemSemanticEditPolicy; jfb.examples.gmf.school.model.diagram.part.SchoolVisualIDRegistry;

and so on.

I tried to do many GMF tutorials on Eclipse Luna but result was the same.
It looks like GMF couldn't create diagram editor on Luna at all.

[Updated on: Tue, 16 December 2014 17:25]

Report message to a moderator

Re: Errors on creation diagram editor (Eclipse Luna 4.4.1) [message #1517327 is a reply to message #1513593] Fri, 19 December 2014 12:21 Go to previous messageGo to next message
Nikos Margaritis is currently offline Nikos MargaritisFriend
Messages: 65
Registered: September 2014
Member

Hello there,

Probably the tutorials that you are using are not up to date. Apart from that, it would be a good idea to attach a minimal example of this project that reproduces the error so as for anyone interested to look into it and reply.

Considering that no example is given, I would point out some general tips:

- Put much effort in to the Ecore model, because most of the times the errors are originated from there.
- Take a look into Eugenia Epsilon(Eclipse) in order to get started because starting with GMF, and working through the dashboard might not be an easy task for beginners.
- Follow this tutorial https://www.eclipse.org/epsilon/doc/articles/eugenia-gmf-tutorial/ of EuGenia and then try to create the same in GMF; after you have understood the concept of how the Ecore should be modeled.
Re: Errors on creation diagram editor (Eclipse Luna 4.4.1) [message #1708776 is a reply to message #1513593] Mon, 21 September 2015 03:06 Go to previous message
Yi Wang is currently offline Yi WangFriend
Messages: 1
Registered: September 2015
Junior Member
Hello,

I have encounter same issues with you. That's very noise.
By the way ,could you please share you solutions for this.
Have you install other version for eclipse to solve it?
Thanks very much.

Best Regards
Ivan
Previous Topic:Failed to create part's control - Eclipse GMF
Next Topic:Create UMLDiagramEditor without opening it (like in OffscreenEditPartFactory)
Goto Forum:
  


Current Time: Mon Oct 23 01:03:17 GMT 2017

Powered by FUDForum. Page generated in 0.02646 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software