Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » MARTE profile in Papyrus(Unable to install MARTE profile in Payrus under Eclipse Luna package)
MARTE profile in Papyrus [message #1511747] Mon, 15 December 2014 06:09 Go to next message
Abhijit Deshpande is currently offline Abhijit DeshpandeFriend
Messages: 11
Registered: December 2014
Junior Member
I installed Eclipse modeling tools Luna package and then installed Papyrus. But, it seems that default Papyrus does not include MARTE profile. And, when I tried to install MARTE using "Install Papyrus Additional Components", it does list out "MARTE" under "UML Language Extensions"; but does not allow me to install the same. I get the message that "Sorry, MARTE is unavailable. Please try again later". Can someone provide me pointers regarding how to install MARTE support in Payrus in Eclipse Luna.

In addition to MARTE, I am also looking for installing "Moka"; which I believe is a module for model execution. And, even for "Moka", I get the same message that "Sorry, Moka (Incubation) is unavailable. Please try again later"
Re: MARTE profile in Papyrus [message #1512250 is a reply to message #1511747] Mon, 15 December 2014 15:44 Go to previous messageGo to next message
Remi Schnekenburger is currently offline Remi SchnekenburgerFriend
Messages: 167
Registered: July 2009
Location: Palaiseau, France
Senior Member
Hi,

thank you for your interest in Papyrus tool and extras. We have noticed the same issue for the extra components from the discovery interface. We are currently fixing the issue (see bug 455232 https://bugs.eclipse.org/bugs/show_bug.cgi?id=455232)

Issue should be fixed on luna nightly. We will propose an intermediate release between official SR1 and SR2, named SR1a, probably at the end of this week. It should contain the fix for the discovery site.

Regards,
Rémi


Remi Schnekenburger

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: MARTE profile in Papyrus [message #1512917 is a reply to message #1512250] Tue, 16 December 2014 04:39 Go to previous messageGo to next message
Abhijit Deshpande is currently offline Abhijit DeshpandeFriend
Messages: 11
Registered: December 2014
Junior Member
Hi Rémi,

Thanks a lot for the quick response. I will wait for the SR1a release to get this issue fixed. In the mean-time, I am wondering if there is any work-around possible to install MARTE profile and Moka module? Like downloading these packages separately and dropping those under plugins directory in eclipse installation? Any pointers in this direction are appreciated.

Thanks,
Abhijit Deshpande

[Updated on: Tue, 16 December 2014 04:40]

Report message to a moderator

Re: MARTE profile in Papyrus [message #1513069 is a reply to message #1512917] Tue, 16 December 2014 07:38 Go to previous messageGo to next message
Remi Schnekenburger is currently offline Remi SchnekenburgerFriend
Messages: 167
Registered: July 2009
Location: Palaiseau, France
Senior Member
Hi,

you can use the extra update sites. they are located here: http://download.eclipse.org/modeling/mdt/papyrus/updates/nightly/luna/

There, you will find instructions to install them separately. Be sure you deselect "group by category" when you try to install Moka or MARTE, otherwise you only have "extras" or "UML" available, and that will install much thing for you. If you deselect "group by categories", you will have access to each extra one by one.

Regards
Rémi


Remi Schnekenburger

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: MARTE profile in Papyrus [message #1786330 is a reply to message #1511747] Tue, 01 May 2018 12:00 Go to previous message
Nissaf Fredj is currently offline Nissaf FredjFriend
Messages: 2
Registered: May 2018
Junior Member
Hello,
I m new with papyrus eclipse and I want to update the papyrus.
First i installed the latest version of eclipse-modeling-neon-3-win32-x86_64.
Then, I want to update the papyrus by:
-help
-install new software
- enter the site :"http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/neon"
and I select all.
The installation does not complete and a big set of errors has been appearing:
No repository found containing: osgi.bundle,org.eclipse.rmf.reqif10.xhtml,0.13.0.201509161042

The list of errors is shown by the attached file.

Can someone helps me please.
  • Attachment: error.jpg
    (Size: 221.81KB, Downloaded 25 times)
Previous Topic:Moka and SysML
Next Topic:Sequence Diagram and Combined Fragment
Goto Forum:
  


Current Time: Fri Nov 16 23:16:40 GMT 2018

Powered by FUDForum. Page generated in 0.01596 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top