Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » B3 » ppc64le not valid in latest b3 aggregator download
ppc64le not valid in latest b3 aggregator download [message #1505096] Tue, 09 December 2014 20:50 Go to next message
Jeff Johnston is currently offline Jeff JohnstonFriend
Messages: 206
Registered: July 2009
Senior Member
I am trying to use the b3 aggregator to work on the org.eclipse.simrel.build aggregation for the Mars release. I have downloaded the most recent version noted in the downloads section of the b3 aggregator project (4.3) to my Eclipse Luna. When I try and open the simrel.b3aggr file for the project, the editor fails because it cannot handle ppc64le as a configuration platform. If I comment out the one line, it works fine.

I noticed a git commit about 6 months ago which adds ppc64le as a valid platform. Is there somewhere I can download a version that has that fix in it? Would it be possible for somebody to update the download site to add a new version to download with the fix or is there a workaround I can use other than editing the file which I might inadvertently check in?
Re: ppc64le not valid in latest b3 aggregator download [message #1508954 is a reply to message #1505096] Fri, 12 December 2014 21:37 Go to previous messageGo to next message
David Williams is currently offline David WilliamsFriend
Messages: 722
Registered: July 2009
Senior Member
On 12/09/2014 03:50 PM, Jeff Johnston wrote:
> I am trying to use the b3 aggregator to work on the
> org.eclipse.simrel.build aggregation for the Mars release. I have
> downloaded the most recent version noted in the downloads section of
> the b3 aggregator project (4.3) to my Eclipse Luna. When I try and
> open the simrel.b3aggr file for the project, the editor fails because
> it cannot handle ppc64le as a configuration platform. If I comment
> out the one line, it works fine.
>
> I noticed a git commit about 6 months ago which adds ppc64le as a
> valid platform. Is there somewhere I can download a version that has
> that fix in it? Would it be possible for somebody to update the
> download site to add a new version to download with the fix or is
> there a workaround I can use other than editing the file which I might
> inadvertently check in?

http://download.eclipse.org/modeling/emft/b3/updates-4.4/

works for me, which is the software repository listed in

https://wiki.eclipse.org/Simrel/Contributing_to_Simrel_Aggregation_Build#Install_the_b3_Aggregator

What site did you use? Did you see another site documented somewhere
that should be changed?
Re: ppc64le not valid in latest b3 aggregator download [message #1513748 is a reply to message #1508954] Tue, 16 December 2014 20:19 Go to previous messageGo to next message
Jeff Johnston is currently offline Jeff JohnstonFriend
Messages: 206
Registered: July 2009
Senior Member
I googled b3 aggregator download and found:

https://www.eclipse.org/b3/download/

which has:

http://download.eclipse.org/modeling/emft/b3/updates-4.3

as the most current recommended version to download and does not mention 4.4.
Re: ppc64le not valid in latest b3 aggregator download [message #1515692 is a reply to message #1513748] Thu, 18 December 2014 09:33 Go to previous message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3240
Registered: July 2009
Senior Member
On 2014-12-16 21:19, Jeff Johnston wrote:
> I googled b3 aggregator download and found:
>
> https://www.eclipse.org/b3/download/
>
> which has:
>
> http://download.eclipse.org/modeling/emft/b3/updates-4.3
>
> as the most current recommended version to download and does not mention 4.4.

It does now. Thanks for reporting.

- thomas
Previous Topic:four part versions?
Next Topic:B3 doesn't use the general eclipse proxy settings ?
Goto Forum:
  


Current Time: Fri Sep 21 17:36:25 GMT 2018

Powered by FUDForum. Page generated in 0.02259 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top