Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Model-to-Model Transformation » Empty target model and the console showed no errors(Empty target model and the console showed no errors)
Empty target model and the console showed no errors [message #1496081] Tue, 02 December 2014 19:20
taghreed altamimi is currently offline taghreed altamimiFriend
Messages: 172
Registered: October 2014
Senior Member
I am doing model transformation from sequence diagram to communication diagram the mapping is one to one ,each time I run the rules (sd2comd.atl) I got empty target file it seems that there is an exception but I don't know why because I tried to run the debug but it didn't work at all even I tried to run one rule only and I got empty target file.

I have attached the ecore files

source model sd.ecore this is for sequence diagram
target model commdiagram.ecore this for communication diagram

sd2comd.atl the rules

mytest2.sd is an example(instance ) of the source model which is sequence diagram.

please help me .
  • Attachment: sd.ecore
    (Size: 3.52KB, Downloaded 86 times)
  • Attachment: commdiagram.ecore
    (Size: 3.15KB, Downloaded 79 times)
  • Attachment: Mytest2.sd
    (Size: 1.15KB, Downloaded 78 times)
  • Attachment: sd2comd.atl
    (Size: 1.70KB, Downloaded 73 times)
Previous Topic:Empty target model
Next Topic:many to one mapping
Goto Forum:
  


Current Time: Tue Feb 20 22:05:25 GMT 2018

Powered by FUDForum. Page generated in 0.01677 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software