Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Editor Shortcuts not working anymore in Luna(migration: Kepler->Luna)
Editor Shortcuts not working anymore in Luna [message #1490595] Fri, 28 November 2014 09:17 Go to next message
Sumit Singh is currently offline Sumit SinghFriend
Messages: 141
Registered: October 2012
Location: Bangalore
Senior Member

I have one RCP application in Kepler based on compatibility layer.

I'm re-using Javascript perspective.
After migrating to Luna, i'm facing following problem.

If you run RCP without -clearPersetstate option then in JavaScript perspective, CTRL+A, CTRL+Z, CTRL+Y.. etc is not working.

If you clear the state then its working.


If i open workbench.xmi there is no entry for CTRL+A, CTRL+Z, CTRL+Y.. etc. In kepler everything was working fine.
Re: Editor Shortcuts not working anymore in Luna [message #1498191 is a reply to message #1490595] Thu, 04 December 2014 08:33 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Have you retested this with the original JavaScript Tooling, meaning
without your RCP app?

Best regards

Jonas

Am 28.11.2014 10:17, schrieb sumit singh:
> I have one RCP application in Kepler based on compatibility layer.
>
> I'm re-using Javascript perspective.
> After migrating to Luna, i'm facing following problem.
>
> If you run RCP without -clearPersetstate option then in JavaScript
> perspective, CTRL+A, CTRL+Z, CTRL+Y.. etc is not working.
>
> If you clear the state then its working.
>
>
> If i open workbench.xmi there is no entry for CTRL+A, CTRL+Z, CTRL+Y..
> etc. In kepler everything was working fine.


--
Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Editor Shortcuts not working anymore in Luna [message #1503289 is a reply to message #1498191] Mon, 08 December 2014 10:25 Go to previous messageGo to next message
Sumit Singh is currently offline Sumit SinghFriend
Messages: 141
Registered: October 2012
Location: Bangalore
Senior Member

I think the problem is not specific to JavaScript, I tried it with creating one e4 RCP application and tried to use Select All (Ctrl+A) its worked fist time but same behaviour later on, if you run it without clean.
Re: Editor Shortcuts not working anymore in Luna [message #1503294 is a reply to message #1503289] Mon, 08 December 2014 10:30 Go to previous message
Sumit Singh is currently offline Sumit SinghFriend
Messages: 141
Registered: October 2012
Location: Bangalore
Senior Member

I found one workaround for this:

Created one more fragment.e4xmi with alway merge option in extension point.
Then contribute Shortcut using existing eclipse command (Ex: for Select All -> CTRL+A).
Now its worked.

Previous Topic:Command with parameters and DI ?
Next Topic:EventAdmin is null in EventBroker if run Junit test using maven in Luna
Goto Forum:
  


Current Time: Wed Jan 20 03:20:05 GMT 2021

Powered by FUDForum. Page generated in 0.02453 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top