Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Hotkeys doing strange things for me in Luna!(Doesnt work like it used to in previous versions, like QuickFix (CTRL-1))
Hotkeys doing strange things for me in Luna! [message #1479698] Wed, 19 November 2014 17:01 Go to next message
Simon L. is currently offline Simon L.Friend
Messages: 2
Registered: July 2009
Junior Member
Hi,

To date I was using an older version of Eclipse, and now I've upgraded. I always particularly liked the QuickFix function of Eclipse when working with Java, and I use the Shortcut "CTRL-ALT-SPACE" rather than the default "CTRL-1" shortcut for the Quick Fix function.

But it seems now, both are broken. This is a MAJOR grievance to me.

When I press the shortcuts I grew accustomed to, the following happens:

"CTRL-1": a popup appears in the lower right corner showing the shortcut and if I press Enter, it opens the quick fix. But this is not quick! Alone to display the shortcut, it needs just short of 1sec. >_>

index.php/fa/19945/0/

When I press "CTRL-ALT-SPACE" (I configured this as an alternative to the CTRL-1-Shortcut), a strange greenish box appears.

index.php/fa/19946/0/

In both cases, no instructions WHAT this new crap is, or how to get rid of it.

Can you PLEASE help me out? I just want to access QuickFix in a way that is quick and not totally irritating.

Really thanks, it saves me a lot of time and nerves =)
  • Attachment: 1.png
    (Size: 54.56KB, Downloaded 537 times)
  • Attachment: 2.png
    (Size: 58.16KB, Downloaded 468 times)
Re: Hotkeys doing strange things for me in Luna! [message #1481887 is a reply to message #1479698] Fri, 21 November 2014 09:54 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3254
Registered: July 2009
Senior Member

You seem to have added Ctrl+Alt+Space to the Quick Fix key binding, making it a sequence, rather than just replacing the default Ctrl+1.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Fri, 21 November 2014 09:55]

Report message to a moderator

Re: Hotkeys doing strange things for me in Luna! [message #1482232 is a reply to message #1481887] Fri, 21 November 2014 15:57 Go to previous message
Simon L. is currently offline Simon L.Friend
Messages: 2
Registered: July 2009
Junior Member
I don't think that's the issue. I have reset Ctrl-1 to be the only shortcut for Quick Fix. Now it does nothing at all but display "no matches" at the lower right corner:

I just want my quick fix back, please, please, please! Mad Sad Sad Sad Sad
You know, that auto-completion-style popup right next to the code which has things like "assign to new field", "convert to index-based for-loop", "extract method" and other nice magic-like life-enhancers! You MUST know this thing if you've ever achieved somewhat-happiness while programming java!

index.php/fa/19977/0/

When I use the menu though, it works! Mad Mad

index.php/fa/19979/0/
If I click, this appears (like it should with Ctrl-1, which doesn't work!!)
index.php/fa/19980/0/

The Problem is, I can't seem to make it work using different hotkeys. It just always tries to display this shitty-ass retarded popup in the lower right corner which needs like a second to show up, which steals the focus from the main eclipse shell and I also have to escape it with the ESC key or I can't continue to type. Please tell me this isn't news to y'all! Someone must have encountered this before or my faith in Eclipse QA is thoroughly shattered.

Please help!! Please!
  • Attachment: 1.png
    (Size: 65.24KB, Downloaded 85 times)
  • Attachment: 2.png
    (Size: 39.94KB, Downloaded 438 times)
  • Attachment: 3.png
    (Size: 24.08KB, Downloaded 412 times)
  • Attachment: 4.png
    (Size: 15.61KB, Downloaded 430 times)

[Updated on: Fri, 21 November 2014 16:18]

Report message to a moderator

Previous Topic:Open CustomSearch Page Tab within Default Eclipse Search Page
Next Topic:Tooltip description (F2) size
Goto Forum:
  


Current Time: Tue Sep 25 23:36:08 GMT 2018

Powered by FUDForum. Page generated in 0.03103 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top