Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot update Eclipse: "Cannot find a solution ..."
Cannot update Eclipse: "Cannot find a solution ..." [message #265456] Mon, 13 October 2008 14:59 Go to next message
Eclipse UserFriend
Originally posted by: jeffreyz.q-free.com

I am at my wits end. There seems to be a major problem with Eclipse's
built-in update mechanism, or possibly the Eclipse update sites or both
or ...

No matter what I try, it is not possible to update Eclipse. Whenever I
try to run an update I get an error like the following:


Cannot complete the request. See the details.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.1.v3449c,3.4. 1.v3449c]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.1.v3449c,3.4.1.v3449c]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.1 00.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341,3.4.100.r341_ v20080814-989JESIEdAciFYfkZZsBfSwQ2341]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.0.I2 0080606-1300,3.4.0.I20080606-1300]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.1.M2 0080827-0800a,3.4.1.M20080827-0800a]]
can be satisfied.

< Many lines snipped out >


I have the "Eclipse IDE for Java EE Developers" version installed, and
the only other plug-in I have installed is PyDev 1.3.22 (the latest).

I have tried re-installing Eclipse and starting with a fresh, empty
workspace, but after I perform a single update, all subsequent updates
fail with errors of the form I listed above.

I am running:

Eclipse 3.4.1
Windows XP sp3 (but have encountered same problem on Mac OS X at home)

I have seen references to similar (virtually identical) problems that
others have reported, but I have never seen an explanation or work-around.

Surely someone else must have encountered this problem as well? Has the
new p2 update system simply imploded and is unable to function any longer?

Any help would be *very* appreciated.

Jeff
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265476 is a reply to message #265456] Tue, 14 October 2008 08:39 Go to previous messageGo to next message
Owen Rees is currently offline Owen ReesFriend
Messages: 41
Registered: July 2009
Member
Jeffrey Zelt <jeffreyz@q-free.com> writes:

> I am running:
>
> Eclipse 3.4.1
> Windows XP sp3 (but have encountered same problem on Mac OS X at home)

Are you usuing a web proxy and if so does it have a cache? I have
found that that causes a lot of trouble with update. I have not seen
the specific problem you report, but I would not be surprised to get
errors related to not finding things if update is operating on
partially stale and inconsistent data about what is available from the
various sites it is using.

--
Owen Rees; speaking personally, and not on behalf of HP.
========================================================
Hewlett-Packard Limited. Registered No: 690597 England
Registered Office: Cain Road, Bracknell, Berks RG12 1HN
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265482 is a reply to message #265456] Tue, 14 October 2008 12:07 Go to previous messageGo to next message
Mikael Steen is currently offline Mikael SteenFriend
Messages: 7
Registered: July 2009
Junior Member
Jeffrey Zelt wrote:
> I am at my wits end. There seems to be a major problem with Eclipse's
> built-in update mechanism, or possibly the Eclipse update sites or both
> or ...
>
> No matter what I try, it is not possible to update Eclipse. Whenever I
> try to run an update I get an error like the following:
>
>
> Cannot complete the request. See the details.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.1.v3449c,3.4. 1.v3449c]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.1.v3449c,3.4.1.v3449c]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.1 00.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341,3.4.100.r341_ v20080814-989JESIEdAciFYfkZZsBfSwQ2341]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.0.I2 0080606-1300,3.4.0.I20080606-1300]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.1.M2 0080827-0800a,3.4.1.M20080827-0800a]]
> can be satisfied.
>
> < Many lines snipped out >
>
>
> I have the "Eclipse IDE for Java EE Developers" version installed, and
> the only other plug-in I have installed is PyDev 1.3.22 (the latest).
>
> I have tried re-installing Eclipse and starting with a fresh, empty
> workspace, but after I perform a single update, all subsequent updates
> fail with errors of the form I listed above.
>
> I am running:
>
> Eclipse 3.4.1
> Windows XP sp3 (but have encountered same problem on Mac OS X at home)
>
> I have seen references to similar (virtually identical) problems that
> others have reported, but I have never seen an explanation or work-around.
>
> Surely someone else must have encountered this problem as well? Has the
> new p2 update system simply imploded and is unable to function any longer?
>
> Any help would be *very* appreciated.
>
> Jeff

I'm experiencing the exact same problem running Eclipse 3.4.1 on linux
(openSUSE 10.3) and jdk 1.6.0_03. I do not use a web proxy as have been
suggested to cause the problem. I have installed and updated a lot of
plugins up until recently without any problems, then all of a sudden
this problem arises (I noticed it a couple of days ago).

/Micke.
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265494 is a reply to message #265476] Tue, 14 October 2008 12:44 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jeffreyz.q-free.com

No, I am not using a web proxy, but thanks for the help.

I *may* have solved my problem. My original Eclipse installation
eventually refused to even start. It would report an error in a small
dialog and the only options was to close the dialog.

So I re-installed Eclipse from scratch again and updated the plug-ins.
After doing this I encountered the same problem again where I received
the following error when I tried to install/update additional plug-ins:


Cannot complete the request. See the details.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.1.v3449c,3.4. 1.v3449c]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.1.v3449c,3.4.1.v3449c]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.1 00.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341,3.4.100.r341_ v20080814-989JESIEdAciFYfkZZsBfSwQ2341]]
can be satisfied.
Cannot find a solution where both Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.0.I2 0080606-1300,3.4.0.I20080606-1300]]
and Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.1.M2 0080827-0800a,3.4.1.M20080827-0800a]]
can be satisfied.

< Many lines snipped out >


I was able to fix this Eclipse installation by using the:

Revert Configuration...

option of the "Software Updates..." menu item. I selected an earlier
configuration and then this Eclipse installation started to function
properly again.

Somehow, the Eclipse installation "corrupted" itself (using a fairly
broad definition of *corruption"). I assume there there are still
problems with the new p2 update system that lead to this problem.

Apart from my Eclipse installation crashing on startup 50% of the time
(a problem I have had for many months and no one has been able to
explain to me), my Eclipse installation is usable again.

Jeff



> Jeffrey Zelt <jeffreyz@q-free.com> writes:
>
>> I am running:
>>
>> Eclipse 3.4.1
>> Windows XP sp3 (but have encountered same problem on Mac OS X at home)
>
> Are you usuing a web proxy and if so does it have a cache? I have
> found that that causes a lot of trouble with update. I have not seen
> the specific problem you report, but I would not be surprised to get
> errors related to not finding things if update is operating on
> partially stale and inconsistent data about what is available from the
> various sites it is using.
>
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265514 is a reply to message #265456] Tue, 14 October 2008 13:26 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

Jeffrey Zelt wrote:
> I am at my wits end. There seems to be a major problem with Eclipse's
> built-in update mechanism, or possibly the Eclipse update sites or both
> or ...
>
> No matter what I try, it is not possible to update Eclipse. Whenever I
> try to run an update I get an error like the following:

A few people have been reporting this kind of problem during update,
ever since 3.4.1 came out. It could be a problem with either the 3.4.1
update itself or some commonly-used plugin that is not compatible with
3.4.1.
Please enter a bug against the component RT > Equinox > p2 with a
description of what you do and the stack trace. Also include all
plugins/features that you have installed that were not included in the
original Eclipse package you downloaded.
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Equinox& amp;component=p2

Eric


> Cannot complete the request. See the details.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.1.v3449c,3.4. 1.v3449c]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.1.v3449c,3.4.1.v3449c]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.1 00.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341,3.4.100.r341_ v20080814-989JESIEdAciFYfkZZsBfSwQ2341]]
> can be satisfied.
> Cannot find a solution where both Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.0.I2 0080606-1300,3.4.0.I20080606-1300]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.1.M2 0080827-0800a,3.4.1.M20080827-0800a]]
> can be satisfied.
>
> < Many lines snipped out >
>
>
> I have the "Eclipse IDE for Java EE Developers" version installed, and
> the only other plug-in I have installed is PyDev 1.3.22 (the latest).
>
> I have tried re-installing Eclipse and starting with a fresh, empty
> workspace, but after I perform a single update, all subsequent updates
> fail with errors of the form I listed above.
>
> I am running:
>
> Eclipse 3.4.1
> Windows XP sp3 (but have encountered same problem on Mac OS X at home)
>
> I have seen references to similar (virtually identical) problems that
> others have reported, but I have never seen an explanation or work-around.
>
> Surely someone else must have encountered this problem as well? Has the
> new p2 update system simply imploded and is unable to function any longer?
>
> Any help would be *very* appreciated.
>
> Jeff
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265553 is a reply to message #265514] Wed, 15 October 2008 08:04 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jeffreyz.q-free.com

I *thought* I had fixed my problem by using the:

Revert Configuration...

option of the "Software Updates..." menu item. I selected an earlier
configuration and then myEclipse installation started to function
properly again.

However, I started Eclipse this morning and the *same problem* occurred
(see below for a description).

When I opened the "Revert Configuration..." dialog from "Software
Updates..." today, it displayed *many* configurations since I last
"fixed" my system yesterday. Eclipse seems to be saving a configuration
every few minutes. And during this period I did not install any updates
or new plug-ins in any way.

Moreover, when I clicked on most of these stored configurations, Eclipse
hesitated for a few seconds and then opened a separate dialog to report
that the configuration was corrupted and could not be used (I did not
record the exact text of the message).

Luckily, I was able to go back about 20-30 saved configurations that
were created since yesterday and find one that was not corrupt and now I
can use my Eclipse installation again.


I am using Eclipse as an IDE and I am not even a Java programmer, but
this is what it looks like is happening to me:

1. Eclipse (probably the new p2 update system) is creating and storing
configurations every few minutes, even though I do not make (knowingly)
any changes to my configuration.

2. At some point, Eclipse does something that renders a stored
configuration corrupt. From this point on, *all* stored configurations
appear to be corrupt.


This is not acceptable, of course. I know nothing about Eclipse
programming and do not even know how to report this as a bug. It seems
to be a very fundamental problem with core Eclipse functionality, and it
seems that others have been bitten by it as well.

I will just cross my fingers that I can continue to fix my Eclipse
installation this way each time it happens (and I assume it *will*
continue to happen).

And I just gave a talk for our department a few weeks ago extolling the
virtues of Eclipse and recommending that others give it a try. I
actually hope that no one follows my advice until these rough edges are
cleaned up. Sigh.

Jeff



> Jeffrey Zelt wrote:
>> I am at my wits end. There seems to be a major problem with Eclipse's
>> built-in update mechanism, or possibly the Eclipse update sites or
>> both or ...
>>
>> No matter what I try, it is not possible to update Eclipse. Whenever
>> I try to run an update I get an error like the following:
>
> A few people have been reporting this kind of problem during update,
> ever since 3.4.1 came out. It could be a problem with either the 3.4.1
> update itself or some commonly-used plugin that is not compatible with
> 3.4.1.
> Please enter a bug against the component RT > Equinox > p2 with a
> description of what you do and the stack trace. Also include all
> plugins/features that you have installed that were not included in the
> original Eclipse package you downloaded.
> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Equinox& amp;component=p2
>
> Eric
>
>
>> Cannot complete the request. See the details.
>> Cannot find a solution where both Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
>> and Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.1.v3449c,3.4. 1.v3449c]]
>> can be satisfied.
>> Cannot find a solution where both Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
>> and Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.1.v3449c,3.4.1.v3449c]]
>> can be satisfied.
>> Cannot find a solution where both Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
>> and Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.1 00.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341,3.4.100.r341_ v20080814-989JESIEdAciFYfkZZsBfSwQ2341]]
>> can be satisfied.
>> Cannot find a solution where both Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.0.I2 0080606-1300,3.4.0.I20080606-1300]]
>> and Match[requiredCapability:
>> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.1.M2 0080827-0800a,3.4.1.M20080827-0800a]]
>> can be satisfied.
>>
>> < Many lines snipped out >
>>
>>
>> I have the "Eclipse IDE for Java EE Developers" version installed, and
>> the only other plug-in I have installed is PyDev 1.3.22 (the latest).
>>
>> I have tried re-installing Eclipse and starting with a fresh, empty
>> workspace, but after I perform a single update, all subsequent updates
>> fail with errors of the form I listed above.
>>
>> I am running:
>>
>> Eclipse 3.4.1
>> Windows XP sp3 (but have encountered same problem on Mac OS X at
>> home)
>>
>> I have seen references to similar (virtually identical) problems that
>> others have reported, but I have never seen an explanation or
>> work-around.
>>
>> Surely someone else must have encountered this problem as well? Has
>> the new p2 update system simply imploded and is unable to function any
>> longer?
>>
>> Any help would be *very* appreciated.
>>
>> Jeff
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265558 is a reply to message #265553] Wed, 15 October 2008 13:27 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

First: Please, please enter a bug with as much detail as possible:
https://bugs.eclipse.org/bugs
Include what you originally installed, what other plugins you installed
and/or updated. It is bug reports that get the developers' attention;
newsgroup postings may or may not be read by the people who can fix
things quickly.

Second: Do you perhaps have the auto-update feature enabled? Check the
Preferences under Install/Update > Automatic Updates. That might explain
why you see so many old configurations.

Third: You can likely get back to a consistently good state by just
downloading and installing a fresh copy of 3.4.1. Make sure NOT to unzip
it on top of your existing installation; put it in a new location in
your file system (or archive the old installation away). You can point
the new installation to your existing workspace(s) and it should look
pretty much like you never changed. The only other thing you'd need to
do would be re-install any other plugins that you might have installed
since you originally installed Eclipse.

Hope this helps,
Eric


Jeffrey Zelt wrote:
> I *thought* I had fixed my problem by using the:
>
> Revert Configuration...
>
> option of the "Software Updates..." menu item. I selected an earlier
> configuration and then myEclipse installation started to function
> properly again.
>
> However, I started Eclipse this morning and the *same problem* occurred
> (see below for a description).
>
> When I opened the "Revert Configuration..." dialog from "Software
> Updates..." today, it displayed *many* configurations since I last
> "fixed" my system yesterday. Eclipse seems to be saving a configuration
> every few minutes. And during this period I did not install any updates
> or new plug-ins in any way.
>
> Moreover, when I clicked on most of these stored configurations, Eclipse
> hesitated for a few seconds and then opened a separate dialog to report
> that the configuration was corrupted and could not be used (I did not
> record the exact text of the message).
>
> Luckily, I was able to go back about 20-30 saved configurations that
> were created since yesterday and find one that was not corrupt and now I
> can use my Eclipse installation again.
>
>
> I am using Eclipse as an IDE and I am not even a Java programmer, but
> this is what it looks like is happening to me:
>
> 1. Eclipse (probably the new p2 update system) is creating and storing
> configurations every few minutes, even though I do not make (knowingly)
> any changes to my configuration.
>
> 2. At some point, Eclipse does something that renders a stored
> configuration corrupt. From this point on, *all* stored configurations
> appear to be corrupt.
>
>
> This is not acceptable, of course. I know nothing about Eclipse
> programming and do not even know how to report this as a bug. It seems
> to be a very fundamental problem with core Eclipse functionality, and it
> seems that others have been bitten by it as well.
>
> I will just cross my fingers that I can continue to fix my Eclipse
> installation this way each time it happens (and I assume it *will*
> continue to happen).
>
> And I just gave a talk for our department a few weeks ago extolling the
> virtues of Eclipse and recommending that others give it a try. I
> actually hope that no one follows my advice until these rough edges are
> cleaned up. Sigh.
>
> Jeff
>
>
>
>> Jeffrey Zelt wrote:
>>> I am at my wits end. There seems to be a major problem with
>>> Eclipse's built-in update mechanism, or possibly the Eclipse update
>>> sites or both or ...
>>>
>>> No matter what I try, it is not possible to update Eclipse. Whenever
>>> I try to run an update I get an error like the following:
>>
>> A few people have been reporting this kind of problem during update,
>> ever since 3.4.1 came out. It could be a problem with either the 3.4.1
>> update itself or some commonly-used plugin that is not compatible with
>> 3.4.1.
>> Please enter a bug against the component RT > Equinox > p2 with a
>> description of what you do and the stack trace. Also include all
>> plugins/features that you have installed that were not included in the
>> original Eclipse package you downloaded.
>> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Equinox& amp;component=p2
>>
>> Eric
>>
>>
>>> Cannot complete the request. See the details.
>>> Cannot find a solution where both Match[requiredCapability:
>>> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
>>> and Match[requiredCapability:
>>> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.1.v3449c,3.4. 1.v3449c]]
>>> can be satisfied.
>>> Cannot find a solution where both Match[requiredCapability:
>>> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
>>> and Match[requiredCapability:
>>> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.1.v3449c,3.4.1.v3449c]]
>>> can be satisfied.
>>> Cannot find a solution where both Match[requiredCapability:
>>> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
>>> and Match[requiredCapability:
>>> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.1 00.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341,3.4.100.r341_ v20080814-989JESIEdAciFYfkZZsBfSwQ2341]]
>>> can be satisfied.
>>> Cannot find a solution where both Match[requiredCapability:
>>> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.0.I2 0080606-1300,3.4.0.I20080606-1300]]
>>> and Match[requiredCapability:
>>> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.1.M2 0080827-0800a,3.4.1.M20080827-0800a]]
>>> can be satisfied.
>>>
>>> < Many lines snipped out >
>>>
>>>
>>> I have the "Eclipse IDE for Java EE Developers" version installed,
>>> and the only other plug-in I have installed is PyDev 1.3.22 (the
>>> latest).
>>>
>>> I have tried re-installing Eclipse and starting with a fresh, empty
>>> workspace, but after I perform a single update, all subsequent
>>> updates fail with errors of the form I listed above.
>>>
>>> I am running:
>>>
>>> Eclipse 3.4.1
>>> Windows XP sp3 (but have encountered same problem on Mac OS X at
>>> home)
>>>
>>> I have seen references to similar (virtually identical) problems that
>>> others have reported, but I have never seen an explanation or
>>> work-around.
>>>
>>> Surely someone else must have encountered this problem as well? Has
>>> the new p2 update system simply imploded and is unable to function
>>> any longer?
>>>
>>> Any help would be *very* appreciated.
>>>
>>> Jeff
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265564 is a reply to message #265558] Wed, 15 October 2008 14:20 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jeffreyz.q-free.com

Eric Rizzo wrote:
> First: Please, please enter a bug with as much detail as possible:
> https://bugs.eclipse.org/bugs
> Include what you originally installed, what other plugins you installed
> and/or updated. It is bug reports that get the developers' attention;
> newsgroup postings may or may not be read by the people who can fix
> things quickly.

I will try to do my best.


> Second: Do you perhaps have the auto-update feature enabled? Check the
> Preferences under Install/Update > Automatic Updates. That might explain
> why you see so many old configurations.

Yes, I did have it enabled. I disabled it earlier today because I too
suspected it.


> Third: You can likely get back to a consistently good state by just
> downloading and installing a fresh copy of 3.4.1. Make sure NOT to unzip
> it on top of your existing installation; put it in a new location in
> your file system (or archive the old installation away). You can point
> the new installation to your existing workspace(s) and it should look
> pretty much like you never changed. The only other thing you'd need to
> do would be re-install any other plugins that you might have installed
> since you originally installed Eclipse.

Yes, this was what I was forced to do yesterday because my original
Eclipse installation became corrupted in a way that it would not start.
I did use a new location in my file system. I suspect this won't be
the last time I do this :-)

Thank you for the help - I have seen a great many postings from you
helping others in need and we all appreciate it.

Jeff




>
> Hope this helps,
> Eric
>
>
> Jeffrey Zelt wrote:
>> I *thought* I had fixed my problem by using the:
>>
>> Revert Configuration...
>>
>> option of the "Software Updates..." menu item. I selected an earlier
>> configuration and then myEclipse installation started to function
>> properly again.
>>
>> However, I started Eclipse this morning and the *same problem*
>> occurred (see below for a description).
>>
>> When I opened the "Revert Configuration..." dialog from "Software
>> Updates..." today, it displayed *many* configurations since I last
>> "fixed" my system yesterday. Eclipse seems to be saving a
>> configuration every few minutes. And during this period I did not
>> install any updates or new plug-ins in any way.
>>
>> Moreover, when I clicked on most of these stored configurations,
>> Eclipse hesitated for a few seconds and then opened a separate dialog
>> to report that the configuration was corrupted and could not be used
>> (I did not record the exact text of the message).
>>
>> Luckily, I was able to go back about 20-30 saved configurations that
>> were created since yesterday and find one that was not corrupt and now
>> I can use my Eclipse installation again.
>>
>>
>> I am using Eclipse as an IDE and I am not even a Java programmer, but
>> this is what it looks like is happening to me:
>>
>> 1. Eclipse (probably the new p2 update system) is creating and storing
>> configurations every few minutes, even though I do not make
>> (knowingly) any changes to my configuration.
>>
>> 2. At some point, Eclipse does something that renders a stored
>> configuration corrupt. From this point on, *all* stored
>> configurations appear to be corrupt.
>>
>>
>> This is not acceptable, of course. I know nothing about Eclipse
>> programming and do not even know how to report this as a bug. It
>> seems to be a very fundamental problem with core Eclipse
>> functionality, and it seems that others have been bitten by it as well.
>>
>> I will just cross my fingers that I can continue to fix my Eclipse
>> installation this way each time it happens (and I assume it *will*
>> continue to happen).
>>
>> And I just gave a talk for our department a few weeks ago extolling
>> the virtues of Eclipse and recommending that others give it a try. I
>> actually hope that no one follows my advice until these rough edges
>> are cleaned up. Sigh.
>>
>> Jeff
>>
>>
>>
>>> Jeffrey Zelt wrote:
>>>> I am at my wits end. There seems to be a major problem with
>>>> Eclipse's built-in update mechanism, or possibly the Eclipse update
>>>> sites or both or ...
>>>>
>>>> No matter what I try, it is not possible to update Eclipse.
>>>> Whenever I try to run an update I get an error like the following:
>>>
>>> A few people have been reporting this kind of problem during update,
>>> ever since 3.4.1 came out. It could be a problem with either the
>>> 3.4.1 update itself or some commonly-used plugin that is not
>>> compatible with 3.4.1.
>>> Please enter a bug against the component RT > Equinox > p2 with a
>>> description of what you do and the stack trace. Also include all
>>> plugins/features that you have installed that were not included in
>>> the original Eclipse package you downloaded.
>>> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Equinox& amp;component=p2
>>>
>>> Eric
>>>
>>>
>>>> Cannot complete the request. See the details.
>>>> Cannot find a solution where both Match[requiredCapability:
>>>> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.0.v3448f,3.4. 0.v3448f]]
>>>> and Match[requiredCapability:
>>>> org.eclipse.equinox.p2.iu/org.eclipse.swt/[3.4.1.v3449c,3.4. 1.v3449c]]
>>>> can be satisfied.
>>>> Cannot find a solution where both Match[requiredCapability:
>>>> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.0.v3448f,3.4.0.v3448f]]
>>>> and Match[requiredCapability:
>>>> org.eclipse.equinox.p2.iu/org.eclipse.swt.win32.win32.x86/[3 .4.1.v3449c,3.4.1.v3449c]]
>>>> can be satisfied.
>>>> Cannot find a solution where both Match[requiredCapability:
>>>> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.0 .v20080324a-989JERhEk-jWnd5IY8K5tjxB,3.4.0.v20080324a-989JER hEk-jWnd5IY8K5tjxB]]
>>>> and Match[requiredCapability:
>>>> org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.jar/[3.4.1 00.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341,3.4.100.r341_ v20080814-989JESIEdAciFYfkZZsBfSwQ2341]]
>>>> can be satisfied.
>>>> Cannot find a solution where both Match[requiredCapability:
>>>> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.0.I2 0080606-1300,3.4.0.I20080606-1300]]
>>>> and Match[requiredCapability:
>>>> org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.1.M2 0080827-0800a,3.4.1.M20080827-0800a]]
>>>> can be satisfied.
>>>>
>>>> < Many lines snipped out >
>>>>
>>>>
>>>> I have the "Eclipse IDE for Java EE Developers" version installed,
>>>> and the only other plug-in I have installed is PyDev 1.3.22 (the
>>>> latest).
>>>>
>>>> I have tried re-installing Eclipse and starting with a fresh, empty
>>>> workspace, but after I perform a single update, all subsequent
>>>> updates fail with errors of the form I listed above.
>>>>
>>>> I am running:
>>>>
>>>> Eclipse 3.4.1
>>>> Windows XP sp3 (but have encountered same problem on Mac OS X at
>>>> home)
>>>>
>>>> I have seen references to similar (virtually identical) problems
>>>> that others have reported, but I have never seen an explanation or
>>>> work-around.
>>>>
>>>> Surely someone else must have encountered this problem as well? Has
>>>> the new p2 update system simply imploded and is unable to function
>>>> any longer?
>>>>
>>>> Any help would be *very* appreciated.
>>>>
>>>> Jeff
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265595 is a reply to message #265456] Thu, 16 October 2008 14:49 Go to previous messageGo to next message
Cathy Scott is currently offline Cathy ScottFriend
Messages: 4
Registered: July 2009
Junior Member
Hi I have a similar problem.
I have recently installed Eclipse 3.4.0.M20080911-1700

I used Software updates to install PyDev for Eclipse (1.3.22) and PyDev
Mylyn Integration (0.3.0)

I then tried to install Subversion but I have the problem that Jeffrey has
described above.

I had thought that it was a problem with the Subversion install but it
actually occurs whatever plugin I try to install.

This is a new install - is the information above useful for trying to
replicate the error for debugging?

I'm going to install Eclipse again - maybe a different level as I do need
to get Subversion installed so that I can do some useful work ;-) but I am
happy to provide information for any bug report so that this problem can
be sorted out.

Is there a bug filed yet?

Thanks,
Cathy
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265622 is a reply to message #265595] Fri, 17 October 2008 06:26 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jeffreyz.q-free.com

I have filed the bug report:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=251067

Feel free to add to it.

And good luck. Don't forget to try reverting to a previous
configuration and to first turn off automatic updates - this seems to
have helped for me (but has not actually fixed anything).

Jeffrey


Cathy Scott wrote:
> Hi I have a similar problem.
> I have recently installed Eclipse 3.4.0.M20080911-1700
>
> I used Software updates to install PyDev for Eclipse (1.3.22) and PyDev
> Mylyn Integration (0.3.0)
>
> I then tried to install Subversion but I have the problem that Jeffrey
> has described above.
>
> I had thought that it was a problem with the Subversion install but it
> actually occurs whatever plugin I try to install.
>
> This is a new install - is the information above useful for trying to
> replicate the error for debugging?
>
> I'm going to install Eclipse again - maybe a different level as I do
> need to get Subversion installed so that I can do some useful work ;-)
> but I am happy to provide information for any bug report so that this
> problem can be sorted out.
>
> Is there a bug filed yet?
>
> Thanks,
> Cathy
>
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #265632 is a reply to message #265622] Fri, 17 October 2008 13:32 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

Cathy, please do add your experience and details to the bug report. It
looks like PyDev is the commonality between you two and it will help
tracking it down if the developers know that.

Eric

Jeffrey Zelt wrote:
> I have filed the bug report:
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=251067
>
> Feel free to add to it.
>
> And good luck. Don't forget to try reverting to a previous
> configuration and to first turn off automatic updates - this seems to
> have helped for me (but has not actually fixed anything).
>
> Jeffrey
>
>
> Cathy Scott wrote:
>> Hi I have a similar problem.
>> I have recently installed Eclipse 3.4.0.M20080911-1700
>>
>> I used Software updates to install PyDev for Eclipse (1.3.22) and
>> PyDev Mylyn Integration (0.3.0)
>>
>> I then tried to install Subversion but I have the problem that Jeffrey
>> has described above.
>>
>> I had thought that it was a problem with the Subversion install but it
>> actually occurs whatever plugin I try to install.
>>
>> This is a new install - is the information above useful for trying to
>> replicate the error for debugging?
>>
>> I'm going to install Eclipse again - maybe a different level as I do
>> need to get Subversion installed so that I can do some useful work ;-)
>> but I am happy to provide information for any bug report so that this
>> problem can be sorted out.
>>
>> Is there a bug filed yet?
>>
>> Thanks,
>> Cathy
>>
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #268878 is a reply to message #265482] Wed, 25 February 2009 04:52 Go to previous messageGo to next message
Steve Betts is currently offline Steve BettsFriend
Messages: 1
Registered: July 2009
Junior Member
I have this same problem on Windows. I just downloaded the latest version
of Eclipse Java IDE, then I updated everything (that was already
installed). Now I go to install, say, Java EE Developer Tools, and I get
this:

Cannot find a solution satisfying the following requirements
org.eclipse.swt [3.4.0.v3448f].

But I have org.eclipse.swt 3.4.2.v3452b

My version information is:

Eclipse Platform

Version: 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL
Build id: M20090211-1700

I don't know much about the eclipse platform, but it looks to me like the
tool that everyone uses to define dependencies changed from allowing any
newer version to requiring the exact version. Or maybe the default value
of the "match exact" button was changed. Anyway, it's all in the shitter
now.
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #268884 is a reply to message #268878] Wed, 25 February 2009 20:25 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

On 2/24/2009 11:52 PM, Steve Betts wrote:
> I have this same problem on Windows. I just downloaded the latest
> version of Eclipse Java IDE, then I updated everything (that was already
> installed). Now I go to install, say, Java EE Developer Tools, and I get
> this:
>
> Cannot find a solution satisfying the following requirements
> org.eclipse.swt [3.4.0.v3448f].
>
> But I have org.eclipse.swt 3.4.2.v3452b
>
> My version information is:
>
> Eclipse Platform
>
> Version: 3.4.2.R342_v20090122-9I96EiWElHi8lheoJKJIvhM3JfVsYbRrgVIWL
> Build id: M20090211-1700

Where did you download this from? 3.4.2 (aka, Ganymede SR2) is not yet
released as far as I know, so it looks like you've got an integration or
milestone build of it - correct?

Eric
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #268970 is a reply to message #268884] Tue, 03 March 2009 21:31 Go to previous messageGo to next message
AndrÃ?© April is currently offline AndrÃ?© AprilFriend
Messages: 1
Registered: July 2009
Junior Member
I have the same problem on Linux (32 bits). I downloaded Ganymede today
for my home computer. I clicked on the "Eclipse IDE for Java EE Developers
(163 MB)" link in the download section. The proposed download was
"eclipse-jee-ganymede-SR2-linux-gtk.tar.gz".

What can I do? Download an older version of Ganymede? How/where?

Thanks,

André
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #269031 is a reply to message #268970] Thu, 05 March 2009 14:17 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

On 3/3/2009 4:31 PM, André April wrote:
> I have the same problem on Linux (32 bits). I downloaded Ganymede today
> for my home computer. I clicked on the "Eclipse IDE for Java EE
> Developers (163 MB)" link in the download section. The proposed download
> was "eclipse-jee-ganymede-SR2-linux-gtk.tar.gz".
>
> What can I do? Download an older version of Ganymede? How/where?

I don't understand what you're trying to do; if you just downloaded
Eclipse today why would you need to update it?
Are you trying to update a specific feature, or _everything_?

Eric
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #269122 is a reply to message #269031] Sun, 08 March 2009 12:35 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: no.spam.org

I have the same problem:
"Cannot find a solution satisfying the following requirements
org.eclipse.swt "

I've been using eclipse 3.4 on Ubuntu 8.10. When I've tried to install
some plugins, for example, "Maven integration for eclipse" I recieved this
error.
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #269146 is a reply to message #269122] Mon, 09 March 2009 16:48 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

On 3/8/2009 8:35 AM, Luis wrote:
> I have the same problem:
> "Cannot find a solution satisfying the following requirements
> org.eclipse.swt "
>
> I've been using eclipse 3.4 on Ubuntu 8.10. When I've tried to install
> some plugins, for example, "Maven integration for eclipse" I recieved
> this error.
>

These messages are being revised for Eclipse 3.5 to make them more
user-friendly and useful. See these bug reports:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=240062
https://bugs.eclipse.org/bugs/show_bug.cgi?id=200380

Eric
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #269369 is a reply to message #269146] Sat, 14 March 2009 17:51 Go to previous messageGo to next message
Luis is currently offline LuisFriend
Messages: 1
Registered: July 2009
Junior Member
Ok, thanks for the answer. This kind of error messages are confused for
new users like me.

I'm my own case I've solved the problem unselecting a module of the
plug-in, the Subeclipse handler that it's not interesting for me.
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #269681 is a reply to message #269369] Sun, 22 March 2009 22:11 Go to previous messageGo to next message
Richard Brown is currently offline Richard BrownFriend
Messages: 1
Registered: July 2009
Junior Member
I have this problem when trying to use the update manager to install
almost any software on the "Available Software" list.
Re: Cannot update Eclipse: "Cannot find a solution ..." [message #552108 is a reply to message #265456] Tue, 10 August 2010 21:27 Go to previous message
No real name is currently offline No real nameFriend
Messages: 1
Registered: August 2010
Junior Member
This forum is quite old, but I had the similar problem and trying to find in Internet about it, led me to this forum. If someone still have this problem, other things mentioned above can be applied, but for me, I tried to install the plugin suitable for my release of the Eclipse and it works now.
For that I removed the check saying "show only latest version", and when the list is there, I selected the suitable version for my Eclipse.
Hope that helps !
Previous Topic:External Tools Configuration
Next Topic:How to find which version of Java Eclipse is running under?
Goto Forum:
  


Current Time: Mon Apr 22 22:50:07 GMT 2019

Powered by FUDForum. Page generated in 0.04577 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top