Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » p2 director, "missing requirements" that are totally there
p2 director, "missing requirements" that are totally there [message #1468964] Tue, 11 November 2014 07:26
Ben Gamble is currently offline Ben GambleFriend
Messages: 3
Registered: September 2014
Junior Member
Let me say up front I've only had a few months' exposure to these tools so if you're about to ask me, "well, why don't you do it in the following totally different and far superior way?" I'm not gonna have an answer for that.

So the build process I'm supporting calls for assembling a packaging-time eclipse instance by 1) untarring the appropriate eclipse platform runtime and 2) loading it up with EMF, GEF, WTP, some other stuff using director. I inherited shell scripts that work like a champ to assemble the right prerequisites for 4.4.1.

My task now, for reasons I will spare you, is to assemble a heretofore unused architecture for Juno. Happily, I have zips of all the dependencies I need. Unhappily, the pieces are not going together. As far as I can tell, my immediate problem looks like this (line breaks for readability):

$ /path/to/different/eclipse -nosplash  -application org.eclipse.equinox.p2.director 
-metadataRepository jar:file:///foo/\!/ 
-artifactRepository jar:file:///foo/\!/ 
-installIU -destination /foo/macosx/eclipse 
-profile SDKProfile -bundlepool /foo/macosx/eclipse
-p2.os macosx cocoa -p2.arch x86_64 -roaming 

Installing 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT.
Cannot complete the install because one or more required items could not be found.
 Software being installed: Eclipse CVS Client 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT ( 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT)
 Missing requirement: CVS Team Provider UI 3.3.500.v20120522-1148 ( 3.3.500.v20120522-1148) requires 'bundle 4.4.2' but it could not be found
 Cannot satisfy dependency:
  From: Eclipse CVS Client 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT ( 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT)
  To: [3.3.500.v20120522-1148]

Well, that would seem to be a pretty straightforward message: I need 4.4.2. Except here in /foo/macosx/eclipse:

$ ls plugins/*
$ fgrep artifacts.xml
    <artifact classifier='osgi.bundle' id='' version='4.4.2.v20110823'>

Which sure looks to me like the platform runtime I'm trying to drop cvs into does in fact contain the exact plugin director is complaining about. At this point, due to unfamiliarity with the tools, I'd be wondering if the error isn't that it's looking for somewhere else entirely, but like I say, when I try to put together the analogous pieces for 4.4.1 it works great.

Can anyone help me make sense of this?
Previous Topic:How to programatically close the osgi console
Next Topic:Cant get Eclipse to work.
Goto Forum:

Current Time: Mon Oct 18 04:16:39 GMT 2021

Powered by FUDForum. Page generated in 0.01492 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top