Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Ops! Copy/Paste operation does not copy stereotyped attribute values :-(
Ops! Copy/Paste operation does not copy stereotyped attribute values :-( [message #1465412] Sat, 08 November 2014 10:15 Go to next message
Emilio Dolce is currently offline Emilio DolceFriend
Messages: 10
Registered: November 2014
Junior Member
...I'm investigating the copy/paste strategies to resolve this very blocking limit for my initiative...
Any advice?
Thank you.
Emilio.
Re: Ops! Copy/Paste operation does not copy stereotyped attribute values :-( [message #1465429 is a reply to message #1465412] Sat, 08 November 2014 10:34 Go to previous messageGo to next message
Emilio Dolce is currently offline Emilio DolceFriend
Messages: 10
Registered: November 2014
Junior Member
I saw that the org.eclipse.papyrus.uml.commands plugin extensions for copy/paste handlers are commented out for deprecation. Probably the new implementation is still in testing...

[Updated on: Sat, 08 November 2014 10:41]

Report message to a moderator

Re: Ops! Copy/Paste operation does not copy stereotyped attribute values :-( [message #1465577 is a reply to message #1465429] Sat, 08 November 2014 13:33 Go to previous messageGo to next message
Emilio Dolce is currently offline Emilio DolceFriend
Messages: 10
Registered: November 2014
Junior Member
Wow! I successfully created a new paste strategy in order to copy all applied stereotype attribute values.
I can provide the solution if requested.
Anyway I thing should be better to allow actual StereotypePasteStrategy of uml sub project to do this work, even better if enabled thru preference page.
Good week-end.
Emilio.
Re: Ops! Copy/Paste operation does not copy stereotyped attribute values :-( [message #1470609 is a reply to message #1465577] Wed, 12 November 2014 13:28 Go to previous message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 926
Registered: February 2011
Senior Member
Hi Emilio,

The bug has been reported:

438511: Copy/paste should copy property values for applied stereotype
https://bugs.eclipse.org/bugs/show_bug.cgi?id=438511

And there is a Gerrit contribution, waiting for review:

29338: Bug 438511 - Copy/paste should copy property values for applied stereotype - add a command to apply a stereotype and data from a stereotypeapplication - add a test for the model explorer use case [Iaa1415a6]
https://git.eclipse.org/r/#/c/29338/

(I just noticed you have already commented on the Bugzilla, but I guess this could still be helpful for others)

Regards,
Camille


Camille Letavernier
Previous Topic:Property view value change listener to trigger custom actions
Next Topic:Where to find MARTE metamodel
Goto Forum:
  


Current Time: Tue Jul 07 14:26:50 GMT 2020

Powered by FUDForum. Page generated in 0.02001 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top