Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Installing Sirius 2.0.0 on Eclipse Modeling
Installing Sirius 2.0.0 on Eclipse Modeling [message #1460453] Mon, 03 November 2014 15:34 Go to next message
Jonathan Dumont is currently offline Jonathan DumontFriend
Messages: 32
Registered: January 2013
Location: Laval
Member
Hi,

I've tried to install Sirius 2.0.0 on an Eclipse Modeling Luna SR1, from the following update site : http://download.eclipse.org/sirius/updates/releases/2.0.0/luna

During the installation process, some conflicts appears. It seems that Sirius 2.0.0 can't be installed as Sirius 1.0.1 is already included in the Eclipse Modeling distribution. It doesn't allow to update it, or even to uninstall the current version.

Is there a way to update Sirius easily, or to uninstall the previous versions from an packaged Eclipse Modeling ?

Regards,

Jonathan


Re: Installing Sirius 2.0.0 on Eclipse Modeling [message #1460531 is a reply to message #1460453] Mon, 03 November 2014 17:09 Go to previous messageGo to next message
Maxime Porhel is currently offline Maxime PorhelFriend
Messages: 482
Registered: July 2009
Location: Nantes, France
Senior Member
Hi,

Le 03/11/2014 16:34, Jonathan Dumont a écrit :
> Hi,

>
> I've tried to install Sirius 2.0.0 on an Eclipse Modeling Luna SR1, from
> the following update site :
> http://download.eclipse.org/sirius/updates/releases/2.0.0/luna
>
> During the installation process, some conflicts appears. It seems that
> Sirius 2.0.0 can't be installed as Sirius 1.0.1 is already included in
> the Eclipse Modeling distribution. It doesn't allow to update it, or
> even to uninstall the current version.
>
> Is there a way to update Sirius easily, or to uninstall the previous
> versions from an packaged Eclipse Modeling ?
>
> Regards,
>
> Jonathan

I think you should take a look to the bug 448394 [1].

Your issue comes from the EcoreTools2 compatibility with Sirius. It has
been fixed in a commit already available in the EcoreTools 2.0.x nighlty
builds [2].



Regards,


--
Maxime - Obeo

Need professional services for Sirius?
http://www.obeodesigner.com/sirius

--
[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=448394
[2] http://download.eclipse.org/ecoretools/updates/nightly/2.0.x/luna


Maxime Porhel - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius

Join the Sirius community at SiriusCon. Register for free: Nov. 9th Paris
http://www.siriuscon.org/
Re: Installing Sirius 2.0.0 on Eclipse Modeling [message #1460673 is a reply to message #1460531] Mon, 03 November 2014 20:35 Go to previous message
Jonathan Dumont is currently offline Jonathan DumontFriend
Messages: 32
Registered: January 2013
Location: Laval
Member
Thanks for your quick reply.
I think that this is the problem, I will use the nightly build.


Previous Topic:Saving style changes
Next Topic:Create edge End Label from a target element property
Goto Forum:
  


Current Time: Fri Apr 10 20:27:56 GMT 2020

Powered by FUDForum. Page generated in 0.02286 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top