Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse 3.x Bridge Cannot Be Installed with e4 Tools(How to use compatibility layer for an e4 RCP application if 3.x Bridge cannot be Installed?)
Eclipse 3.x Bridge Cannot Be Installed with e4 Tools [message #1456928] Thu, 30 October 2014 21:38 Go to next message
Patty Eilers is currently offline Patty EilersFriend
Messages: 10
Registered: October 2014
Junior Member
In an attempt to develop an e4 RCP application that references/wraps Eclipse 3.x RCP plug-ins, I understand that I must use the compatibility layer which is supported by installing the Eclipse 3.x Bridge. However, when I attempt to do this I am informed that the e4 Tools and EMF will be un-installed as a result.

Has anyone figured out how to get this working in Eclipse Luna 4.4?
Re: Eclipse 3.x Bridge Cannot Be Installed with e4 Tools [message #1457346 is a reply to message #1456928] Fri, 31 October 2014 08:21 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

the comp√ľatibility layer is already part of Eclipse, in fact it is
mainly the org.eclipse.ui bundle. The Eclipse 3.x Bridge you are
referrng to provide Wrappers to use POJO Implementations using
dependency injection within 3.x.

Best regards

Jonas

Am 30.10.2014 22:38, schrieb Patty Eilers:
> In an attempt to develop an e4 RCP application that references/wraps
> Eclipse 3.x RCP plug-ins, I understand that I must use the compatibility
> layer which is supported by installing the Eclipse 3.x Bridge. However,
> when I attempt to do this I am informed that the e4 Tools and EMF will
> be un-installed as a result.
>
> Has anyone figured out how to get this working in Eclipse Luna 4.4?
Re: Eclipse 3.x Bridge Cannot Be Installed with e4 Tools [message #1457626 is a reply to message #1457346] Fri, 31 October 2014 14:27 Go to previous messageGo to next message
Patty Eilers is currently offline Patty EilersFriend
Messages: 10
Registered: October 2014
Junior Member
Thank you for the prompt reply Jonas. It is the wrappers that I am looking to achieve...so my understanding is that I need to install the Eclipse 3.x Bridge plug-in (in accordance with the tutorial on your site). Is it a one or the other situation--use either 3.x Bridge or e4 Tools since they don't seem to be compatible?
Re: Eclipse 3.x Bridge Cannot Be Installed with e4 Tools [message #1457830 is a reply to message #1457626] Fri, 31 October 2014 19:06 Go to previous messageGo to next message
Patty Eilers is currently offline Patty EilersFriend
Messages: 10
Registered: October 2014
Junior Member
A bit more explanation. I have tried installing the Eclipse 3.x bridge into both Eclipse Luna and Kepler Standard Editions--with the following error (see below). Do I need to go back to an Eclipse 3.x version?

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.14.0.v20131111-1508 (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.14.0.v20131111-1508)
Software currently installed: Eclipse Standard/SDK 2.0.2.20140224-0000 (epp.package.standard 2.0.2.20140224-0000)
Only one of the following can be installed at once:
Eclipse UI Application Services 1.0.0.v20130515-1857 (org.eclipse.e4.ui.services 1.0.0.v20130515-1857)
Eclipse UI Application Services 1.0.1.v20131118-1940 (org.eclipse.e4.ui.services 1.0.1.v20131118-1940)
Eclipse UI Application Services 1.0.1.v20130909-1436 (org.eclipse.e4.ui.services 1.0.1.v20130909-1436)
Cannot satisfy dependency:
From: Eclipse Standard/SDK 2.0.2.20140224-0000 (epp.package.standard 2.0.2.20140224-0000)
To: org.eclipse.epp.package.standard.feature.feature.group [2.0.2.20140224-0000]
Cannot satisfy dependency:
From: Eclipse e4 Rich Client Platform 1.2.2.v20140206-1358 (org.eclipse.e4.rcp.feature.group 1.2.2.v20140206-1358)
To: org.eclipse.e4.ui.services [1.0.1.v20131118-1940]
Cannot satisfy dependency:
From: Eclipse e4 Tools Bridge for 3.x (Incubation) 0.14.0.v20131111-1508 (org.eclipse.e4.tools.e3x.bridge.feature.feature.group 0.14.0.v20131111-1508)
To: org.eclipse.e4.ui.services [1.0.1.v20130909-1436]
Cannot satisfy dependency:
From: Eclipse Standard/SDK Feature 2.0.2.20140224-0000 (org.eclipse.epp.package.standard.feature.feature.group 2.0.2.20140224-0000)
To: org.eclipse.platform.feature.group [4.3.2.v20140221-1852]
Cannot satisfy dependency:
From: Eclipse Platform 4.3.2.v20140221-1852 (org.eclipse.platform.feature.group 4.3.2.v20140221-1852)
To: org.eclipse.rcp.feature.group [4.3.2.v20140221-1700]
Cannot satisfy dependency:
Re: Eclipse 3.x Bridge Cannot Be Installed with e4 Tools [message #1461019 is a reply to message #1457830] Tue, 04 November 2014 05:48 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
I will look into that...

Am 31.10.2014 20:06, schrieb Patty Eilers:
> A bit more explanation. I have tried installing the Eclipse 3.x bridge
> into both Eclipse Luna and Kepler Standard Editions--with the following
> error (see below). Do I need to go back to an Eclipse 3.x version?
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Eclipse e4 Tools Bridge for 3.x (Incubation)
> 0.14.0.v20131111-1508
> (org.eclipse.e4.tools.e3x.bridge.feature.feature.group
> 0.14.0.v20131111-1508)
> Software currently installed: Eclipse Standard/SDK 2.0.2.20140224-0000
> (epp.package.standard 2.0.2.20140224-0000)
> Only one of the following can be installed at once: Eclipse UI
> Application Services 1.0.0.v20130515-1857 (org.eclipse.e4.ui.services
> 1.0.0.v20130515-1857)
> Eclipse UI Application Services 1.0.1.v20131118-1940
> (org.eclipse.e4.ui.services 1.0.1.v20131118-1940)
> Eclipse UI Application Services 1.0.1.v20130909-1436
> (org.eclipse.e4.ui.services 1.0.1.v20130909-1436)
> Cannot satisfy dependency:
> From: Eclipse Standard/SDK 2.0.2.20140224-0000 (epp.package.standard
> 2.0.2.20140224-0000)
> To: org.eclipse.epp.package.standard.feature.feature.group
> [2.0.2.20140224-0000]
> Cannot satisfy dependency:
> From: Eclipse e4 Rich Client Platform 1.2.2.v20140206-1358
> (org.eclipse.e4.rcp.feature.group 1.2.2.v20140206-1358)
> To: org.eclipse.e4.ui.services [1.0.1.v20131118-1940]
> Cannot satisfy dependency:
> From: Eclipse e4 Tools Bridge for 3.x (Incubation)
> 0.14.0.v20131111-1508
> (org.eclipse.e4.tools.e3x.bridge.feature.feature.group
> 0.14.0.v20131111-1508)
> To: org.eclipse.e4.ui.services [1.0.1.v20130909-1436]
> Cannot satisfy dependency:
> From: Eclipse Standard/SDK Feature 2.0.2.20140224-0000
> (org.eclipse.epp.package.standard.feature.feature.group
> 2.0.2.20140224-0000)
> To: org.eclipse.platform.feature.group [4.3.2.v20140221-1852]
> Cannot satisfy dependency:
> From: Eclipse Platform 4.3.2.v20140221-1852
> (org.eclipse.platform.feature.group 4.3.2.v20140221-1852)
> To: org.eclipse.rcp.feature.group [4.3.2.v20140221-1700]
> Cannot satisfy dependency:
Re: Eclipse 3.x Bridge Cannot Be Installed with e4 Tools [message #1461555 is a reply to message #1457830] Tue, 04 November 2014 17:02 Go to previous message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

I have checked. The e4 core tools feature already contains the compat
bundle. The compat for 3.x feature contains everything needed to be
installed for a 3.x Eclipse, so it will not be installable on 4.x.
So as you have already installed the core tools, you are ready to go.

Best regards

Jonas

Am 31.10.2014 20:06, schrieb Patty Eilers:
> A bit more explanation. I have tried installing the Eclipse 3.x bridge
> into both Eclipse Luna and Kepler Standard Editions--with the following
> error (see below). Do I need to go back to an Eclipse 3.x version?
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Eclipse e4 Tools Bridge for 3.x (Incubation)
> 0.14.0.v20131111-1508
> (org.eclipse.e4.tools.e3x.bridge.feature.feature.group
> 0.14.0.v20131111-1508)
> Software currently installed: Eclipse Standard/SDK 2.0.2.20140224-0000
> (epp.package.standard 2.0.2.20140224-0000)
> Only one of the following can be installed at once: Eclipse UI
> Application Services 1.0.0.v20130515-1857 (org.eclipse.e4.ui.services
> 1.0.0.v20130515-1857)
> Eclipse UI Application Services 1.0.1.v20131118-1940
> (org.eclipse.e4.ui.services 1.0.1.v20131118-1940)
> Eclipse UI Application Services 1.0.1.v20130909-1436
> (org.eclipse.e4.ui.services 1.0.1.v20130909-1436)
> Cannot satisfy dependency:
> From: Eclipse Standard/SDK 2.0.2.20140224-0000 (epp.package.standard
> 2.0.2.20140224-0000)
> To: org.eclipse.epp.package.standard.feature.feature.group
> [2.0.2.20140224-0000]
> Cannot satisfy dependency:
> From: Eclipse e4 Rich Client Platform 1.2.2.v20140206-1358
> (org.eclipse.e4.rcp.feature.group 1.2.2.v20140206-1358)
> To: org.eclipse.e4.ui.services [1.0.1.v20131118-1940]
> Cannot satisfy dependency:
> From: Eclipse e4 Tools Bridge for 3.x (Incubation)
> 0.14.0.v20131111-1508
> (org.eclipse.e4.tools.e3x.bridge.feature.feature.group
> 0.14.0.v20131111-1508)
> To: org.eclipse.e4.ui.services [1.0.1.v20130909-1436]
> Cannot satisfy dependency:
> From: Eclipse Standard/SDK Feature 2.0.2.20140224-0000
> (org.eclipse.epp.package.standard.feature.feature.group
> 2.0.2.20140224-0000)
> To: org.eclipse.platform.feature.group [4.3.2.v20140221-1852]
> Cannot satisfy dependency:
> From: Eclipse Platform 4.3.2.v20140221-1852
> (org.eclipse.platform.feature.group 4.3.2.v20140221-1852)
> To: org.eclipse.rcp.feature.group [4.3.2.v20140221-1700]
> Cannot satisfy dependency:
Previous Topic:Shortcuts / Keybinding doesn't work
Next Topic:EditorPart failed with E4
Goto Forum:
  


Current Time: Mon Jan 18 17:53:23 GMT 2021

Powered by FUDForum. Page generated in 0.02030 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top