Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Project building error
Project building error [message #1447663] Sat, 18 October 2014 17:57
Fabiano Bonin is currently offline Fabiano BoninFriend
Messages: 1
Registered: October 2014
Junior Member
Hi, i´m getting this error while building a project.

I already tried to reinstall eclipse from scratch, use a new workspace, delete and re-checkout the project, use eclipse 4.4.0, and still can´t build it.

I can compile and run the project using maven. There are no errors in the classes.

I had this same error some days ago, and after 2 days, after add/remove/edit some source files, it disappeared, and after a week it is happening again.

What can i do to help to find what is happening?

Regards,

Fabiano

What steps will reproduce the problem?
1.
2.
3.


-- Error Details --
Date: Sat Oct 18 14:37:29 BRT 2014
Message: Errors occurred during the build.
Severity: Error
Product: Eclipse 4.4.1.20140925-1820 (org.eclipse.epp.package.jee.product)
Plugin: org.eclipse.core.resources
Session Data:
eclipse.buildId=4.4.1.M20140925-0400
java.version=1.8.0_20
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=pt_BR
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product


-- Error Details --
Date: Sat Oct 18 14:37:29 BRT 2014
Message: Errors running builder 'Java Builder' on project 'PersonalsoftWms'.
Severity: Error
Product: Eclipse 4.4.1.20140925-1820 (org.eclipse.epp.package.jee.product)
Plugin: org.eclipse.jdt.core
Exception Stack Trace:
java.lang.ArrayIndexOutOfBoundsException: 6400
at org.eclipse.jdt.internal.compiler.ClassFile.generateBootstrapMethods(ClassFile.java:3006)
at org.eclipse.jdt.internal.compiler.ClassFile.addAttributes(ClassFile.java:387)
at org.eclipse.jdt.internal.compiler.ast.TypeDeclaration.generateCode(TypeDeclaration.java:577)
at org.eclipse.jdt.internal.compiler.ast.TypeDeclaration.generateCode(TypeDeclaration.java:635)
at org.eclipse.jdt.internal.compiler.ast.CompilationUnitDeclaration.generateCode(CompilationUnitDeclaration.java:368)
at org.eclipse.jdt.internal.compiler.Compiler.process(Compiler.java:781)
at org.eclipse.jdt.internal.compiler.ProcessTaskManager.run(ProcessTaskManager.java:137)
at java.lang.Thread.run(Thread.java:745)
Previous Topic:VERY urgent help required ASAP
Next Topic:Problem with Eclipse Kepler combination (shift + 8)
Goto Forum:
  


Current Time: Sun Oct 20 18:46:36 GMT 2019

Powered by FUDForum. Page generated in 0.02577 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top