Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » change version range validation
change version range validation [message #1444620] Tue, 14 October 2014 10:21 Go to next message
Sven Klemm is currently offline Sven KlemmFriend
Messages: 9
Registered: June 2011
Junior Member
Is there a possibility to adapt or parameterize the equinox bundle version range validation?

e.g. instead of preventing a bundle A with requiring bundle B in version [1.1.0,2.0.0) getting loaded because bundle B is now in version 2.0.0 installed

uc1 working
- bundle A 1.1.0 {require bundle B [1.1.0,2.0.0)}, bundle B 1.3.4

uc2 not working/bundle A is not resolved
- bundle A 1.1.0 {require bundle B [1.1.0,2.0.0)}, bundle B 2.0.0

==> i'd like to only WARN about the unsatified right version range instead of preventing the resolving state
Re: change version range validation [message #1444702 is a reply to message #1444620] Tue, 14 October 2014 12:38 Go to previous message
Thomas Watson is currently offline Thomas WatsonFriend
Messages: 486
Registered: July 2009
Senior Member
There is no way of doing this. I say that, but there is a "hard" way to do something like this, but it requires you to write some advanced Equinox specific hooks that would get down in the guts of the framework and possibly re-write the bundle manifests so that you can open up the ranges. But that would not give you exactly what you want with warning about wiring to versions out of the right side of a range.
Previous Topic:Performance
Next Topic:P2 disable "Installed Software" and "Installation History" tabs
Goto Forum:
  


Current Time: Thu Sep 20 15:02:32 GMT 2018

Powered by FUDForum. Page generated in 0.02303 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top