Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » [Luna] mysterious workspace loaded at first startup
[Luna] mysterious workspace loaded at first startup [message #1444031] Mon, 13 October 2014 14:58 Go to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
I don't know why, but now, when I launch eclipse, it shows a workspace with no projects in it. So, to change workspace, I've to manually select the right one via menu.

This anonymous workspace points to the home: any new project is automatically added to the home folder. It is shown only on the startup.

I tried to see the list of workspaces in Windows>Preferences>General>Startup and Shutdown>Workspaces; no sign of this new workspace.
I aso tried to edit the .../eclipse/configuration/.settings/org.eclipse.ui.ide.prefs file, but again no sign of the home workspace.
Even if, from other workspaces, I select File>Switch Workspace, there is no sign of it; instead, from this "anonymous" workspace, if I select File>Switch Workspace, it shows ALL the workspaces.
Also the "Prompt for workspace on startup" option doesn't work.
What's going on?
Re: [Luna] mysterious workspace loaded at first startup [message #1444077 is a reply to message #1444031] Mon, 13 October 2014 15:50 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3518
Registered: July 2009
Senior Member

How do you launch this copy of Eclipse? Is it forcing a specific workspace directory with the -data switch?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: [Luna] mysterious workspace loaded at first startup [message #1444081 is a reply to message #1444077] Mon, 13 October 2014 15:52 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Nitin Dahyabhai wrote on Mon, 13 October 2014 15:50
How do you launch this copy of Eclipse? Is it forcing a specific workspace directory with the -data switch?


I don't know anything of this option, so I don't think so. I'm on Ubuntu and I have the eclipse folder under /opt. I launch it via terminal without any further options and, until now, it always displayed the last closed workspace on startup.
Re: [Luna] mysterious workspace loaded at first startup [message #1444132 is a reply to message #1444081] Mon, 13 October 2014 17:30 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Do you have an eclipse.ini file in the directory where the eclipse executable lives? What are its contents?
Also, did you download and install eclipse from www.eclipse.org ?

[Updated on: Mon, 13 October 2014 17:31]

Report message to a moderator

Re: [Luna] mysterious workspace loaded at first startup [message #1444250 is a reply to message #1444132] Mon, 13 October 2014 21:33 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Eric Rizzo wrote on Mon, 13 October 2014 17:30
did you download and install eclipse from www.eclipse.org ?

sure. As said, Eclipse works great until yesterday. I don't know what happens, maybe it's due to some setting preference?
Eric Rizzo wrote on Mon, 13 October 2014 17:30
Do you have an eclipse.ini file in the directory where the eclipse executable lives? What are its contents?

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-startup
/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.library
/opt/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326
-vmargs
-Dosgi.requiredJavaVersion=1.6
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m


Re: [Luna] mysterious workspace loaded at first startup [message #1444273 is a reply to message #1444250] Mon, 13 October 2014 22:20 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3518
Registered: July 2009
Senior Member

Are you now, or have you ever, run it as root?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: [Luna] mysterious workspace loaded at first startup [message #1444474 is a reply to message #1444273] Tue, 14 October 2014 05:49 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Nitin Dahyabhai wrote on Mon, 13 October 2014 22:20
Are you now, or have you ever, run it as root?

Not now and not usually, but yes, I think it's happened a few times. Btw, I never launched it as root in the past few days.

[Updated on: Tue, 14 October 2014 05:50]

Report message to a moderator

Re: [Luna] mysterious workspace loaded at first startup [message #1445533 is a reply to message #1444474] Wed, 15 October 2014 15:17 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
bump, any idea?
Re: [Luna] mysterious workspace loaded at first startup [message #1445577 is a reply to message #1445533] Wed, 15 October 2014 16:26 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3518
Registered: July 2009
Senior Member

Download another copy from eclipse.org, keep it somewhere under your home directory, and run that one? And never as root.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: [Luna] mysterious workspace loaded at first startup [message #1445581 is a reply to message #1445577] Wed, 15 October 2014 16:34 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Nitin Dahyabhai wrote on Wed, 15 October 2014 16:26
Download another copy from eclipse.org, keep it somewhere under your home directory, and run that one? And never as root.

Well, this is not the solution I was looking for. I have of plugins installed and I don't want to reinstall all from the start.
Also, I never launched eclipse with root option in the past few weeks; the problem appears from nothing some days ago.
Re: [Luna] mysterious workspace loaded at first startup [message #1445609 is a reply to message #1445581] Wed, 15 October 2014 17:31 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Can you be certain that you're running the copy of Eclipse that you think you are (for example, using "which eclipse" and/or going to the folder where your intended Eclipse lives and running "./eclipse)?"
Re: [Luna] mysterious workspace loaded at first startup [message #1445610 is a reply to message #1445609] Wed, 15 October 2014 17:34 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Eric Rizzo wrote on Wed, 15 October 2014 17:31
Can you be certain that you're running the copy of Eclipse that you think you are (for example, using "which eclipse" and/or going to the folder where your intended Eclipse lives and running "./eclipse)?"

sure, I'm also launching eclipse from terminal sometimes (going to /opt/eclipse and running ./eclipse) and I have the same problems.
$>which eclipse
/usr/bin/eclipse
$>ls -Al /usr/bin | grep eclipse
lrwxrwxrwx 1 root   root          20 set 24  2013 eclipse -> /opt/eclipse/eclipse

Re: [Luna] mysterious workspace loaded at first startup [message #1445664 is a reply to message #1445610] Wed, 15 October 2014 19:19 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Hmm, very strange. One more triple-check:
Open the About Eclipse dialog and click the Installation Details button. The go to the Configuration tab. Once the data loads, look for eclipse.home.location and tell what the value is.
Actually, you could paste in the whole first part of that Configuration data, up until the *** Features line. Maybe something in there will give a clue as to what's going on.

[Updated on: Wed, 15 October 2014 19:20]

Report message to a moderator

Re: [Luna] mysterious workspace loaded at first startup [message #1445685 is a reply to message #1445664] Wed, 15 October 2014 20:04 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Eric Rizzo wrote on Wed, 15 October 2014 19:19
...

Quote:

*** Date: Wednesday, October 15, 2014 at 10:00:37 PM Central European Summer Time

*** Platform Details:

*** System properties:
applicationXMI=org.eclipse.ui.workbench/LegacyIDE.e4xmi
awt.toolkit=sun.awt.X11.XToolkit
eclipse.application=org.eclipse.ui.ide.workbench
eclipse.buildId=4.4.1.M20140925-0400
eclipse.commands=-data
/media/Data/Personal Folder/Programming/Eclipse/ComputazionePervasiva
-os
linux
-ws
gtk
-arch
x86_64
-showsplash
/opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp
-launcher
/opt/eclipse/eclipse
-name
Eclipse
--launcher.library
/opt/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326/eclipse_1605.so
-startup
/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.appendVmargs
-exitdata
2e8018
-product
org.eclipse.epp.package.jee.product
-vm
/usr/bin/java
eclipse.home.location=file:/opt/eclipse/
eclipse.launcher=/opt/eclipse/eclipse
eclipse.launcher.name=Eclipse
eclipse.p2.data.area=@config.dir/../p2/
eclipse.p2.profile=epp.package.jee
eclipse.product=org.eclipse.epp.package.jee.product
eclipse.startTime=1413385294028
eclipse.stateSaveDelayInterval=30000
eclipse.vm=/usr/bin/java
eclipse.vmargs=-Dosgi.requiredJavaVersion=1.6
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar
/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
equinox.use.ds=true
file.encoding=UTF-8
file.encoding.pkg=sun.io
file.separator=/
gosh.args=--nointeractive
guice.disable.misplaced.annotation.check=true
java.awt.graphicsenv=sun.awt.X11GraphicsEnvironment
java.awt.printerjob=sun.print.PSPrinterJob
java.class.path=/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
java.class.version=52.0
java.endorsed.dirs=/usr/lib/jvm/java-8-oracle/jre/lib/endorsed
java.ext.dirs=/usr/lib/jvm/java-8-oracle/jre/lib/ext:/usr/java/packages/lib/ext
java.home=/usr/lib/jvm/java-8-oracle/jre
java.io.tmpdir=/tmp
java.library.path=/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
java.runtime.name=Java(TM) SE Runtime Environment
java.runtime.version=1.8.0_20-b26
java.specification.name=Java Platform API Specification
java.specification.vendor=Oracle Corporation
java.specification.version=1.8
java.vendor=Oracle Corporation
java.vendor.url=http://java.oracle.com/
java.vendor.url.bug=http://bugreport.sun.com/bugreport/
java.version=1.8.0_20
java.vm.info=mixed mode
java.vm.name=Java HotSpot(TM) 64-Bit Server VM
java.vm.specification.name=Java Virtual Machine Specification
java.vm.specification.vendor=Oracle Corporation
java.vm.specification.version=1.8
java.vm.vendor=Oracle Corporation
java.vm.version=25.20-b23
line.separator=

org.apache.commons.logging.Log=org.apache.commons.logging.impl.NoOpLog
org.eclipse.debug.ui.breakpoints.toggleFactoriesUsed=true
org.eclipse.equinox.launcher.splash.location=/opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp
org.eclipse.equinox.simpleconfigurator.configUrl=file:org.eclipse.equinox.simpleconfigurator/bundles.info
org.eclipse.m2e.log.dir=/media/Data/Personal Folder/Programming/Eclipse/ComputazionePervasiva/.metadata/.plugins/org.eclipse.m2e.logback.configuration
org.eclipse.swt.browser.DefaultType=mozilla
org.eclipse.swt.browser.MozillaFactoriesRegistered=true
org.eclipse.swt.browser.XULRunnerInitialized=true
org.eclipse.swt.browser.XULRunnerPath=/opt/eclipse/plugins/org.mozilla.xulrunner.gtk.linux.x86_64_1.9.2.19pre/xulrunner
org.eclipse.swt.internal.gtk.useCairo=true
org.eclipse.update.reconcile=false
org.jboss.tools.resolved.remote.properties=examples.categories.url|jbosstools|4.2=http://download.jboss.org/jbosstools/examples/project-examples-category-4.2.xml
maven.examples.url|jbosstools|4.2=http://download.jboss.org/jbosstools/examples/project-examples-maven-4.2.GA.xml
jboss.discovery.site.url|jbosstools|4.2.0=http://download.jboss.org/jbosstools/updates/development/luna/central/core/
jboss.discovery.directory.url|jbosstools|4.2.0=http://download.jboss.org/jbosstools/updates/development/luna/jbosstools-directory.xml
buzz.feed.url=http://planet.jboss.org/feeds/buzz
jboss.discovery.earlyaccess.list.url|jbosstools|4.2.0=http://download.jboss.org/jbosstools/updates/development/luna/jbosstools-earlyaccess.properties
jboss.discovery.earlyaccess.site.url|jbosstools|4.2.0=http://download.jboss.org/jbosstools/earlyaccess/development/luna/
community.examples.url|jbosstools|4.2=http://download.jboss.org/jbosstools/examples/project-examples-community-4.2.Beta2.xml
portal.examples.url|jbosstools|4.2=http://download.jboss.org/gatein/quickstarts/jboss-portal-6.2/project-examples-jboss-portal6.2-jbds8.0-001.xml
featured.examples.url|jbosstools|4.2=http://download.jboss.org/jbosstools/examples/project-examples-shared-4.2.GA.xml

org.osgi.framework.executionenvironment=OSGi/Minimum-1.0,OSGi/Minimum-1.1,OSGi/Minimum-1.2,JavaSE/compact1-1.8,JavaSE/compact2-1.8,JavaSE/compact3-1.8,JRE-1.1,J2SE-1.2,J2SE-1.3,J2SE-1.4,J2SE-1.5,JavaSE-1.6,JavaSE-1.7,JavaSE-1.8
org.osgi.framework.language=en
org.osgi.framework.os.name=Linux
org.osgi.framework.os.version=3.13.0
org.osgi.framework.processor=x86-64
org.osgi.framework.system.capabilities=osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2",osgi.ee; osgi.ee="JRE"; version:List<Version>="1.0, 1.1",osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7, 1.8",osgi.ee; osgi.ee="JavaSE/compact1"; version:List<Version>="1.8",osgi.ee; osgi.ee="JavaSE/compact2"; version:List<Version>="1.8",osgi.ee; osgi.ee="JavaSE/compact3"; version:List<Version>="1.8"
org.osgi.framework.system.packages=<...content trimmed...>
org.osgi.framework.uuid=2028c027-7c54-0014-1f28-9b8978f7b73a
org.osgi.framework.vendor=Eclipse
org.osgi.framework.version=1.8.0
org.osgi.supports.framework.extension=true
org.osgi.supports.framework.fragment=true
org.osgi.supports.framework.requirebundle=true
os.arch=amd64
os.name=Linux
os.version=3.13.0-37-generic
osgi.arch=x86_64
osgi.bundles=reference:file:org.eclipse.osgi.compatibility.state_1.0.1.v20140709-1414.jar,reference:file:org.eclipse.equinox.weaving.hook_1.1.100.weaving-hook-20140821.jar,reference:file:org.eclipse.fx.osgi_1.0.0.201408250501.jar,reference:file:org.eclipse.equinox.simpleconfigurator_1.1.0.v20131217-1203.jar@1:start
osgi.bundles.defaultStartLevel=4
osgi.compatibility.bootdelegation=true
osgi.configuration.area=file:/opt/eclipse/configuration/
osgi.configuration.area.default=null
osgi.framework=file:/opt/eclipse/plugins/org.eclipse.osgi_3.10.1.v20140909-1633.jar
osgi.framework.extensions=reference:file:org.eclipse.osgi.compatibility.state_1.0.1.v20140709-1414.jar,reference:file:org.eclipse.equinox.weaving.hook_1.1.100.weaving-hook-20140821.jar,reference:file:org.eclipse.fx.osgi_1.0.0.201408250501.jar
osgi.framework.shape=jar
osgi.framework.useSystemProperties=true
osgi.frameworkClassPath=., file:/opt/eclipse/plugins/org.eclipse.osgi.compatibility.state_1.0.1.v20140709-1414.jar, file:/opt/eclipse/plugins/org.eclipse.equinox.weaving.hook_1.1.100.weaving-hook-20140821.jar, file:/opt/eclipse/plugins/org.eclipse.fx.osgi_1.0.0.201408250501.jar
osgi.install.area=file:/opt/eclipse/
osgi.instance.area=file:/media/Data/Personal Folder/Programming/Eclipse/ComputazionePervasiva/
osgi.instance.area.default=file:/home/xxx/
osgi.logfile=/media/Data/Personal Folder/Programming/Eclipse/ComputazionePervasiva/.metadata/.log
osgi.nl=en_US
osgi.os=linux
osgi.requiredJavaVersion=1.6
osgi.splashLocation=/opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp
osgi.splashPath=platform:/base/plugins/org.eclipse.platform
osgi.syspath=/opt/eclipse/plugins
osgi.tracefile=/media/Data/Personal Folder/Programming/Eclipse/ComputazionePervasiva/.metadata/trace.log
osgi.user.area=file:/home/xxx/user/
osgi.user.area.default=null
osgi.ws=gtk
path.separator=:
product.home=/opt/eclipse/plugins/org.jboss.tools.common.model_3.6.0.CR1-v20140829-2038-B51/
securerandom.source=file:/dev/./urandom
sun.arch.data.model=64
sun.boot.class.path=/usr/lib/jvm/java-8-oracle/jre/lib/resources.jar:/usr/lib/jvm/java-8-oracle/jre/lib/rt.jar:/usr/lib/jvm/java-8-oracle/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jsse.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jce.jar:/usr/lib/jvm/java-8-oracle/jre/lib/charsets.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jfr.jar:/usr/lib/jvm/java-8-oracle/jre/classes
sun.boot.library.path=/usr/lib/jvm/java-8-oracle/jre/lib/amd64
sun.cpu.endian=little
sun.cpu.isalist=
sun.desktop=gnome
sun.font.fontmanager=sun.awt.X11FontManager
sun.io.unicode.encoding=UnicodeLittle
sun.java.command=/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar -data /media/Data/Personal Folder/Programming/Eclipse/ComputazionePervasiva -os linux -ws gtk -arch x86_64 -showsplash /opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp -launcher /opt/eclipse/eclipse -name Eclipse --launcher.library /opt/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326/eclipse_1605.so -startup /opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar --launcher.appendVmargs -exitdata 2e8018 -product org.eclipse.epp.package.jee.product -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=256m -Xms40m -Xmx512m -jar /opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
sun.java.launcher=SUN_STANDARD
sun.jnu.encoding=UTF-8
sun.management.compiler=HotSpot 64-Bit Tiered Compilers
sun.os.patch.level=unknown
user.country=US
user.dir=/home/xxx
user.home=/home/xxx
user.language=en
user.name=xxx
user.timezone=Europe/Rome


[Updated on: Thu, 16 October 2014 12:45] by Moderator

Report message to a moderator

Re: [Luna] mysterious workspace loaded at first startup [message #1446157 is a reply to message #1445685] Thu, 16 October 2014 12:49 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
These lines tell us that something in the way you launch Eclipse is specifying a workspace:
eclipse.commands=-data
/media/Data/Personal Folder/Programming/Eclipse/ComputazionePervasiva


The -data command instructs Eclipse to load that workspace and ignore the "Show workspace selection at start-up" setting.

So the question now is, what about the way you launch Eclipse is inserting that? One brutish way to find out would be to search your file system for that text (either "-data" or the name of the workspace that comes after it).
Re: [Luna] mysterious workspace loaded at first startup [message #1446169 is a reply to message #1446157] Thu, 16 October 2014 12:59 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Eric Rizzo wrote on Thu, 16 October 2014 12:49
These lines tell us that something in the way you launch Eclipse is specifying a workspace:
eclipse.commands=-data
/media/Data/Personal Folder/Programming/Eclipse/ComputazionePervasiva


The -data command instructs Eclipse to load that workspace and ignore the "Show workspace selection at start-up" setting.

So the question now is, what about the way you launch Eclipse is inserting that? One brutish way to find out would be to search your file system for that text (either "-data" or the name of the workspace that comes after it).

Sure, it launchs the last used workspace and (if it worked) it's great. The actual problem is that it launchs the "/home/xxx" workspace and not the last used one; and again, there is no track of this workspace anywhere.
Re: [Luna] mysterious workspace loaded at first startup [message #1446172 is a reply to message #1446169] Thu, 16 October 2014 13:03 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
What you're saying and what what the evidence says (the configuration details you posted) are two different things. Which is it?
Re: [Luna] mysterious workspace loaded at first startup [message #1446186 is a reply to message #1446172] Thu, 16 October 2014 13:20 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Eric Rizzo wrote on Thu, 16 October 2014 13:03
What you're saying and what what the evidence says (the configuration details you posted) are two different things. Which is it?

Evidence is that I normally launch eclipse via terminal
cd /opt/eclipse
./eclipse

or via an icon launcher, in both cases without any further command. Btw, after reading again the details, I think tjat maybe the problem is related with the equinox launcher. Not sure about that tbh.
$>./eclipse
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
org.eclipse.m2e.logback.configuration: The org.eclipse.m2e.logback.configuration bundle was activated before the state location was initialized.  Will retry after the state location is initialized.
org.eclipse.m2e.logback.configuration: Logback config file: /opt/eclipse/.metadata/.plugins/org.eclipse.m2e.logback.configuration/logback.1.5.0.20140606-0033.xml
org.eclipse.m2e.logback.configuration: SLF4J logger factory class: org.slf4j.helpers.SubstituteLoggerFactory
org.eclipse.m2e.logback.configuration: SLF4J logger factory class: org.slf4j.helpers.SubstituteLoggerFactory
org.eclipse.m2e.logback.configuration: Initializing logback
java.lang.ClassCastException: org.eclipse.osgi.internal.framework.EquinoxConfiguration$1 cannot be cast to java.lang.String
	at org.eclipse.m2e.logback.configuration.LogHelper.logJavaProperties(LogHelper.java:26)
	at org.eclipse.m2e.logback.configuration.LogPlugin.loadConfiguration(LogPlugin.java:189)
	at org.eclipse.m2e.logback.configuration.LogPlugin.configureLogback(LogPlugin.java:144)
	at org.eclipse.m2e.logback.configuration.LogPlugin.access$2(LogPlugin.java:107)
	at org.eclipse.m2e.logback.configuration.LogPlugin$1.run(LogPlugin.java:62)
	at java.util.TimerThread.mainLoop(Timer.java:555)
	at java.util.TimerThread.run(Timer.java:505)
[INFO] Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.
[INFO] Setting property: velocimacro.messages.on => 'false'.
[INFO] Setting property: resource.loader => 'classpath'.
[INFO] Setting property: resource.manager.logwhenfound => 'false'.
log4j:WARN No appenders could be found for logger (org.springsource.ide.eclipse.commons.core.templates.TemplateProcessor).
log4j:WARN Please initialize the log4j system properly.

There is also a bug opened for this
https://bugs.eclipse.org/bugs/show_bug.cgi?id=445122

[Updated on: Thu, 16 October 2014 13:23]

Report message to a moderator

Re: [Luna] mysterious workspace loaded at first startup [message #1448322 is a reply to message #1446186] Sun, 19 October 2014 19:45 Go to previous messageGo to next message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Another update. The previous configuration (Installation Details> Configuration) was loaded when I've yet loaded the target workspace. Instead, this shown below is the same output taken from the mysterious workspace. Hope this help.

Quote:

*** Date: Sunday, October 19, 2014 at 9:37:59 PM Central European Summer Time

*** Platform Details:

*** System properties:
applicationXMI=org.eclipse.ui.workbench/LegacyIDE.e4xmi
awt.toolkit=sun.awt.X11.XToolkit
eclipse.application=org.eclipse.ui.ide.workbench
eclipse.buildId=4.4.1.M20140925-0400
eclipse.commands=-os
linux
-ws
gtk
-arch
x86_64
-showsplash
/opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp
-launcher
/opt/eclipse/eclipse
-name
Eclipse
--launcher.library
/opt/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326/eclipse_1605.so
-startup
/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.appendVmargs
-exitdata
4064800c
-product
org.eclipse.epp.package.jee.product
-vm
/usr/bin/java
eclipse.home.location=file:/opt/eclipse/
eclipse.launcher=/opt/eclipse/eclipse
eclipse.launcher.name=Eclipse
eclipse.p2.data.area=@config.dir/../p2/
eclipse.p2.profile=epp.package.jee
eclipse.product=org.eclipse.epp.package.jee.product
eclipse.startTime=1413747456898
eclipse.stateSaveDelayInterval=30000
eclipse.vm=/usr/bin/java
eclipse.vmargs=-Dosgi.requiredJavaVersion=1.6
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
-jar
/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
equinox.use.ds=true
file.encoding=UTF-8
file.encoding.pkg=sun.io
file.separator=/
gosh.args=--nointeractive
guice.disable.misplaced.annotation.check=true
java.awt.graphicsenv=sun.awt.X11GraphicsEnvironment
java.awt.printerjob=sun.print.PSPrinterJob
java.class.path=/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
java.class.version=52.0
java.endorsed.dirs=/usr/lib/jvm/java-8-oracle/jre/lib/endorsed
java.ext.dirs=/usr/lib/jvm/java-8-oracle/jre/lib/ext:/usr/java/packages/lib/ext
java.home=/usr/lib/jvm/java-8-oracle/jre
java.io.tmpdir=/tmp
java.library.path=/usr/lib/nvidia-331/:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
java.runtime.name=Java(TM) SE Runtime Environment
java.runtime.version=1.8.0_25-b17
java.specification.name=Java Platform API Specification
java.specification.vendor=Oracle Corporation
java.specification.version=1.8
java.vendor=Oracle Corporation
java.vendor.url=http://java.oracle.com/
java.vendor.url.bug=http://bugreport.sun.com/bugreport/
java.version=1.8.0_25
java.vm.info=mixed mode
java.vm.name=Java HotSpot(TM) 64-Bit Server VM
java.vm.specification.name=Java Virtual Machine Specification
java.vm.specification.vendor=Oracle Corporation
java.vm.specification.version=1.8
java.vm.vendor=Oracle Corporation
java.vm.version=25.25-b02
line.separator=

org.apache.commons.logging.Log=org.apache.commons.logging.impl.NoOpLog
org.eclipse.debug.ui.breakpoints.toggleFactoriesUsed=true
org.eclipse.equinox.launcher.splash.location=/opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp
org.eclipse.equinox.simpleconfigurator.configUrl=file:org.eclipse.equinox.simpleconfigurator/bundles.info
org.eclipse.m2e.log.dir=/home/xxx/.metadata/.plugins/org.eclipse.m2e.logback.configuration
org.eclipse.swt.internal.gtk.useCairo=true
org.eclipse.update.reconcile=false
org.eclipse.update.resolution_url=
org.osgi.framework.executionenvironment=OSGi/Minimum-1.0,OSGi/Minimum-1.1,OSGi/Minimum-1.2,JavaSE/compact1-1.8,JavaSE/compact2-1.8,JavaSE/compact3-1.8,JRE-1.1,J2SE-1.2,J2SE-1.3,J2SE-1.4,J2SE-1.5,JavaSE-1.6,JavaSE-1.7,JavaSE-1.8
org.osgi.framework.language=en
org.osgi.framework.os.name=Linux
org.osgi.framework.os.version=3.13.0
org.osgi.framework.processor=x86-64
org.osgi.framework.system.capabilities=osgi.ee; osgi.ee="OSGi/Minimum"; version:List<Version>="1.0, 1.1, 1.2",osgi.ee; osgi.ee="JRE"; version:List<Version>="1.0, 1.1",osgi.ee; osgi.ee="JavaSE"; version:List<Version>="1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7, 1.8",osgi.ee; osgi.ee="JavaSE/compact1"; version:List<Version>="1.8",osgi.ee; osgi.ee="JavaSE/compact2"; version:List<Version>="1.8",osgi.ee; osgi.ee="JavaSE/compact3"; version:List<Version>="1.8"
org.osgi.framework.system.packages=<content truncated>
org.osgi.framework.uuid=402fed61-c757-0014-1f16-ed19c45e2914
org.osgi.framework.vendor=Eclipse
org.osgi.framework.version=1.8.0
org.osgi.supports.framework.extension=true
org.osgi.supports.framework.fragment=true
org.osgi.supports.framework.requirebundle=true
os.arch=amd64
os.name=Linux
os.version=3.13.0-37-generic
osgi.arch=x86_64
osgi.bundles=reference:file:org.eclipse.osgi.compatibility.state_1.0.1.v20140709-1414.jar,reference:file:org.eclipse.equinox.weaving.hook_1.1.100.weaving-hook-20140821.jar,reference:file:org.eclipse.fx.osgi_1.0.0.201408150502.jar,reference:file:org.eclipse.equinox.simpleconfigurator_1.1.0.v20131217-1203.jar@1:start
osgi.bundles.defaultStartLevel=4
osgi.compatibility.bootdelegation=true
osgi.configuration.area=file:/opt/eclipse/configuration/
osgi.configuration.area.default=null
osgi.framework=file:/opt/eclipse/plugins/org.eclipse.osgi_3.10.1.v20140909-1633.jar
osgi.framework.extensions=reference:file:org.eclipse.osgi.compatibility.state_1.0.1.v20140709-1414.jar,reference:file:org.eclipse.equinox.weaving.hook_1.1.100.weaving-hook-20140821.jar,reference:file:org.eclipse.fx.osgi_1.0.0.201408150502.jar
osgi.framework.shape=jar
osgi.framework.useSystemProperties=true
osgi.frameworkClassPath=., file:/opt/eclipse/plugins/org.eclipse.osgi.compatibility.state_1.0.1.v20140709-1414.jar, file:/opt/eclipse/plugins/org.eclipse.equinox.weaving.hook_1.1.100.weaving-hook-20140821.jar, file:/opt/eclipse/plugins/org.eclipse.fx.osgi_1.0.0.201408150502.jar
osgi.install.area=file:/opt/eclipse/
osgi.instance.area=file:/home/xxx/
osgi.instance.area.default=file:/home/xxx/
osgi.logfile=/home/xxx/.metadata/.log
osgi.nl=en_US
osgi.os=linux
osgi.requiredJavaVersion=1.6
osgi.splashLocation=/opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp
osgi.splashPath=platform:/base/plugins/org.eclipse.platform
osgi.syspath=/opt/eclipse/plugins
osgi.tracefile=/home/xxx/.metadata/trace.log
osgi.user.area=null
osgi.user.area.default=null
osgi.ws=gtk
path.separator=:
securerandom.source=file:/dev/./urandom
sun.arch.data.model=64
sun.boot.class.path=/usr/lib/jvm/java-8-oracle/jre/lib/resources.jar:/usr/lib/jvm/java-8-oracle/jre/lib/rt.jar:/usr/lib/jvm/java-8-oracle/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jsse.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jce.jar:/usr/lib/jvm/java-8-oracle/jre/lib/charsets.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jfr.jar:/usr/lib/jvm/java-8-oracle/jre/classes
sun.boot.library.path=/usr/lib/jvm/java-8-oracle/jre/lib/amd64
sun.cpu.endian=little
sun.cpu.isalist=
sun.desktop=gnome
sun.io.unicode.encoding=UnicodeLittle
sun.java.command=/opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar -os linux -ws gtk -arch x86_64 -showsplash /opt/eclipse//plugins/org.eclipse.platform_4.4.0.v20140925-0400/splash.bmp -launcher /opt/eclipse/eclipse -name Eclipse --launcher.library /opt/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326/eclipse_1605.so -startup /opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar --launcher.appendVmargs -exitdata 4064800c -product org.eclipse.epp.package.jee.product -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=256m -Xms40m -Xmx512m -jar /opt/eclipse/plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
sun.java.launcher=SUN_STANDARD
sun.jnu.encoding=UTF-8
sun.management.compiler=HotSpot 64-Bit Tiered Compilers
sun.os.patch.level=unknown
user.country=US
user.dir=/home/xxx
user.home=/home/xxx
user.language=en
user.name=xxx
user.timezone=Europe/Rome


[Updated on: Mon, 20 October 2014 13:46] by Moderator

Report message to a moderator

Re: [Luna] mysterious workspace loaded at first startup [message #1448819 is a reply to message #1448322] Mon, 20 October 2014 13:46 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
It's not clear what you're trying now. The configuration details above do not include the -data option that loads a specific workspace; the info suggests that it was running on a workspace at /home/xxx/
Can you be more specific and detailed about what you're doing when you post these details, and what behavior you're observing?
Re: [Luna] mysterious workspace loaded at first startup [message #1448831 is a reply to message #1448819] Mon, 20 October 2014 14:02 Go to previous message
Simone Perriello is currently offline Simone PerrielloFriend
Messages: 25
Registered: October 2014
Junior Member
Eric Rizzo wrote on Mon, 20 October 2014 13:46
It's not clear what you're trying now. The configuration details above do not include the -data option that loads a specific workspace; the info suggests that it was running on a workspace at /home/xxx/
Can you be more specific and detailed about what you're doing when you post these details, and what behavior you're observing?

Sure.
I'll post a short summary.
These are the steps that now I'm forcing to execute in order to have a working workspace:

  1. I launch eclipse (without any further options)
  2. -----it shows the anonymous workspace (no projects and so on)
  3. I switch workspace File>Switch workspace>WhateverWorkspace
  4. -----it shows the WhateverWorkspace

Now, if I click on File>Switch workspace there is no track of the anonymous workspace. However, if, after step 2, I create a new project, this is created in the home directory. So, the anonymous workspace points to my home and I don't know why.

Regarding the configuration details, the first one that I posted are taken from step 4 (so when I'm working on the WhateverWorkspace), while the second ones are taken from step 2 (so when I'm working on the anonymous workspace).

Hope this helps a little bit more.

[Updated on: Mon, 20 October 2014 15:45]

Report message to a moderator

Previous Topic:FDT creating a project
Next Topic:Using ADT
Goto Forum:
  


Current Time: Thu Oct 24 01:55:25 GMT 2019

Powered by FUDForum. Page generated in 0.04016 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top