Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EMF Forms] Stable version for experiment(combination of versions: Java, EMF Forms, eclipse modeling project etc.)
[EMF Forms] Stable version for experiment [message #1441305] Thu, 09 October 2014 14:39 Go to next message
Akira Tanaka is currently offline Akira TanakaFriend
Messages: 86
Registered: March 2010
Member
Hello,

I am revisiting EMF Forms and having some difficulty in IDE setup. Could anybody share thought on [relatively] stable combination of versions for
- Java (8, 7, 6?)
- EMF Forms (1.2, 1.3, 1.4?)
- Eclipse Modeling Project package (Luna SR1?, Luna v1, Kepler SR2, ... ) ?

At this stage, I am just interested in basic functionalities without errors in console. BTW, I am working on Mac.

Thank you for any help in advance.
Akira
Re: [EMF Forms] Stable version for experiment [message #1441866 is a reply to message #1441305] Fri, 10 October 2014 09:36 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

what are the problem with your IDE set-up? Could you describe that more
in detail?
Have you followed this:
http://eclipsesource.com/blogs/tutorials/getting-started-with-EMF-Forms/
?
Java Version does not really matter. Please always use the latest
version, Luna SR1 (already contains 1.4.0). In the meantime 1.4.1 is
available so you can update Luna SR1 with 1.4.1 of EMF Forms

Best regards

Jonas

Am 09.10.2014 16:39, schrieb Akira Tanaka:
> Hello,
>
> I am revisiting EMF Forms and having some difficulty in IDE setup.
> Could anybody share thought on [relatively] stable combination of
> versions for
> - Java (8, 7, 6?)
> - EMF Forms (1.2, 1.3, 1.4?)
> - Eclipse Modeling Project package (Luna SR1?, Luna v1, Kepler SR2, ... ) ?
>
> At this stage, I am just interested in basic functionalities without
> errors in console. BTW, I am working on Mac.
>
> Thank you for any help in advance.
> Akira
>
Re: [EMF Forms] Stable version for experiment [message #1442029 is a reply to message #1441866] Fri, 10 October 2014 14:19 Go to previous messageGo to next message
Akira Tanaka is currently offline Akira TanakaFriend
Messages: 86
Registered: March 2010
Member
Hello Jonas,

Thank you for the response. I tried again to fresh install everything, and it works now. Thank you very much. I can proceed with this setup. However, just in case, I tried yesterday's setup, I get error messages when launching run configuration. Other modeling components like Acceleo might have impact(?).

!SESSION 2014-10-10 22:36:34.470 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_51
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=ja_JP
Framework arguments:  -application org.eclipse.emf.ecp.application.e3.application
Command-line arguments:  -application org.eclipse.emf.ecp.application.e3.application -data /Users/atanaka/Desktop/Luna/Modeling/workspace-acceleo/../runtime-EclipseApplication -dev file:/Users/atanaka/Desktop/Luna/Modeling/workspace-acceleo/.metadata/.plugins/org.eclipse.pde.core/Eclipse Application/dev.properties -os macosx -ws cocoa -arch x86_64 -consoleLog

!ENTRY org.eclipse.amalgam.discovery.modeling 4 0 2014-10-10 22:36:35.721
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.amalgam.discovery.modeling [83]
  Unresolved requirement: Require-Bundle: org.eclipse.amalgam.discovery.ui; bundle-version="1.0.0"
    -> Bundle-SymbolicName: org.eclipse.amalgam.discovery.ui; bundle-version="1.5.0.201404290822"; singleton:="true"
       org.eclipse.amalgam.discovery.ui [84]
         Unresolved requirement: Require-Bundle: org.eclipse.equinox.p2.ui
           -> Bundle-SymbolicName: org.eclipse.equinox.p2.ui; bundle-version="2.3.0.v20140404-1657"; singleton:="true"
              org.eclipse.equinox.p2.ui [442]
                Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.director
                  -> Export-Package: org.eclipse.equinox.internal.p2.director; bundle-version="2.3.100.v20140224-1921"; bundle-symbolic-name="org.eclipse.equinox.p2.director"; version="0.0.0"; x-friends:="org.eclipse.equinox.p2.operations,  org.eclipse.equinox.p2.repository.tools,  org.eclipse.pde.core,  org.eclipse.equinox.p2.reconciler.dropins,  org.eclipse.equinox.p2.ui,  org.eclipse.equinox.p2.director.app"
                     org.eclipse.equinox.p2.director [421]
                       Unresolved requirement: Import-Package: org.eclipse.equinox.internal.provisional.configurator

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.amalgam.discovery.ui 4 0 2014-10-10 22:36:35.724
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.amalgam.discovery.ui [84]
  Unresolved requirement: Require-Bundle: org.eclipse.equinox.p2.ui
    -> Bundle-SymbolicName: org.eclipse.equinox.p2.ui; bundle-version="2.3.0.v20140404-1657"; singleton:="true"
       org.eclipse.equinox.p2.ui [442]
         Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.director
           -> Export-Package: org.eclipse.equinox.internal.p2.director; bundle-version="2.3.100.v20140224-1921"; bundle-symbolic-name="org.eclipse.equinox.p2.director"; version="0.0.0"; x-friends:="org.eclipse.equinox.p2.operations,  org.eclipse.equinox.p2.repository.tools,  org.eclipse.pde.core,  org.eclipse.equinox.p2.reconciler.dropins,  org.eclipse.equinox.p2.ui,  org.eclipse.equinox.p2.director.app"
              org.eclipse.equinox.p2.director [421]
                Unresolved requirement: Import-Package: org.eclipse.equinox.internal.provisional.configurator

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ant.launching 4 0 2014-10-10 22:36:35.728
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ant.launching [86]
  Unresolved requirement: Require-Bundle: org.eclipse.debug.core; bundle-version="[3.9.0,4.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.ant.ui 4 0 2014-10-10 22:36:35.734
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ant.ui [87]
  Unresolved requirement: Require-Bundle: org.eclipse.ui.externaltools; bundle-version="[3.2.0,4.0.0)"
    -> Bundle-SymbolicName: org.eclipse.ui.externaltools; bundle-version="3.2.300.v20140327-1949"; singleton:="true"
       org.eclipse.ui.externaltools [1136]
         Unresolved requirement: Require-Bundle: org.eclipse.debug.core; bundle-version="[3.9.0,4.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
...


Above are just several beginning entries.

Thank you again for your help.
Akira
Re: [EMF Forms] Stable version for experiment [message #1443754 is a reply to message #1442029] Mon, 13 October 2014 07:07 Go to previous message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

the error messages mean, that other components (non-ecp) could not be
resolved. Did you create the run config as described in the tutorial?

Best regards

Jonas

Am 10.10.2014 16:19, schrieb Akira Tanaka:
> Hello Jonas,
>
> Thank you for the response. I tried again to fresh install everything,
> and it works now. Thank you very much. I can proceed with this setup.
> However, just in case, I tried yesterday's setup, I get error messages
> when launching run configuration. Other modeling components like
> Acceleo might have impact(?).
>
>
> !SESSION 2014-10-10 22:36:34.470
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.7.0_51
> java.vendor=Oracle Corporation
> BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=ja_JP
> Framework arguments: -application
> org.eclipse.emf.ecp.application.e3.application
> Command-line arguments: -application
> org.eclipse.emf.ecp.application.e3.application -data
> /Users/atanaka/Desktop/Luna/Modeling/workspace-acceleo/../runtime-EclipseApplication
> -dev
> file:/Users/atanaka/Desktop/Luna/Modeling/workspace-acceleo/.metadata/.plugins/org.eclipse.pde.core/Eclipse
> Application/dev.properties -os macosx -ws cocoa -arch x86_64 -consoleLog
>
> !ENTRY org.eclipse.amalgam.discovery.modeling 4 0 2014-10-10 22:36:35.721
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module:
> org.eclipse.amalgam.discovery.modeling
> Unresolved requirement: Require-Bundle:
> org.eclipse.amalgam.discovery.ui; bundle-version="1.0.0"
> -> Bundle-SymbolicName: org.eclipse.amalgam.discovery.ui;
> bundle-version="1.5.0.201404290822"; singleton:="true"
> org.eclipse.amalgam.discovery.ui
> Unresolved requirement: Require-Bundle: org.eclipse.equinox.p2.ui
> -> Bundle-SymbolicName: org.eclipse.equinox.p2.ui;
> bundle-version="2.3.0.v20140404-1657"; singleton:="true"
> org.eclipse.equinox.p2.ui
> Unresolved requirement: Import-Package:
> org.eclipse.equinox.internal.p2.director
> -> Export-Package:
> org.eclipse.equinox.internal.p2.director;
> bundle-version="2.3.100.v20140224-1921";
> bundle-symbolic-name="org.eclipse.equinox.p2.director"; version="0.0.0";
> x-friends:="org.eclipse.equinox.p2.operations,
> org.eclipse.equinox.p2.repository.tools, org.eclipse.pde.core,
> org.eclipse.equinox.p2.reconciler.dropins, org.eclipse.equinox.p2.ui,
> org.eclipse.equinox.p2.director.app"
> org.eclipse.equinox.p2.director
> Unresolved requirement: Import-Package:
> org.eclipse.equinox.internal.provisional.configurator
>
> at org.eclipse.osgi.container.Module.start(Module.java:434)
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
>
> !ENTRY org.eclipse.amalgam.discovery.ui 4 0 2014-10-10 22:36:35.724
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module:
> org.eclipse.amalgam.discovery.ui
> Unresolved requirement: Require-Bundle: org.eclipse.equinox.p2.ui
> -> Bundle-SymbolicName: org.eclipse.equinox.p2.ui;
> bundle-version="2.3.0.v20140404-1657"; singleton:="true"
> org.eclipse.equinox.p2.ui
> Unresolved requirement: Import-Package:
> org.eclipse.equinox.internal.p2.director
> -> Export-Package: org.eclipse.equinox.internal.p2.director;
> bundle-version="2.3.100.v20140224-1921";
> bundle-symbolic-name="org.eclipse.equinox.p2.director"; version="0.0.0";
> x-friends:="org.eclipse.equinox.p2.operations,
> org.eclipse.equinox.p2.repository.tools, org.eclipse.pde.core,
> org.eclipse.equinox.p2.reconciler.dropins, org.eclipse.equinox.p2.ui,
> org.eclipse.equinox.p2.director.app"
> org.eclipse.equinox.p2.director
> Unresolved requirement: Import-Package:
> org.eclipse.equinox.internal.provisional.configurator
>
> at org.eclipse.osgi.container.Module.start(Module.java:434)
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
>
> !ENTRY org.eclipse.ant.launching 4 0 2014-10-10 22:36:35.728
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module:
> org.eclipse.ant.launching
> Unresolved requirement: Require-Bundle: org.eclipse.debug.core;
> bundle-version="[3.9.0,4.0.0)"
>
> at org.eclipse.osgi.container.Module.start(Module.java:434)
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
>
> !ENTRY org.eclipse.ant.ui 4 0 2014-10-10 22:36:35.734
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module:
> org.eclipse.ant.ui
> Unresolved requirement: Require-Bundle: org.eclipse.ui.externaltools;
> bundle-version="[3.2.0,4.0.0)"
> -> Bundle-SymbolicName: org.eclipse.ui.externaltools;
> bundle-version="3.2.300.v20140327-1949"; singleton:="true"
> org.eclipse.ui.externaltools [1136]
> Unresolved requirement: Require-Bundle: org.eclipse.debug.core;
> bundle-version="[3.9.0,4.0.0)"
>
> at org.eclipse.osgi.container.Module.start(Module.java:434)
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
>
> at
> org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> ..
>
>
> Above are just several beginning entries.
>
> Thank you again for your help.
> Akira
Previous Topic:EMFstore: encrypted model persistence?
Next Topic:[EMFStore] Updating product meta-model
Goto Forum:
  


Current Time: Sun Mar 29 22:16:15 GMT 2020

Powered by FUDForum. Page generated in 0.11073 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top