Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Newbie Q - PoM changes not reflected in eclipse(updating references to new versions)
Newbie Q - PoM changes not reflected in eclipse [message #1441222] Thu, 09 October 2014 12:11
Ben Frankman is currently offline Ben FrankmanFriend
Messages: 2
Registered: September 2014
Junior Member
Hi,

I've taken over a java web app built using maven and imported to the eclipse luna IDE. Essentially I'm trying to move to elasticSearch 1.3 from 0.90.11 but I'm very new to almost all aspects of this! The application is using Spring and as I understand it the reference in the POM is
<spring-data-elasticsearch.version>1.0.0.M1</spring-data-elasticsearch.version>
This is the only reference I can find to elastic and so I'm assuming any further references to elastic search are derived from this (is this a reasonable assumption !?).
I tried updating the POM to
<spring-data-elasticsearch.version>1.2.0.BUILD-SNAPSHOT</spring-data-elasticsearch.version>

as google tells me this should be a version that references 1.3.

When I do a command line build now (mvn clean install) i get a lot of errors (cannot find symbol). I wanted to look at this in eclipse so that I can see & understand what the errors are (I hope) but when I open eclipse although the POM has the change I think it is still looking at the old version? My Referenced Libraries folder refers to spring-data-elasticsearch-1.0.0.M1.jar and elasticsearch-0.90.11.jar (both in the M2_REPO structure) and I can't find any reference to the newer versions (although they are in the M2 repository folder structure).

I've tried a clean and build in eclipse but no dice.

Not expecting a complete solution but can anyone give me any pointers as to where I'm going wrong !?

Thanks in advance

Previous Topic:How to get super/sub types of a class
Next Topic:Eclipse typing slowly
Goto Forum:
  


Current Time: Mon Nov 30 09:22:35 GMT 2020

Powered by FUDForum. Page generated in 0.01846 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top