Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Re: NullPointerException when editing an ecore model
Re: NullPointerException when editing an ecore model [message #1439666] Tue, 07 October 2014 11:36 Go to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3109
Registered: July 2009
Senior Member
This appears to be an OCL topic.

====8<====


Hi everyone,

I dont know if this is a general bug or just an issue on my machine.
However googeling this problem leads to no resource.

When I try to annotate my ecore model with additional OCL constraints
using the "OCLinEcore Editor" an error pops up saying An internal error
occurred during: "XtextReconcilerJob".
java.lang.NullPointerException

The log says


!ENTRY org.eclipse.core.jobs 4 2 2014-10-06 22:26:02.629
!MESSAGE An internal error occurred during: "XtextReconcilerJob".
!STACK 0
java.lang.NullPointerException
at
org.eclipse.xtext.ui.editor.DirtyStateEditorSupport.getResourceDescriptionManager(DirtyStateEditorSupport.java:496)
at
org.eclipse.xtext.ui.editor.DirtyStateEditorSupport.announceDirtyState(DirtyStateEditorSupport.java:466)
at
org.eclipse.xtext.ui.editor.reconciler.XtextDocumentReconcileStrategy.postParse(XtextDocumentReconcileStrategy.java:160)
at
org.eclipse.xtext.ui.editor.reconciler.XtextDocumentReconcileStrategy.doReconcile(XtextDocumentReconcileStrategy.java:146)
at
org.eclipse.xtext.ui.editor.reconciler.XtextDocumentReconcileStrategy.reconcile(XtextDocumentReconcileStrategy.java:65)
at
org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.doRun(XtextReconciler.java:401)
at
org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.access$3(XtextReconciler.java:386)
at
org.eclipse.xtext.ui.editor.reconciler.XtextReconciler$1.process(XtextReconciler.java:327)
at
org.eclipse.xtext.ui.editor.reconciler.XtextReconciler$1.process(XtextReconciler.java:1)
at
org.eclipse.xtext.util.concurrent.IUnitOfWork$Void.exec(IUnitOfWork.java:36)
at
org.eclipse.xtext.ui.editor.model.XtextDocument$XtextDocumentLocker.modify(XtextDocument.java:418)
at
org.eclipse.xtext.ui.editor.model.XtextDocument.internalModify(XtextDocument.java:131)
at
org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.run(XtextReconciler.java:324)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


This happens when I type in the first character and the editor state
gets dirty. Anyone else with this problem?
Re: NullPointerException when editing an ecore model [message #1439882 is a reply to message #1439666] Tue, 07 October 2014 16:35 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7267
Registered: July 2009
Senior Member
HI

I think that both Xtext and OCL have had fixes in this area. I certainly
saw this with the OCL editors but also the vanilla Xtext editor at
around the time of Luna.

Give OCL 5.0.1 (or 5.0.2) a try since 5.0.1 came out with Luna and fixed
a number of too late irritations.

However the NPE is entirely in Xtext so maybe you need an Xtext update.

Regards

Ed Willink

On 07/10/2014 12:36, Sebastian Zarnekow wrote:
> This appears to be an OCL topic.
>
> ====8<====
>
>
> Hi everyone,
>
> I dont know if this is a general bug or just an issue on my machine.
> However googeling this problem leads to no resource.
>
> When I try to annotate my ecore model with additional OCL constraints
> using the "OCLinEcore Editor" an error pops up saying An internal error
> occurred during: "XtextReconcilerJob".
> java.lang.NullPointerException
>
> The log says
>
>
> !ENTRY org.eclipse.core.jobs 4 2 2014-10-06 22:26:02.629
> !MESSAGE An internal error occurred during: "XtextReconcilerJob".
> !STACK 0
> java.lang.NullPointerException
> at
> org.eclipse.xtext.ui.editor.DirtyStateEditorSupport.getResourceDescriptionManager(DirtyStateEditorSupport.java:496)
>
> at
> org.eclipse.xtext.ui.editor.DirtyStateEditorSupport.announceDirtyState(DirtyStateEditorSupport.java:466)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextDocumentReconcileStrategy.postParse(XtextDocumentReconcileStrategy.java:160)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextDocumentReconcileStrategy.doReconcile(XtextDocumentReconcileStrategy.java:146)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextDocumentReconcileStrategy.reconcile(XtextDocumentReconcileStrategy.java:65)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.doRun(XtextReconciler.java:401)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.access$3(XtextReconciler.java:386)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler$1.process(XtextReconciler.java:327)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler$1.process(XtextReconciler.java:1)
>
> at
> org.eclipse.xtext.util.concurrent.IUnitOfWork$Void.exec(IUnitOfWork.java:36)
>
> at
> org.eclipse.xtext.ui.editor.model.XtextDocument$XtextDocumentLocker.modify(XtextDocument.java:418)
>
> at
> org.eclipse.xtext.ui.editor.model.XtextDocument.internalModify(XtextDocument.java:131)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.run(XtextReconciler.java:324)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
>
>
> This happens when I type in the first character and the editor state
> gets dirty. Anyone else with this problem?
Previous Topic:acceleo : stereotype value and generated files layout
Next Topic:[Acceleo] Sirius Model transformation problem
Goto Forum:
  


Current Time: Sun Sep 26 15:12:32 GMT 2021

Powered by FUDForum. Page generated in 0.01479 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top