Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse 4.2.0 fail to launch after tried to change permgen size(Eclipse was running fine but after trying increase permgen space according to wiki instructions, now it fails silently)
Eclipse 4.2.0 fail to launch after tried to change permgen size [message #1436132] Thu, 02 October 2014 12:57 Go to next message
Guillaume DemarbreFriend
Messages: 1
Registered: October 2014
Junior Member
HI all, and thanks in advance for your help

first of all, sorry for my english =)

Now, as I sayed in the title :

I'm in eclipse 4.2.0, working for an Android project, and as it's a fresh install, i forgot to increase permgenspace like i had to for previous instal on other PCs.

So, when i saw the permgen error, i went to the wiki to make sure there's no mistake, but whatever i tried (yes, there isn't 50 possibilities ... ) eclipse don't want to launch anymore ....

I can see the splashscreen for 2-3 seconds, the grey progress bar goes to " ? workbench" and then fail with no error massage.

I also tried to restore the original version of my eclipse.ini file but that's not changing anything... so I really don't understand what happenned ...

That's for the problem globally. Now here is some details :

I'm on Win 7.1 x64 with JDK 7.

I'm not sure it has "link" to my problem but :

When the permgen error happenned, i was trying to run an Android App on virtual device. So i clicked on the cross to close eclipse, and it gave me an error i don't really remember (about 4-5 lines of text) finally asking "Do you want to exit the workbench ? >> Y / N". I answered Yes of course Razz .

Perhaps it's in relation to my problem : the launch fail at the workbench step ...

But i really don't understand, this is not my first Android project with Eclipse, and this is not the first time i increase permgen space ... so where is my mistake ???

Please enlight me Very Happy
  • Attachment: eclipse.ini
    (Size: 0.43KB, Downloaded 70 times)
Re: Eclipse 4.2.0 fail to launch after tried to change permgen size [message #1436257 is a reply to message #1436132] Thu, 02 October 2014 16:23 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
It's possible the workspace got corrupted when you encountered the first permgen error. Try creating a new workspace and importing your project(s) into it.
Previous Topic:eclipse installation problem
Next Topic:Eclipse Luna not launching
Goto Forum:
  


Current Time: Sun Oct 20 07:02:41 GMT 2019

Powered by FUDForum. Page generated in 0.03143 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top