Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Runtimes » unable to compile javafx8 code in eclipse kepler using jre1.8
unable to compile javafx8 code in eclipse kepler using jre1.8 [message #1434682] Tue, 30 September 2014 12:44 Go to next message
Muralidhar Yaragalla is currently offline Muralidhar YaragallaFriend
Messages: 38
Registered: January 2011
Location: Ponnur
Member

Hi i am trying to learn javafx8. I have imported jre8 into kepler. But unable to compile the file. The import " import javafx.application.Application" says

"Access restriction: The type Application is not accessible due to restriction on required library D:\jdk1.8.0_20\jre\lib\ext\jfxrt.jar"

why is this happening? how can i run my code?

Thanks in advance.


Thanks and Regards,
Muralidhar Yaragalla.
http://yaragalla.blogspot.in
Re: unable to compile javafx8 code in eclipse kepler using jre1.8 [message #1434725 is a reply to message #1434682] Tue, 30 September 2014 13:46 Go to previous message
Muralidhar Yaragalla is currently offline Muralidhar YaragallaFriend
Messages: 38
Registered: January 2011
Location: Ponnur
Member

I have resolved this by adding an access rule to the jre. thank you so much.

Thanks and Regards,
Muralidhar Yaragalla.
http://yaragalla.blogspot.in
Previous Topic:Can I get an Empty IDE as target platform using Target Platform provisioning
Next Topic:Problem of memory consumption with Jetty 9 and JDK8
Goto Forum:
  


Current Time: Wed Sep 26 03:32:10 GMT 2018

Powered by FUDForum. Page generated in 0.01673 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top