Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » [Resolved] - Headless import issues upgrading from 3.5 to 4.4
[Resolved] - Headless import issues upgrading from 3.5 to 4.4 [message #1425074] Tue, 16 September 2014 20:47 Go to next message
Chad Diller is currently offline Chad DillerFriend
Messages: 4
Registered: September 2014
Junior Member
I'm attempting to upgrade our buckminster version from 3.5 to 4.4. I'm trying to upgrade just buckminster and leave our target platform alone (for now). The target platform is built from 3.5 and it a p2 repo on the file system. If I do an import using 3.5 it works fine. If I use the 4.4 buckminster version I get errors importing. This happens for numerous org.eclipse.swt and org.eclipse.equinox.launcher bundles. The target contains the org.eclipse.rcp_3.5.2 feature which references these bundles but the target doesn't actual have them in the plugins directory. The target was created using the p2.mirror ant task. Thanks for any help.

  ERROR   [0033] : No suitable provider for component org.eclipse.swt.gtk.solaris.sparc:osgi.bundle/[3.5.2.v3557f,3.5.2.v3557f](&(target.arch=sparc)(target.os=solaris)(target.ws=gtk)) was found in searchPath target
    ERROR   [0033] : Rejecting provider p2(file:///<path>/target[file://<path>/target]): No component match was found


My rmap has the following to grab stuff from the target:

   <searchPath name="target">
      <provider readerType="p2" componentType="osgi.bundle,eclipse.feature" mutable="false" source="false">
         <uri format="file:{0}">
            <bc:propertyRef key="baseTargetPath" />
         </uri>
      </provider>
   </searchPath>
   <locator searchPathRef="target" pattern=".*" />


This also occurs if I run with target.os, target.arch , and target.ws set to linux, x86_64, gtk (which is all I really care about.)

[Updated on: Thu, 18 September 2014 16:48]

Report message to a moderator

Re: Headless import issues upgrading from 3.5 to 4.4 [message #1426369 is a reply to message #1425074] Thu, 18 September 2014 16:48 Go to previous message
Chad Diller is currently offline Chad DillerFriend
Messages: 4
Registered: September 2014
Junior Member
We've decided to go ahead and update the target platform instead of trying to build against the old one. In this case I was able to successfully resolve the cquery.
Previous Topic:target definition with multiple architecture bundles
Next Topic:Difference between 3.6 and 3.7?
Goto Forum:
  


Current Time: Mon May 21 13:18:55 GMT 2018

Powered by FUDForum. Page generated in 0.01801 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top