Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Acceleo maven plugin 3.5 does not compile mtl fieles with 'uml2/5.0.0/UML'
Acceleo maven plugin 3.5 does not compile mtl fieles with 'uml2/5.0.0/UML' [message #1423557] Sun, 14 September 2014 16:56 Go to next message
Mariusz K is currently offline Mariusz KFriend
Messages: 2
Registered: September 2014
Junior Member
Hi,

I'm trying to compile eclipse Acceleo project using Acceleo maven plugin 3.5. I have declared inside .mtl file:

[module generate('http://www.eclipse.org/uml2/5.0.0/UML')]

but I'm getting compilation error; 'Errors for file 'generate.mtl': [The metamodel couldn't be resolved, Invalid Type: Class, Cannot find operation ...'

When I change it to [module generate('http://www.eclipse.org/uml2/4.0.0/UML')] it compiles

I wanted to use 'uml2/5.0.0' as as latest version of Papyrus is generating with that version.

I'm quite sure that there is a problem with plugin dependencies.

Is somone have it configured for UML2 5.0.0 (org.eclipse.uml2.uml_5.0.0v20140602-0749.jar)?

Re: Acceleo maven plugin 3.5 does not compile mtl fieles with 'uml2/5.0.0/UML' [message #1435403 is a reply to message #1423557] Wed, 01 October 2014 12:49 Go to previous message
Stephane Begaudeau is currently offline Stephane BegaudeauFriend
Messages: 458
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

In order to use this version of the UML metamodel, you just need to have it installed in Eclipse. If you try to create a new Acceleo module, can you select this version of the UML metamodel in the wizard? If you can't, you may need to update your version of UML2.

Regards,

Stephane Begaudeau, Obeo
Previous Topic:[Acceleo] main.emtl not found after deploying plugins
Next Topic:[Acceleo] The type of the first parameter of the main template named 'generateElement' is a proxy
Goto Forum:
  


Current Time: Thu Sep 23 16:01:27 GMT 2021

Powered by FUDForum. Page generated in 0.02420 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top