Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » How to get plugin to work when package is already installed on the system
How to get plugin to work when package is already installed on the system [message #1417502] Fri, 05 September 2014 15:48 Go to next message
Brad Van Orden is currently offline Brad Van OrdenFriend
Messages: 2
Registered: September 2014
Junior Member
I have some RHEL 6.5 servers not connected to the Internet, but connected to some internal Red Hat maintained satellite server. I'm trying to do some rpm package development and wanted to try to use the Eclipse RPM Editor: http://www.eclipse.org/linuxtools/projectPages/specfile/. I saw on our satellite server that Red Hat had this in a package, eclipse-rpm-editor-0.5.0-2.el6.x86_64. So, I installed it. When I start eclipse, the plugin is not available. I tried with "eclipse -clean," but still nothing. The installation document on the web page says to use Help -> Install New Software: https://wiki.eclipse.org/Linux_Tools_Project/PluginInstallHelp. I tried to click on Add and point to the directory where the jar files are located, but that doesn't work. I tried to create soft links from the jar files to /usr/lib64/eclipse/plugins and restarted eclipse. Still can't see it. Tried to make soft links in /usr/lib64/eclipse/dropins, but that didn't work either.

Does anyone know how to tell eclipse that the software is already installed on the server and not pull it from an external URL?

Thanks!
Re: How to get plugin to work when package is already installed on the system [message #1419448 is a reply to message #1417502] Mon, 08 September 2014 16:27 Go to previous message
Brad Van Orden is currently offline Brad Van OrdenFriend
Messages: 2
Registered: September 2014
Junior Member
I think what I am looking for is related to http://wiki.eclipse.org/Equinox_p2_director_application, but not sure. I'm a very novice eclipse user. The eclipse rpm (eclipse-platform) is installed to /usr/lib64/eclipse/plugins.

The eclipse-rpm-editor rpm is installed to
/usr/share/eclipse/dropins/rpm-editor/eclipse/plugins/org.eclipse.linuxtools.rpm.core_0.4.3.201003171651.jar
/usr/share/eclipse/dropins/rpm-editor/eclipse/plugins/org.eclipse.linuxtools.rpm.rpmlint_0.4.3.201003171651.jar
/usr/share/eclipse/dropins/rpm-editor/eclipse/plugins/org.eclipse.linuxtools.rpm.ui.editor_0.4.3.201003171651.jar
/usr/share/eclipse/dropins/rpm-editor/eclipse/plugins/org.eclipse.linuxtools.rpm.ui_0.4.3.201003171651.jar


I need to figure out how to tell eclipse that these other plugins are available. I went to /usr/lib64/eclipse/plugins and made a soft link from each jar file to this location and started eclipse -clean, but still no plugin. I then tried creating soft links in /usr/lib64/eclipse/dropins, but that didn't work either.

Any suggestions would be greatly appreciated. Smile
Previous Topic:offline userguides required
Next Topic:Install groovyfx plugin
Goto Forum:
  


Current Time: Mon Oct 21 17:19:48 GMT 2019

Powered by FUDForum. Page generated in 0.02885 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top