Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » release of Xcore 1.3.0 (compatible with Xtext 2.7.0)
release of Xcore 1.3.0 (compatible with Xtext 2.7.0) [message #1416017] Thu, 04 September 2014 06:52 Go to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1754
Registered: July 2009
Location: Firenze, Italy
Senior Member
Hi

Xtext 2.7.0 was released yesterday, but the current released version of
Xcore 1.2.0 is not compatible with that. I see that Xcore 1.3.0
(working with Xtext 2.7.0) is in the EMF nightly update site... when
will it be officially released?

thanks in advance
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Re: release of Xcore 1.3.0 (compatible with Xtext 2.7.0) [message #1416055 is a reply to message #1416017] Thu, 04 September 2014 08:35 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30351
Registered: July 2009
Senior Member
The maintenance stream (Xcore 1.2.1) is built against Xtext 2.7.0 as
well and both are targeting to be part of Luna SR1 so the latest RCx
build of EMF 2.10.1 should be compatible.

On 04/09/2014 8:52 AM, Lorenzo Bettini wrote:
> Hi
>
> Xtext 2.7.0 was released yesterday, but the current released version of
> Xcore 1.2.0 is not compatible with that. I see that Xcore 1.3.0
> (working with Xtext 2.7.0) is in the EMF nightly update site... when
> will it be officially released?
>
> thanks in advance
> Lorenzo
>
Re: release of Xcore 1.3.0 (compatible with Xtext 2.7.0) [message #1416065 is a reply to message #1416055] Thu, 04 September 2014 08:51 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1754
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 04/09/2014 10:35, Ed Merks wrote:
> The maintenance stream (Xcore 1.2.1) is built against Xtext 2.7.0 as
> well and both are targeting to be part of Luna SR1 so the latest RCx
> build of EMF 2.10.1 should be compatible.
>
> On 04/09/2014 8:52 AM, Lorenzo Bettini wrote:
>> Hi
>>
>> Xtext 2.7.0 was released yesterday, but the current released version of
>> Xcore 1.2.0 is not compatible with that. I see that Xcore 1.3.0
>> (working with Xtext 2.7.0) is in the EMF nightly update site... when
>> will it be officially released?
>>
>> thanks in advance
>> Lorenzo
>>
>

Thank you Ed. But 1.2.1 is not part of the EMF release update site, is it?

cheers
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Re: release of Xcore 1.3.0 (compatible with Xtext 2.7.0) [message #1416072 is a reply to message #1416065] Thu, 04 September 2014 09:11 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30351
Registered: July 2009
Senior Member
Lorenzo,

Not until it's released. But there is an update site for the maintenance
builds (and it would be nice if we had those on the download page)...

On 04/09/2014 10:51 AM, Lorenzo Bettini wrote:
> On 04/09/2014 10:35, Ed Merks wrote:
>> The maintenance stream (Xcore 1.2.1) is built against Xtext 2.7.0 as
>> well and both are targeting to be part of Luna SR1 so the latest RCx
>> build of EMF 2.10.1 should be compatible.
>>
>> On 04/09/2014 8:52 AM, Lorenzo Bettini wrote:
>>> Hi
>>>
>>> Xtext 2.7.0 was released yesterday, but the current released version of
>>> Xcore 1.2.0 is not compatible with that. I see that Xcore 1.3.0
>>> (working with Xtext 2.7.0) is in the EMF nightly update site... when
>>> will it be officially released?
>>>
>>> thanks in advance
>>> Lorenzo
>>>
> Thank you Ed. But 1.2.1 is not part of the EMF release update site, is it?
>
> cheers
> Lorenzo
>
Re: release of Xcore 1.3.0 (compatible with Xtext 2.7.0) [message #1417355 is a reply to message #1416072] Fri, 05 September 2014 08:39 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1754
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 04/09/2014 11:11, Ed Merks wrote:
> Lorenzo,
>
> Not until it's released. But there is an update site for the maintenance
> builds (and it would be nice if we had those on the download page)...

and indeed I can't find that update site :)

>
> On 04/09/2014 10:51 AM, Lorenzo Bettini wrote:
>> On 04/09/2014 10:35, Ed Merks wrote:
>>> The maintenance stream (Xcore 1.2.1) is built against Xtext 2.7.0 as
>>> well and both are targeting to be part of Luna SR1 so the latest RCx
>>> build of EMF 2.10.1 should be compatible.
>>>
>>> On 04/09/2014 8:52 AM, Lorenzo Bettini wrote:
>>>> Hi
>>>>
>>>> Xtext 2.7.0 was released yesterday, but the current released version of
>>>> Xcore 1.2.0 is not compatible with that. I see that Xcore 1.3.0
>>>> (working with Xtext 2.7.0) is in the EMF nightly update site... when
>>>> will it be officially released?
>>>>
>>>> thanks in advance
>>>> Lorenzo
>>>>
>> Thank you Ed. But 1.2.1 is not part of the EMF release update site,
>> is it?
>>
>> cheers
>> Lorenzo
>>
>


--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Re: release of Xcore 1.3.0 (compatible with Xtext 2.7.0) [message #1417499 is a reply to message #1417355] Fri, 05 September 2014 15:39 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30351
Registered: July 2009
Senior Member
I suppose it should be in here (SR1 RC2) by now:
https://www.eclipse.org/downloads/index-developer.php?release=luna

On 05/09/2014 10:39 AM, Lorenzo Bettini wrote:
> On 04/09/2014 11:11, Ed Merks wrote:
>> Lorenzo,
>>
>> Not until it's released. But there is an update site for the maintenance
>> builds (and it would be nice if we had those on the download page)...
> and indeed I can't find that update site :)
>
>> On 04/09/2014 10:51 AM, Lorenzo Bettini wrote:
>>> On 04/09/2014 10:35, Ed Merks wrote:
>>>> The maintenance stream (Xcore 1.2.1) is built against Xtext 2.7.0 as
>>>> well and both are targeting to be part of Luna SR1 so the latest RCx
>>>> build of EMF 2.10.1 should be compatible.
>>>>
>>>> On 04/09/2014 8:52 AM, Lorenzo Bettini wrote:
>>>>> Hi
>>>>>
>>>>> Xtext 2.7.0 was released yesterday, but the current released version of
>>>>> Xcore 1.2.0 is not compatible with that. I see that Xcore 1.3.0
>>>>> (working with Xtext 2.7.0) is in the EMF nightly update site... when
>>>>> will it be officially released?
>>>>>
>>>>> thanks in advance
>>>>> Lorenzo
>>>>>
>>> Thank you Ed. But 1.2.1 is not part of the EMF release update site,
>>> is it?
>>>
>>> cheers
>>> Lorenzo
>>>
>
Re: release of Xcore 1.3.0 (compatible with Xtext 2.7.0) [message #1419215 is a reply to message #1417499] Mon, 08 September 2014 09:05 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1754
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 05/09/2014 17:39, Ed Merks wrote:
> I suppose it should be in here (SR1 RC2) by now:
> https://www.eclipse.org/downloads/index-developer.php?release=luna

Hi

no: this still contains Xcore 1.2.0;
could you please post the update site for maintenance builds? That
would be helpful for CI.

thanks
Lorenzo

>
> On 05/09/2014 10:39 AM, Lorenzo Bettini wrote:
>> On 04/09/2014 11:11, Ed Merks wrote:
>>> Lorenzo,
>>>
>>> Not until it's released. But there is an update site for the maintenance
>>> builds (and it would be nice if we had those on the download page)...
>> and indeed I can't find that update site :)
>>
>>> On 04/09/2014 10:51 AM, Lorenzo Bettini wrote:
>>>> On 04/09/2014 10:35, Ed Merks wrote:
>>>>> The maintenance stream (Xcore 1.2.1) is built against Xtext 2.7.0 as
>>>>> well and both are targeting to be part of Luna SR1 so the latest RCx
>>>>> build of EMF 2.10.1 should be compatible.
>>>>>
>>>>> On 04/09/2014 8:52 AM, Lorenzo Bettini wrote:
>>>>>> Hi
>>>>>>
>>>>>> Xtext 2.7.0 was released yesterday, but the current released
>>>>>> version of
>>>>>> Xcore 1.2.0 is not compatible with that. I see that Xcore 1.3.0
>>>>>> (working with Xtext 2.7.0) is in the EMF nightly update site... when
>>>>>> will it be officially released?
>>>>>>
>>>>>> thanks in advance
>>>>>> Lorenzo
>>>>>>
>>>> Thank you Ed. But 1.2.1 is not part of the EMF release update site,
>>>> is it?
>>>>
>>>> cheers
>>>> Lorenzo
>>>>
>>
>


--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Re: release of Xcore 1.3.0 (compatible with Xtext 2.7.0) [message #1419282 is a reply to message #1419215] Mon, 08 September 2014 11:19 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30351
Registered: July 2009
Senior Member
Lorenzo,

Sorry I always forget and then I need to ask helpful Dennis:
http://download.eclipse.org/modeling/emf/emf/updates/2.10.x/


On 08/09/2014 11:05 AM, Lorenzo Bettini wrote:
> On 05/09/2014 17:39, Ed Merks wrote:
>> I suppose it should be in here (SR1 RC2) by now:
>> https://www.eclipse.org/downloads/index-developer.php?release=luna
> Hi
>
> no: this still contains Xcore 1.2.0;
> could you please post the update site for maintenance builds? That
> would be helpful for CI.
>
> thanks
> Lorenzo
>
>> On 05/09/2014 10:39 AM, Lorenzo Bettini wrote:
>>> On 04/09/2014 11:11, Ed Merks wrote:
>>>> Lorenzo,
>>>>
>>>> Not until it's released. But there is an update site for the maintenance
>>>> builds (and it would be nice if we had those on the download page)...
>>> and indeed I can't find that update site :)
>>>
>>>> On 04/09/2014 10:51 AM, Lorenzo Bettini wrote:
>>>>> On 04/09/2014 10:35, Ed Merks wrote:
>>>>>> The maintenance stream (Xcore 1.2.1) is built against Xtext 2.7.0 as
>>>>>> well and both are targeting to be part of Luna SR1 so the latest RCx
>>>>>> build of EMF 2.10.1 should be compatible.
>>>>>>
>>>>>> On 04/09/2014 8:52 AM, Lorenzo Bettini wrote:
>>>>>>> Hi
>>>>>>>
>>>>>>> Xtext 2.7.0 was released yesterday, but the current released
>>>>>>> version of
>>>>>>> Xcore 1.2.0 is not compatible with that. I see that Xcore 1.3.0
>>>>>>> (working with Xtext 2.7.0) is in the EMF nightly update site... when
>>>>>>> will it be officially released?
>>>>>>>
>>>>>>> thanks in advance
>>>>>>> Lorenzo
>>>>>>>
>>>>> Thank you Ed. But 1.2.1 is not part of the EMF release update site,
>>>>> is it?
>>>>>
>>>>> cheers
>>>>> Lorenzo
>>>>>
>
Previous Topic:Understanding CDODataOutputImpl and CDODataInputImpl classes' methods
Next Topic:[xcore] Disabling auto-build of xcore
Goto Forum:
  


Current Time: Sun Aug 18 21:21:18 GMT 2019

Powered by FUDForum. Page generated in 0.02373 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top