Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » MWE2 URI resolving
MWE2 URI resolving [message #1415149] Tue, 02 September 2014 07:34 Go to next message
Daniel K. is currently offline Daniel K.Friend
Messages: 14
Registered: August 2014
Location: Stuttgart
Junior Member
Hi,
I recognized a problem regarding using the MWE2.
I'm using URIs to reference files in the workspace using platform:/resource/<project>/<resource> in the definition of the workflow.
This includes also references to files located in other projects in the same workspace.
In general it is working fine, but with the following restriction:
The target referenced project must be located physically inside of the same workspace.
If the target project is imported as a reference, the following exception is coming Sad :

[ERROR]: Error at loading files!(Element: -UNKNOWN-; Reported by: XXX)
java.io.IOException: The path '/<project>/<resource>' is unmapped

Is there something I'm missing to get it run?

Regards
Daniel
Re: MWE2 URI resolving [message #1415152 is a reply to message #1415149] Tue, 02 September 2014 07:36 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13277
Registered: July 2009
Senior Member
Hi,

do you define standalonesetup and setplatformuri within?


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: MWE2 URI resolving [message #1415168 is a reply to message #1415152] Tue, 02 September 2014 08:40 Go to previous messageGo to next message
Daniel K. is currently offline Daniel K.Friend
Messages: 14
Registered: August 2014
Location: Stuttgart
Junior Member
Hi,
yes.
I have a StandaloneSetup defined.
It looks like this:

var runtimeProject = "../${projectName}"
bean = StandaloneSetup {
scanClassPath = true
platformUri = "${runtimeProject}/.."
registerGeneratedEPackage = "somepackage"
}

Regards
Daniel
Re: MWE2 URI resolving [message #1415180 is a reply to message #1415168] Tue, 02 September 2014 09:00 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13277
Registered: July 2009
Senior Member
then it should work if all projects are in dir "${runtimeProject}/.."

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: MWE2 URI resolving [message #1415181 is a reply to message #1415180] Tue, 02 September 2014 09:01 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13277
Registered: July 2009
Senior Member
so: which project/path is actually missing

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: MWE2 URI resolving [message #1415214 is a reply to message #1415181] Tue, 02 September 2014 10:28 Go to previous messageGo to next message
Daniel K. is currently offline Daniel K.Friend
Messages: 14
Registered: August 2014
Location: Stuttgart
Junior Member
If I want to reference to files located in the same workspace.
Referencing a file from another project only works, if the project is also physically located in the workspace.
If a want to reference to a file from a project, which is imported from another workspace and not copied, it doesn't work.
Re: MWE2 URI resolving [message #1415219 is a reply to message #1415214] Tue, 02 September 2014 10:43 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13277
Registered: July 2009
Senior Member
it is meant to be physically in the same location

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/xtext/
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: MWE2 URI resolving [message #1415261 is a reply to message #1415219] Tue, 02 September 2014 12:37 Go to previous message
Daniel K. is currently offline Daniel K.Friend
Messages: 14
Registered: August 2014
Location: Stuttgart
Junior Member
Hi,
ok, then we know now about this restriction.
Thanks for clarifying it.

Regards
Daniel
Previous Topic:[xtend] how to pass a function to method to use in filter
Next Topic:Marker id nnn not found
Goto Forum:
  


Current Time: Fri Dec 13 15:58:48 GMT 2019

Powered by FUDForum. Page generated in 0.02500 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top