Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't Update Eclipse 3.7.2(Errors with Git Team Provider and m2e when running software update)
Can't Update Eclipse 3.7.2 [message #1414180] Sat, 30 August 2014 14:12 Go to next message
Mark Phillips is currently offline Mark PhillipsFriend
Messages: 8
Registered: November 2011
Junior Member
I have been using Eclipse Version: 3.7.2 Build id: M20120208-0800 for Android development, and I have not used it in awhile. I started a new project, and tried to update eclipse, but I ran into this error from the update manager. The Update Manager is trying to update the Eclipse Git Team Provider and m2e.

The errors from trying to update the Eclipse Git Team Provider
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Git Team Provider 3.4.1.201406201815-r (org.eclipse.egit.feature.group 3.4.1.201406201815-r)
  Software currently installed: Eclipse SDK 3.7.2.M20120208-0800 (org.eclipse.sdk.ide 3.7.2.M20120208-0800)
  Only one of the following can be installed at once: 
    Team Support UI 3.6.201.v20130125-135424 (org.eclipse.team.ui 3.6.201.v20130125-135424)
    Team Support UI 3.6.101.R37x_v20111109-0800 (org.eclipse.team.ui 3.6.101.R37x_v20111109-0800)
    Team Support UI 3.6.100.I20110525-0800 (org.eclipse.team.ui 3.6.100.I20110525-0800)
  Cannot satisfy dependency:
    From: Eclipse Git Team Provider 3.4.1.201406201815-r (org.eclipse.egit.feature.group 3.4.1.201406201815-r)
    To: org.eclipse.egit.ui [3.4.1.201406201815-r]
  Cannot satisfy dependency:
    From: Git Team Provider UI 3.4.1.201406201815-r (org.eclipse.egit.ui 3.4.1.201406201815-r)
    To: bundle org.eclipse.team.ui [3.6.200,4.0.0)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
    To: org.eclipse.team.ui [3.6.101.R37x_v20111109-0800]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8 (org.eclipse.sdk.feature.group 3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8)
    To: org.eclipse.platform.feature.group [3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q]
  Cannot satisfy dependency:
    From: Eclipse SDK 3.7.2.M20120208-0800 (org.eclipse.sdk.ide 3.7.2.M20120208-0800)
    To: org.eclipse.sdk.feature.group [3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8]


The errors from trying to update the m2e:
Cannot complete the install because one or more required items could not be found.
  Software being installed: m2e - Maven Integration for Eclipse (includes Incubating components) 1.5.0.20140606-0033 (org.eclipse.m2e.feature.feature.group 1.5.0.20140606-0033)
  Missing requirement: Maven Integration for Eclipse 1.5.0.20140606-0033 (org.eclipse.m2e.core 1.5.0.20140606-0033) requires 'bundle com.google.guava [14.0.1,16.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Maven POM XML Editor 1.5.0.20140606-0033 (org.eclipse.m2e.editor.xml 1.5.0.20140606-0033)
    To: bundle org.eclipse.m2e.core [1.5.0,1.6.0)
  Cannot satisfy dependency:
    From: m2e - Maven Integration for Eclipse (includes Incubating components) 1.5.0.20140606-0033 (org.eclipse.m2e.feature.feature.group 1.5.0.20140606-0033)
    To: org.eclipse.m2e.editor.xml [1.5.0.20140606-0033]


It seems the m2e update needs com.google.guave, which I found still exists but has moved around the Internet to a new home. I can't figure out how to tell eclipse about the new home for guava.

I don't see from the error message a way to fix the update for the Git Team Provider.

I guess I could just trash this installation and install a new one, but before I do that I am hoping someone can suggest a better way to get the update working.

Thanks,

Mark
Re: Can't Update Eclipse 3.7.2 [message #1414244 is a reply to message #1414180] Sat, 30 August 2014 18:42 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 08/30/2014 08:12 AM, Mark Phillips wrote:
> I have been using Eclipse Version: 3.7.2 Build id: M20120208-0800 for
> Android development, and I have not used it in awhile. I started a new
> project, and tried to update eclipse, but I ran into this error from the
> update manager. The Update Manager is trying to update the Eclipse Git
> Team Provider and m2e.
> The errors from trying to update the Eclipse Git Team Provider
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Eclipse Git Team Provider
> 3.4.1.201406201815-r (org.eclipse.egit.feature.group 3.4.1.201406201815-r)
> Software currently installed: Eclipse SDK 3.7.2.M20120208-0800
> (org.eclipse.sdk.ide 3.7.2.M20120208-0800)
> Only one of the following can be installed at once: Team Support UI
> 3.6.201.v20130125-135424 (org.eclipse.team.ui 3.6.201.v20130125-135424)
> Team Support UI 3.6.101.R37x_v20111109-0800 (org.eclipse.team.ui
> 3.6.101.R37x_v20111109-0800)
> Team Support UI 3.6.100.I20110525-0800 (org.eclipse.team.ui
> 3.6.100.I20110525-0800)
> Cannot satisfy dependency:
> From: Eclipse Git Team Provider 3.4.1.201406201815-r
> (org.eclipse.egit.feature.group 3.4.1.201406201815-r)
> To: org.eclipse.egit.ui [3.4.1.201406201815-r]
> Cannot satisfy dependency:
> From: Git Team Provider UI 3.4.1.201406201815-r (org.eclipse.egit.ui
> 3.4.1.201406201815-r)
> To: bundle org.eclipse.team.ui [3.6.200,4.0.0)
> Cannot satisfy dependency:
> From: Eclipse Platform
> 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q
> (org.eclipse.platform.feature.group
> 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
> To: org.eclipse.team.ui [3.6.101.R37x_v20111109-0800]
> Cannot satisfy dependency:
> From: Eclipse Project SDK
> 3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8
> (org.eclipse.sdk.feature.group
> 3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8)
> To: org.eclipse.platform.feature.group
> [3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q]
> Cannot satisfy dependency:
> From: Eclipse SDK 3.7.2.M20120208-0800 (org.eclipse.sdk.ide
> 3.7.2.M20120208-0800)
> To: org.eclipse.sdk.feature.group
> [3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8]
>
>
> The errors from trying to update the m2e:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: m2e - Maven Integration for Eclipse
> (includes Incubating components) 1.5.0.20140606-0033
> (org.eclipse.m2e.feature.feature.group 1.5.0.20140606-0033)
> Missing requirement: Maven Integration for Eclipse 1.5.0.20140606-0033
> (org.eclipse.m2e.core 1.5.0.20140606-0033) requires 'bundle
> com.google.guava [14.0.1,16.0.0)' but it could not be found
> Cannot satisfy dependency:
> From: Maven POM XML Editor 1.5.0.20140606-0033
> (org.eclipse.m2e.editor.xml 1.5.0.20140606-0033)
> To: bundle org.eclipse.m2e.core [1.5.0,1.6.0)
> Cannot satisfy dependency:
> From: m2e - Maven Integration for Eclipse (includes Incubating
> components) 1.5.0.20140606-0033 (org.eclipse.m2e.feature.feature.group
> 1.5.0.20140606-0033)
> To: org.eclipse.m2e.editor.xml [1.5.0.20140606-0033]
>
>
> It seems the m2e update needs com.google.guave, which I found still
> exists but has moved around the Internet to a new home. I can't figure
> out how to tell eclipse about the new home for guava.
>
> I don't see from the error message a way to fix the update for the Git
> Team Provider.
>
> I guess I could just trash this installation and install a new one, but
> before I do that I am hoping someone can suggest a better way to get the
> update working.
>
> Thanks,
>
> Mark


Do you use Git and Maven?
Re: Can't Update Eclipse 3.7.2 [message #1414290 is a reply to message #1414244] Sat, 30 August 2014 22:11 Go to previous messageGo to next message
Mark Phillips is currently offline Mark PhillipsFriend
Messages: 8
Registered: November 2011
Junior Member
I use GIT, but not Maven.

Mark
Re: Can't Update Eclipse 3.7.2 [message #1414315 is a reply to message #1414290] Sun, 31 August 2014 00:14 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 08/30/2014 04:11 PM, Mark Phillips wrote:
> I use GIT, but not Maven.
>
> Mark

This certainly isn't my forte. However, if I were faced with your
present problem, I'd remove Maven and Git/eGit from Eclipse and just use
Git from the command line. (I use Git from the command line anyway as
I'm more at home with it.)

Some brighter answer may turn up next week after the holiday.

Best of luck.
Re: Can't Update Eclipse 3.7.2 [message #1414908 is a reply to message #1414315] Mon, 01 September 2014 15:16 Go to previous messageGo to next message
Dilton McGowan II is currently offline Dilton McGowan IIFriend
Messages: 110
Registered: July 2009
Senior Member
On Sat, 30 Aug 2014 18:14:00 -0600, Russell Bateman wrote:

> On 08/30/2014 04:11 PM, Mark Phillips wrote:
>> I use GIT, but not Maven.
>>
>> Mark
>
> This certainly isn't my forte. However, if I were faced with your
> present problem, I'd remove Maven and Git/eGit from Eclipse and just use
> Git from the command line. (I use Git from the command line anyway as
> I'm more at home with it.)
>
> Some brighter answer may turn up next week after the holiday.
>
> Best of luck.

I use git from the command line and EGit both and
haven't seen any issues; which is more than I
can say for Subversion.

Mark you seem to be using an old Eclipse, I'd
say just download Kepler and install EGit.

Luna is out but still new which is why I say
Kepler but you'd still be better off with Luna
than a really old version of Eclipse.

Also, it pays to update Eclipse once a week
kind of like your phone or your OS. Letting
it bit rot is only going to bring troubles
when you dust it off after several months and
try to run it.
Re: Can't Update Eclipse 3.7.2 [message #1414918 is a reply to message #1414908] Mon, 01 September 2014 15:53 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 09/01/2014 09:16 AM, Dilton McGowan II wrote:
> On Sat, 30 Aug 2014 18:14:00 -0600, Russell Bateman wrote:
>
>> On 08/30/2014 04:11 PM, Mark Phillips wrote:
>>> I use GIT, but not Maven.
>>>
>>> Mark
>>
>> This certainly isn't my forte. However, if I were faced with your
>> present problem, I'd remove Maven and Git/eGit from Eclipse and just use
>> Git from the command line. (I use Git from the command line anyway as
>> I'm more at home with it.)
>>
>> Some brighter answer may turn up next week after the holiday.
>>
>> Best of luck.
>
> I use git from the command line and EGit both and
> haven't seen any issues; which is more than I
> can say for Subversion.
>
> Mark you seem to be using an old Eclipse, I'd
> say just download Kepler and install EGit.
>
> Luna is out but still new which is why I say
> Kepler but you'd still be better off with Luna
> than a really old version of Eclipse.
>
> Also, it pays to update Eclipse once a week
> kind of like your phone or your OS. Letting
> it bit rot is only going to bring troubles
> when you dust it off after several months and
> try to run it.
>

It's been years since I last did Android development (under Galileo and
Helios). It may be that it's no longer an easy fit for just any version
of Eclipse and that one is now obliged to use a specific, older version.

I used both Subversive and Subclipse for years with only a bit of
trouble getting them set up. I used svn from within Eclipse at the time.
I got over it with Git because the UI is way too verbose as compared to
the command line. In fact, until it started coming pre-installed, I
never even took the trouble to add eGit.

Galileo, Helios, Kepler and Indigo were all rock-solid releases of
Eclipse (for my Java/EE work) and should all work now as long as you
don't insist on running plug-ins or doing things that require new
technology. Java 8 support comes to mind.

As noted, where Android is in its requirements, I can't say, but you
should ask for exact details and recommendations in a suitable Android
developer-support forum.
Previous Topic:Command Prompt Issues
Next Topic:Eclipse Error when I run the app
Goto Forum:
  


Current Time: Sat Oct 19 04:08:45 GMT 2019

Powered by FUDForum. Page generated in 0.03291 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top