Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Marker id nnn not found
Marker id nnn not found [message #1412910] Wed, 27 August 2014 10:43 Go to next message
Thomas Hallgren is currently offline Thomas HallgrenFriend
Messages: 3240
Registered: July 2009
Senior Member
I see the exception below from time to time when using our Xtext based editor (Geppetto). Our own code is not on the trace and so far I've not found the cause. Does anyone have a clue as to why this is happening?

I'm using Xtext 2.6.2.

!MESSAGE org.eclipse.xtext.ui.editor.validation.MarkerIssueProcessor  - Could not create marker.

!STACK 0
java.lang.reflect.InvocationTargetException
	at org.eclipse.ui.actions.WorkspaceModifyOperation.run(WorkspaceModifyOperation.java:121)
	at org.eclipse.xtext.ui.editor.validation.MarkerIssueProcessor.processIssues(MarkerIssueProcessor.java:58)
	at org.eclipse.xtext.ui.editor.validation.ValidationJob.run(ValidationJob.java:67)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: org.eclipse.core.internal.resources.ResourceException: Marker id 219 not found.
	at org.eclipse.core.internal.resources.Marker.checkInfo(Marker.java:57)
	at org.eclipse.core.internal.resources.Marker.setAttribute(Marker.java:237)
	at org.eclipse.xtext.ui.editor.validation.MarkerCreator.setMarkerAttributes(MarkerCreator.java:45)
	at org.eclipse.xtext.ui.editor.validation.MarkerCreator.createMarker(MarkerCreator.java:31)
	at org.eclipse.xtext.ui.editor.validation.AddMarkersOperation.execute(AddMarkersOperation.java:106)
	at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(WorkspaceModifyOperation.java:106)
	at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2313)
	at org.eclipse.ui.actions.WorkspaceModifyOperation.run(WorkspaceModifyOperation.java:118)
	... 3 more
Root exception:
org.eclipse.core.internal.resources.ResourceException: Marker id 219 not found.
	at org.eclipse.core.internal.resources.Marker.checkInfo(Marker.java:57)
	at org.eclipse.core.internal.resources.Marker.setAttribute(Marker.java:237)
	at org.eclipse.xtext.ui.editor.validation.MarkerCreator.setMarkerAttributes(MarkerCreator.java:45)
	at org.eclipse.xtext.ui.editor.validation.MarkerCreator.createMarker(MarkerCreator.java:31)
	at org.eclipse.xtext.ui.editor.validation.AddMarkersOperation.execute(AddMarkersOperation.java:106)
	at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(WorkspaceModifyOperation.java:106)
	at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2313)
	at org.eclipse.ui.actions.WorkspaceModifyOperation.run(WorkspaceModifyOperation.java:118)
	at org.eclipse.xtext.ui.editor.validation.MarkerIssueProcessor.processIssues(MarkerIssueProcessor.java:58)
	at org.eclipse.xtext.ui.editor.validation.ValidationJob.run(ValidationJob.java:67)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Re: Marker id nnn not found [message #1415440 is a reply to message #1412910] Tue, 02 September 2014 19:56 Go to previous message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1759
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 27/08/2014 12:43, Thomas Hallgren wrote:
> I see the exception below from time to time when using our Xtext based
> editor (Geppetto). Our own code is not on the trace and so far I've not
> found the cause. Does anyone have a clue as to why this is happening?
>
> I'm using Xtext 2.6.2.
>
> !MESSAGE org.eclipse.xtext.ui.editor.validation.MarkerIssueProcessor -
> Could not create marker.
>
> !STACK 0
> java.lang.reflect.InvocationTargetException
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation.run(WorkspaceModifyOperation.java:121)
>
> at
> org.eclipse.xtext.ui.editor.validation.MarkerIssueProcessor.processIssues(MarkerIssueProcessor.java:58)
>
> at
> org.eclipse.xtext.ui.editor.validation.ValidationJob.run(ValidationJob.java:67)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
> Caused by: org.eclipse.core.internal.resources.ResourceException: Marker
> id 219 not found.
> at org.eclipse.core.internal.resources.Marker.checkInfo(Marker.java:57)
> at
> org.eclipse.core.internal.resources.Marker.setAttribute(Marker.java:237)
> at
> org.eclipse.xtext.ui.editor.validation.MarkerCreator.setMarkerAttributes(MarkerCreator.java:45)
>
> at
> org.eclipse.xtext.ui.editor.validation.MarkerCreator.createMarker(MarkerCreator.java:31)
>
> at
> org.eclipse.xtext.ui.editor.validation.AddMarkersOperation.execute(AddMarkersOperation.java:106)
>
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(WorkspaceModifyOperation.java:106)
>
> at
> org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2313)
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation.run(WorkspaceModifyOperation.java:118)
>
> ... 3 more
> Root exception:
> org.eclipse.core.internal.resources.ResourceException: Marker id 219 not
> found.
> at org.eclipse.core.internal.resources.Marker.checkInfo(Marker.java:57)
> at
> org.eclipse.core.internal.resources.Marker.setAttribute(Marker.java:237)
> at
> org.eclipse.xtext.ui.editor.validation.MarkerCreator.setMarkerAttributes(MarkerCreator.java:45)
>
> at
> org.eclipse.xtext.ui.editor.validation.MarkerCreator.createMarker(MarkerCreator.java:31)
>
> at
> org.eclipse.xtext.ui.editor.validation.AddMarkersOperation.execute(AddMarkersOperation.java:106)
>
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(WorkspaceModifyOperation.java:106)
>
> at
> org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2313)
> at
> org.eclipse.ui.actions.WorkspaceModifyOperation.run(WorkspaceModifyOperation.java:118)
>
> at
> org.eclipse.xtext.ui.editor.validation.MarkerIssueProcessor.processIssues(MarkerIssueProcessor.java:58)
>
> at
> org.eclipse.xtext.ui.editor.validation.ValidationJob.run(ValidationJob.java:67)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

Hi Thomas

I sometimes see the "Marker id nnn not found" in the Error Log View in
the second eclipse instance when many dependencies change in the
development instance (i.e., the target platform of the second instance
has many changes).

Could it be due to some missing synchronizations during the rebuild?

In my case, this is not blocking though...

cheers
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book


Previous Topic:MWE2 URI resolving
Next Topic:Xtext 2.7.0 available
Goto Forum:
  


Current Time: Sat Dec 14 18:59:21 GMT 2019

Powered by FUDForum. Page generated in 0.01951 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top