Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Eclipse unusable after latest Oomph update
Eclipse unusable after latest Oomph update [message #1407844] Wed, 13 August 2014 15:44 Go to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 384
Registered: March 2011
Senior Member
When performing startup tasks (automatically) Oomph pops up a dialog asking for permission to access secure information from my keychain (I'm on MacOSX 10.9), in particular it asks me for my Bugzilla password (which I have previously entered), but it pops up the dialog 8 times for every single character that I type. (See screenshot attached). It does this every time I start Eclipse, making it unbearable. Why is it doing this? And more importantly, how can I prevent it from doing that?

I don't see any log files created or modified today to give any hints.

Thanks.
Re: Eclipse unusable after latest Oomph update [message #1407875 is a reply to message #1407844] Wed, 13 August 2014 17:28 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31032
Registered: July 2009
Senior Member
Ernesto,

Comments below.

On 13/08/2014 5:44 PM, Ernesto Posse wrote:
> When performing startup tasks (automatically) Oomph pops up a dialog asking for permission to access secure information from my keychain (I'm on MacOSX 10.9), in particular it asks me for my Bugzilla password (which I have previously entered), but it pops up the dialog 8 times for every single character that I type. (See screenshot attached).
Which of the three choices do you do with the dialog that comes up?
> It does this every time I start Eclipse, making it unbearable. Why is it doing this? And more importantly, how can I prevent it from doing that?
It seems related to some recent changes, and I'm still in the middle of
updating the password support (where I know there was one place where I
had to make changes to ensure that such a dialog doesn't come up, but
I've not committed that yet with too many other things to test...

Can you make a screenshot of your General -> Security -> Secure Storage
preferences page showing the "Password" tab?
>
> I don't see any log files created or modified today to give any hints.
>
> Thanks.
>
Re: Eclipse unusable after latest Oomph update [message #1408229 is a reply to message #1407875] Thu, 14 August 2014 14:51 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 384
Registered: March 2011
Senior Member
I've tried the three choices. Only when I click on "Deny" it will stop asking.

I found out that on Preferences > General > Security > Secure Storage there are entries for "Master password providers", but even if I uncheck them, I still get Oomph to ask for such access. (I'm attaching the screenshot).

Thanks.
Re: Eclipse unusable after latest Oomph update [message #1408248 is a reply to message #1408229] Thu, 14 August 2014 15:37 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31032
Registered: July 2009
Senior Member
Ernesto,

I have those things too (though a Window's specific version of the first
one) but both of mine are check marked. I can try to see what happens
if I uncheck them both, though I'm not sure what that means...

On 14/08/2014 4:51 PM, Ernesto Posse wrote:
> I've tried the three choices. Only when I click on "Deny" it will stop asking.
>
> I found out that on Preferences > General > Security > Secure Storage there are entries for "Master password providers", but even if I uncheck them, I still get Oomph to ask for such access. (I'm attaching the screenshot).
>
> Thanks.
>
Re: Eclipse unusable after latest Oomph update [message #1408252 is a reply to message #1408248] Thu, 14 August 2014 15:48 Go to previous messageGo to next message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 384
Registered: March 2011
Senior Member
They were originally checked. I found a post elsewhere (https://www.eclipse.org/forums/index.php/t/235447/#page_top) suggesting the problem with not accepting passwords was this and that trying to uncheck them would work. But alas, it doesn't.

Also, the [Deny] button doesn't actually stop the repetition as I mentioned before.

I tried updating Oomph, and then it failed to start altogether. Now I'm trying to redo everything from a clean slate, downloading Oomph again, removing ~/.eclipse and ~/.p2 to see if that will lead an environment in a good working state.

Re: Eclipse unusable after latest Oomph update [message #1408592 is a reply to message #1408252] Fri, 15 August 2014 13:57 Go to previous message
Ernesto Posse is currently offline Ernesto PosseFriend
Messages: 384
Registered: March 2011
Senior Member
Restarting from scratch with the latest version of Oomph didn't work.
Previous Topic:Oomph & Check for updates
Next Topic:Project Selection misses "IDE for DSL developers"
Goto Forum:
  


Current Time: Sat Apr 04 13:19:30 GMT 2020

Powered by FUDForum. Page generated in 0.02095 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top