Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse 4.4 not running(Eclipse 4.4 will not run on mac due to an incompatible JVM)
Eclipse 4.4 not running [message #1405578] Thu, 07 August 2014 17:18 Go to next message
Felis Phasma is currently offline Felis PhasmaFriend
Messages: 1
Registered: August 2014
Junior Member
I just downloaded Eclipse 4.4 for mac, when I tried running it, there was a popup saying that eclipse could not run because of an incompatible JVM:
index.php/fa/18821/0/

Last I knew I had the latest java version. I was able to confirm that I had the latest version of java on the java website:
index.php/fa/18822/0/

Does anyone know why I can't get eclipse to work on my mac?

Thank you.
Re: Eclipse 4.4 not running [message #1406080 is a reply to message #1405578] Sat, 09 August 2014 00:22 Go to previous message
Jared Walsh is currently offline Jared WalshFriend
Messages: 1
Registered: August 2014
Junior Member
Hey, I just had this problem too! After some quick browsing, this is what I did to fix the solution:

1. Open the Eclipse folder in Finder, and find the Eclipse application
2. Right click on the app, and click Show Package Contents
3. /Contents/MacOS, and open eclipse.ini. If it asks for a program, any is fine. I used TextEditor
4. A little below halfway down, you should see a line that says:
-Dosgi.requiredJavaVersion=1.7

just change that to 1.7 to 1.6, and then Eclipse should run!

Hope this helped!
Previous Topic:Missing method tooltip snippets
Next Topic:Newbie: Eclipse Web Tools Platform
Goto Forum:
  


Current Time: Thu Dec 03 20:47:08 GMT 2020

Powered by FUDForum. Page generated in 0.01938 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top