Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » testexec can't connect to AUT
testexec can't connect to AUT [message #1405369] Thu, 07 August 2014 07:46 Go to next message
Elise Ruelle is currently offline Elise RuelleFriend
Messages: 65
Registered: April 2013
Member
Hi,

I have a new problem with my automation of my Jubula's test...

I have automated some test suite since a few month and they work pretty well (except some errors). But since some days, sometimes my job on Hudson fail with the error "Can't connect to AUT".
I've checked if the AUT is running and it is. No other things are running on the machine during the execution of my job.

So, a lot of days I have to launch a new time my test so it's time consuming and let me think I can't trust myself to Jubula.

Have you any idea to solve my problem and having a test automation safest ?

For information :
My Hudson server and Jubula run on different virtual machine on the same server.
Jubula version is the 7.1.

Thanks per advance for any help or advice.


Elise Ruelle

ALL4TEC
Re: testexec can't connect to AUT [message #1405443 is a reply to message #1405369] Thu, 07 August 2014 11:29 Go to previous messageGo to next message
Oliver Goetz is currently offline Oliver GoetzFriend
Messages: 140
Registered: May 2011
Senior Member
Hi,

on which platform are you working on? How do you start the AUT (via configuration in testexec, autrun, from the ITE)? Have you changed something in your test Environment? Have you tried using Jubula 8.0?
Regards
Oliver
Re: testexec can't connect to AUT [message #1405460 is a reply to message #1405443] Thu, 07 August 2014 12:08 Go to previous message
Elise Ruelle is currently offline Elise RuelleFriend
Messages: 65
Registered: April 2013
Member
Hi,

My AUT is launched on a virtual machine with Windows XP 32 bits. It's started with the autrun.
My Hudson job is configure to execute the next steps :
- Take the last compiled AUT (from another job)
- Add the plugin to my AUT
- Start the AUT Agent
- Start the AUT
- Run the Test Job with 5 Test suites
- Close the AUT Agent
- Create a index of access to reports

My environment has not been modified since the creation of the Hudson job two month ago.

At the moment, I've not tried Jubula 8.0 but in the near future we would like to upgrade Jubula to the version 8.0. But one of my concerns is whether automation with Jubula 8 is more maintainable ?
Jubula automated tests have been failed too many times for obscure reasons, if you have any advice to ameliorate our automation I would be happy to hear.

Thanks


Elise Ruelle

ALL4TEC
Previous Topic:Parametrise Eventhandler: Retry
Next Topic:Native dialog (file chooser)
Goto Forum:
  


Current Time: Tue Jun 30 05:39:24 GMT 2015

Powered by FUDForum. Page generated in 0.01790 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software