Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Unresolved requirement: Require-Capability: eclipse.platform(Issue updating Equinox/OSGi platform from Kepler to Luna)
Unresolved requirement: Require-Capability: eclipse.platform [message #1403713] Fri, 25 July 2014 14:01 Go to next message
Stephen Ranger is currently offline Stephen RangerFriend
Messages: 8
Registered: November 2012
Junior Member
We recently decided to drop Java 1.7 support and I have been working on updating our software to require Java 1.8 and in the process found out that the libraries we were using from Kepler had some dependency issues and it was suggested somewhere that the new Luna libraries fixed things. So, I've been migrating our libraries to Luna-based libraries.

Now, I believe I have everything updated and I have it in a compilable state, however, it doesn't run successfully. Currently, I have it to the point where I receive the following errors in the workspace/.metadata/.log file:

!SESSION 2014-07-25 09:23:07.218 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_11
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments:  -pluginCustomization configuration/plugin_customization.ini
Command-line arguments:  -clean -pluginCustomization configuration/plugin_customization.ini

!ENTRY org.eclipse.core.filesystem.macosx 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.macosx [122]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=macosx) (|(osgi.arch=x86) (osgi.arch=ppc) (osgi.arch=x86_64)))"


!ENTRY org.eclipse.swt.win32.win32.x86 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.swt.win32.win32.x86 [75]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.eclipse.core.resources.win32.x86_64 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.core.resources.win32.x86_64 [9]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=win32) (osgi.arch=x86_64))"


!ENTRY org.eclipse.equinox.launcher.win32.win32.x86 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.win32.win32.x86 [29]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.eclipse.equinox.launcher.cocoa.macosx 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.cocoa.macosx [55]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )"


!ENTRY org.eclipse.core.filesystem.linux.x86 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.linux.x86 [90]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=linux) (osgi.arch=x86))"


!ENTRY org.eclipse.ui.cocoa 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.ui.cocoa [23]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.ws=cocoa)"


!ENTRY org.eclipse.swt.cocoa.macosx.x86_64 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.swt.cocoa.macosx.x86_64 [71]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"


!ENTRY org.eclipse.equinox.launcher.win32.win32.x86_64 2 0 2014-07-25 09:23:09.754
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.win32.win32.x86_64 [128]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86_64))"


!ENTRY org.eclipse.swt.win32.win32.x86_64 2 0 2014-07-25 09:23:09.755
!MESSAGE Could not resolve module: org.eclipse.swt.win32.win32.x86_64 [118]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86_64))"


!ENTRY org.eclipse.core.filesystem.win32.x86 2 0 2014-07-25 09:23:09.755
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.win32.x86 [124]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.eclipse.core.resources.win32.x86 2 0 2014-07-25 09:23:09.755
!MESSAGE Could not resolve module: org.eclipse.core.resources.win32.x86 [95]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.eclipse.equinox.launcher.cocoa.macosx.x86_64 2 0 2014-07-25 09:23:09.755
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.cocoa.macosx.x86_64 [133]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"


!ENTRY org.eclipse.swt.gtk.linux.x86 2 0 2014-07-25 09:23:09.755
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.x86 [127]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"


!ENTRY org.eclipse.core.filesystem.win32.x86_64 2 0 2014-07-25 09:23:09.755
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.win32.x86_64 [60]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=win32) (osgi.arch=x86_64))"


!ENTRY org.eclipse.swt.cocoa.macosx 2 0 2014-07-25 09:23:09.755
!MESSAGE Could not resolve module: org.eclipse.swt.cocoa.macosx [28]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2014-07-25 09:23:09.755
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.x86 [50]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"


!ENTRY org.eclipse.osgi 4 0 2014-07-25 09:23:09.756
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "<my.app>.workspace.ui.<application>" could not be found in the registry. The applications available are: org
.eclipse.equinox.app.error.
	at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
	at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:236)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1438)


Not sure what the eclipse.platform is referring to. There's a platform.jar in the eclipse luna platform but copying that to my plugins directory doesn't fix the issue. Also, I have gotten it running ifI run it from within Eclipse (which make me think my previous issue is a bundle missing or incorrect start order) but then I get the following errors:

java.lang.NoClassDefFoundError: javafx/scene/Parent
	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(Class.java:2688)
	at java.lang.Class.getMethod0(Class.java:2937)
	at java.lang.Class.getMethod(Class.java:1771)
	at <my.app>.cfp.container.FxGadgetContainerBeanInfo.<init>(FxGadgetContainerBeanInfo.java:10)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:408)
	at java.lang.Class.newInstance(Class.java:433)
	at com.sun.beans.finder.InstanceFinder.instantiate(InstanceFinder.java:96)
	at com.sun.beans.finder.InstanceFinder.find(InstanceFinder.java:66)
	at java.beans.Introspector.findExplicitBeanInfo(Introspector.java:448)
	at java.beans.Introspector.<init>(Introspector.java:398)
	at java.beans.Introspector.getBeanInfo(Introspector.java:173)
	at <my.app>.bean.ComponentUtils.getBeanInfo(ComponentUtils.java:51)
	at <my.app>.bean.ComponentUtils.getDisplayName(ComponentUtils.java:332)
	at <my.app>.bean.ComponentUtils.getName(ComponentUtils.java:358)
	at <my.app>.workspace.ui.compositiongraph.VisualizationComponentList$6.compare(VisualizationComponentList.java:207)
	at <my.app>.workspace.ui.compositiongraph.VisualizationComponentList$6.compare(VisualizationComponentList.java:1)
	at java.util.TimSort.countRunAndMakeAscending(TimSort.java:351)
	at java.util.TimSort.sort(TimSort.java:230)
	at java.util.Arrays.sort(Arrays.java:1435)
	at <my.app>.workspace.ui.compositiongraph.VisualizationComponentList.updateListData(VisualizationComponentList.java:203)
	at <my.app>.workspace.ui.compositiongraph.VisualizationComponentList.access$0(VisualizationComponentList.java:198)
	at <my.app>.workspace.ui.compositiongraph.VisualizationComponentList$4.run(VisualizationComponentList.java:170)
	at <my.app>.util.concurrent.RunQueue$1.run(RunQueue.java:33)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at <my.app>.util.concurrent.MonitoredFuture.run(MonitoredFuture.java:193)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at <my.app>.util.concurrent.Executors$1$1.run(Executors.java:90)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: javafx.scene.Parent cannot be found by <my.app>.cfp_3.1.0.qualifier
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:423)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:336)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:328)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 36 more



Here's my config.ini

osgi.splashPath=platform:/base/plugins/<my.app>.workspace.ui
eclipse.application=<my.app>.workspace.ui.<application>
osgi.bundles=org.eclipse.equinox.common@2:start,\
 org.eclipse.update.configurator@2:start,\
 org.eclipse.equinox.ds@3:start,\
 org.eclipse.equinox.registry@4:start,\
 org.eclipse.equinox.app@5:start,\
 <my.app>.openglstuff@4:start,\
 <my.app>.logviewer@start,\
 org.eclipse.osgi@5:start,\
 <my.app>.workspace.collab@start,\
 <my.app>.workspace.collab.app@start,\
 <my.app>.messaging.app@start,\
 org.eclipse.core.runtime@3:start
 
osgi.bundles.defaultStartLevel=6
osgi.startLevel=6



Any help would be greatly appreciated. If anyone knows where to get some kind of runtime dependency debug or info about how Luna's libraries are different from Kepler or anything that might help me fix my issue I'd be greatly appreciative. (Also, some packages were obfuscated a bit; I don't think it'll cause issues determining what's going on)
Re: Unresolved requirement: Require-Capability: eclipse.platform [message #1404067 is a reply to message #1403713] Tue, 29 July 2014 12:21 Go to previous messageGo to next message
Thomas Watson is currently offline Thomas WatsonFriend
Messages: 490
Registered: July 2009
Senior Member
All the eclipse.platform requirements are coming from bundles that you have in your target that do not match your running environment:

BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US

java.lang.RuntimeException: Application "<my.app>.workspace.ui.<application>" could not be found in the registry

Is that the exact error message? Or did you remove your specific application name here? Similar question on the config.ini settings:

osgi.splashPath=platform:/base/plugins/<my.app>.workspace.ui
eclipse.application=<my.app>.workspace.ui.<application>
Re: Unresolved requirement: Require-Capability: eclipse.platform [message #1407881 is a reply to message #1404067] Wed, 13 August 2014 17:49 Go to previous messageGo to next message
Stephen Ranger is currently offline Stephen RangerFriend
Messages: 8
Registered: November 2012
Junior Member
Yes, I did remove the exact string. In previous versions of eclipse having non-platform jars in my target platform it would just ignore.

However, removing them only fixes the platform specific things; it doesn't fix the javafx exceptions (which are part of the java8 classpath by default). It will, however, run successfully when I remove the non-platform jars from my platform but when I go to open anything that requires javafx, it throws the javafx exceptions from before.
Re: Unresolved requirement: Require-Capability: eclipse.platform [message #1697476 is a reply to message #1407881] Thu, 04 June 2015 09:22 Go to previous message
Shashibhushan Gokhale is currently offline Shashibhushan GokhaleFriend
Messages: 6
Registered: April 2015
Junior Member
Stephen - are you still facing the problem? I am facing it and don't know how to proceed. Please share the solution if you were able to resolve it. By the way, if you are still facing the problem I came across this Eclipse 4.4 porting guide which is available here: https://eclipse.org/eclipse/development/porting/eclipse_4_4_porting_guide.php. I think this could help you identify differences between Kepler and Luna.
Previous Topic:Execute custom touchpoint that is not pre-installed
Next Topic:Eclipse install fails on conflicting equinox p2 dependency
Goto Forum:
  


Current Time: Tue Nov 20 14:04:24 GMT 2018

Powered by FUDForum. Page generated in 0.02250 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top