Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Failed to load p2 repository on maven build
Failed to load p2 repository on maven build [message #1403414] Wed, 23 July 2014 14:12 Go to next message
John Doe is currently offline John DoeFriend
Messages: 25
Registered: May 2014
Junior Member
Hello,

When I try to do a maven build on my e4 project pom, I have this error :

[ERROR] Internal error: java.lang.RuntimeException: Failed to load p2 repository with ID 'efxclipse-addons' from location http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site/: No repository found at http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site. -> [Help 1]
org.apache.maven.InternalErrorException: Internal error: java.lang.RuntimeException: Failed to load p2 repository with ID 'efxclipse-addons' from location http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site/


Indeed, the repository http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site do not exist.

I think the good one is http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/addons/nightly/site but I don't know how to configure the 'efxclipse-addons' url. I tried to modify the url on the tab "Effective POM" of the pom.xml but I couldn't edit it.

Do you know how could I configure it ? Thank you.
Re: Failed to load p2 repository on maven build [message #1403444 is a reply to message #1403414] Wed, 23 July 2014 17:17 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5875
Registered: July 2009
Senior Member
Hi,

What version of e(fx)clipse are you using I guess it is *NOT* 1.0.0
nightly right? Simply open the pom.xml in the releng project and switch
to the pom.xml - tab and adjust the URL.

Tom

On 23.07.14 16:12, John Doe wrote:
> Hello,
>
> When I try to do a maven build on my e4 project pom, I have this error :
>
>
> [ERROR] Internal error: java.lang.RuntimeException: Failed to load p2
> repository with ID 'efxclipse-addons' from location
> http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site/:
> No repository found at
> http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site.
> -> [Help 1]
> org.apache.maven.InternalErrorException: Internal error:
> java.lang.RuntimeException: Failed to load p2 repository with ID
> 'efxclipse-addons' from location
> http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site/
>
>
> Indeed, the repository
> http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site
> do not exist.
> I think the good one is
> http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/addons/nightly/site
> but I don't know how to configure the 'efxclipse-addons' url. I tried to
> modify the url on the tab "Effective POM" of the pom.xml but I couldn't
> edit it.
>
> Do you know how could I configure it ? Thank you.
Re: Failed to load p2 repository on maven build [message #1403495 is a reply to message #1403444] Thu, 24 July 2014 07:54 Go to previous messageGo to next message
John Doe is currently offline John DoeFriend
Messages: 25
Registered: May 2014
Junior Member
I only have this code on my pom.xml :
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
	<modelVersion>4.0.0</modelVersion>
	<name>MyApplicationE4 - application bundle</name>
	<groupId>MyApplicationE4</groupId>
	<artifactId>MyApplicationE4.app</artifactId>
	<packaging>eclipse-plugin</packaging>
	<parent>
		<groupId>MyApplicationE4</groupId>
		<artifactId>MyApplicationE4.app.releng</artifactId>
		<relativePath>../MyApplicationE4.app.releng/pom.xml</relativePath>
		<version>1.0.0-SNAPSHOT</version>
	</parent>
	<build>
		<resources>
			<resource>
				<directory>.</directory>
				<includes>
					<include>META-INF/</include>
				</includes>
			</resource>
		</resources>
		<plugins>
			<plugin>
				<groupId>org.eclipse.tycho</groupId>
				<artifactId>tycho-source-plugin</artifactId>
			</plugin>
		</plugins>
	</build>
</project>


Should I replace the content of the pom.xml tab by the content of the EffectivePOM tab ?
Re: Failed to load p2 repository on maven build [message #1403514 is a reply to message #1403495] Thu, 24 July 2014 09:17 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5875
Registered: July 2009
Senior Member
The important one is "../MyApplicationE4.app.releng/pom.xml" - there you
need to reconfigure the p2 repos.

Tom

On 24.07.14 09:54, John Doe wrote:
> I only have this code on my pom.xml :
>
> <project xmlns="http://maven.apache.org/POM/4.0.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
> <modelVersion>4.0.0</modelVersion>
> <name>MyApplicationE4 - application bundle</name>
> <groupId>MyApplicationE4</groupId>
> <artifactId>MyApplicationE4.app</artifactId>
> <packaging>eclipse-plugin</packaging>
> <parent>
> <groupId>MyApplicationE4</groupId>
> <artifactId>MyApplicationE4.app.releng</artifactId>
> <relativePath>../MyApplicationE4.app.releng/pom.xml</relativePath>
> <version>1.0.0-SNAPSHOT</version>
> </parent>
> <build>
> <resources>
> <resource>
> <directory>.</directory>
> <includes>
> <include>META-INF/</include>
> </includes>
> </resource>
> </resources>
> <plugins>
> <plugin>
> <groupId>org.eclipse.tycho</groupId>
> <artifactId>tycho-source-plugin</artifactId>
> </plugin>
> </plugins>
> </build>
> </project>
>
>
> Should I replace the content of the pom.xml tab by the content of the
> EffectivePOM tab ?
Re: Failed to load p2 repository on maven build [message #1403568 is a reply to message #1403514] Thu, 24 July 2014 12:45 Go to previous messageGo to next message
John Doe is currently offline John DoeFriend
Messages: 25
Registered: May 2014
Junior Member
Got it ! Thanks. But I have a new problem now : https://www.eclipse.org/forums/index.php/m/1403567/#msg_1403567
Re: Failed to load p2 repository on maven build [message #1403829 is a reply to message #1403568] Mon, 28 July 2014 07:57 Go to previous messageGo to next message
John Doe is currently offline John DoeFriend
Messages: 25
Registered: May 2014
Junior Member
This repository is not good for p2 : http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/addons/nightly/site

I also tried : http://download.eclipse.org/efxclipse/runtime-nightly/site

and : http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/runtime/nightly/site

I have this error when I compile:
"No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from org.eclipse.emf.ecore 2.10.0.v20140514-1158 to package javax.crypto 0.0.0.", "Unable to satisfy dependency from org.eclipse.emf.ecore 2.10.0.v20140514-1158 to package javax.crypto.spec 0.0.0."


Do you know what is the good repository for p2 ?


This is the pom :
<repository>
	<id>efxclipse-addons</id>
	<layout>p2</layout>
	<url>http://downloads.efxclipse.org/efxclipse.bestsolution.at/p2-repos/addons/nightly/site</url>
</repository>
]


Thank you.
Re: Failed to load p2 repository on maven build [message #1403833 is a reply to message #1403829] Mon, 28 July 2014 08:07 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5875
Registered: July 2009
Senior Member
The only valid repository is
http://download.eclipse.org/efxclipse/runtime-nightly/site

Tom
Re: Failed to load p2 repository on maven build [message #1403849 is a reply to message #1403833] Mon, 28 July 2014 09:33 Go to previous messageGo to next message
John Doe is currently offline John DoeFriend
Messages: 25
Registered: May 2014
Junior Member
But this URL is used for 2 repository "efxclipse-repo" and "efxclipse-addons". I think this is the problem.

 	<repositories>
		<repository>
			<id>efxclipse-repo</id>
			<layout>p2</layout>
			<url>http://download.eclipse.org/efxclipse/runtime-nightly/site</url>
		</repository> 
 		<repository>
			<id>efxclipse-addons</id>
			<layout>p2</layout>
			<url>http://download.eclipse.org/efxclipse/runtime-nightly/site</url>
		</repository> 
	</repositories> 


I have this warning
[WARNING] p2 repository with URL http://download.eclipse.org/efxclipse/runtime-nightly/site is associated with multiple IDs; was 'efxclipse-repo', now is 'efxclipse-addons'
Re: Failed to load p2 repository on maven build [message #1403851 is a reply to message #1403849] Mon, 28 July 2014 09:37 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5875
Registered: July 2009
Senior Member
You don't need the addons - it is only needed if you run JUnit-Tests

Tom

On 28.07.14 11:33, John Doe wrote:
> But this URL is used for 2 repository "efxclipse-repo" and
> "efxclipse-addons". I think this is the problem.
>
>
> <repositories>
> <repository>
> <id>efxclipse-repo</id>
> <layout>p2</layout>
>
> <url>http://download.eclipse.org/efxclipse/runtime-nightly/site</url>
> </repository> <repository>
> <id>efxclipse-addons</id>
> <layout>p2</layout>
>
> <url>http://download.eclipse.org/efxclipse/runtime-nightly/site</url>
> </repository> </repositories>
>
> I have this warning
>
> [WARNING] p2 repository with URL
> http://download.eclipse.org/efxclipse/runtime-nightly/site is associated
> with multiple IDs; was 'efxclipse-repo', now is 'efxclipse-addons'
>
Re: Failed to load p2 repository on maven build [message #1403860 is a reply to message #1403851] Mon, 28 July 2014 10:01 Go to previous messageGo to next message
John Doe is currently offline John DoeFriend
Messages: 25
Registered: May 2014
Junior Member
I still have this error :

[ERROR] Cannot resolve project dependencies:
[ERROR]   Software being installed: E4App.app 1.0.0.qualifier
[ERROR]   Missing requirement: org.eclipse.emf.ecore 2.10.0.v20140514-1158 requires 'package javax.crypto 0.0.0' but it could not be found
[ERROR]   Cannot satisfy dependency: E4App.app 1.0.0.qualifier depends on: bundle org.eclipse.e4.ui.model.workbench 0.0.0
[ERROR]   Cannot satisfy dependency: org.eclipse.e4.ui.model.workbench 1.1.0.v20140512-1820 depends on: bundle org.eclipse.emf.ecore 2.9.0
Re: Failed to load p2 repository on maven build [message #1403863 is a reply to message #1403860] Mon, 28 July 2014 10:28 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5875
Registered: July 2009
Senior Member
That's interesting "javax.crypto" is from the JRE and part of it since
1.7 IIRC.

I just tested locally and can NOT reproduce the problem running
maven-tycho 0.21 together with JDK8.

Tom

On 28.07.14 12:01, John Doe wrote:
> I still have this error :
>
>
> [ERROR] Cannot resolve project dependencies:
> [ERROR] Software being installed: E4App.app 1.0.0.qualifier
> [ERROR] Missing requirement: org.eclipse.emf.ecore
> 2.10.0.v20140514-1158 requires 'package javax.crypto 0.0.0' but it could
> not be found
> [ERROR] Cannot satisfy dependency: E4App.app 1.0.0.qualifier depends
> on: bundle org.eclipse.e4.ui.model.workbench 0.0.0
> [ERROR] Cannot satisfy dependency: org.eclipse.e4.ui.model.workbench
> 1.1.0.v20140512-1820 depends on: bundle org.eclipse.emf.ecore 2.9.0
>
Previous Topic:Non-resolvable parent POM on OSGI Bundle Project
Next Topic:CSS Warnings
Goto Forum:
  


Current Time: Sat Sep 05 10:26:31 GMT 2015

Powered by FUDForum. Page generated in 0.05482 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software