Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » e4/maven/tycho doesn't find required bundle
e4/maven/tycho doesn't find required bundle [message #1400440] Mon, 14 July 2014 07:50 Go to next message
Hanspeter Halle is currently offline Hanspeter HalleFriend
Messages: 2
Registered: June 2014
Junior Member
I'm working on my first project with e4, maven and tycho. For that reason I post here, as I guess the solution is quite simple, but I cant find it. This project built fine, until I decided to use version 1.5.0 of org.eclipse.core.databinding.observable instead of 1.4.1. Maven doesn't find this bundle, while it is present in my eclipse installation. So my question is: How can I force tycho or maven to use the repository containing the newer bundle.
Re: e4/maven/tycho doesn't find required bundle [message #1400700 is a reply to message #1400440] Mon, 14 July 2014 15:49 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Are you using a Target Platform?
Also, note that there is a Tycho users mailing list that might help.


[Updated on: Mon, 14 July 2014 15:52]

Report message to a moderator

Re: e4/maven/tycho doesn't find required bundle [message #1402599 is a reply to message #1400700] Thu, 17 July 2014 08:01 Go to previous message
Hanspeter Halle is currently offline Hanspeter HalleFriend
Messages: 2
Registered: June 2014
Junior Member
There was no target platform configured. But by the help of the repository browser linked by the doc page I figured out that the missing bundle was not part of the Eclipse update site (as I thought) but on an e4 snapshot repository. So I added this to my POM and it works now. Thank you for your support.
Previous Topic:How to new CQSession (cqjni.jar) by eclipse-jee-kepler-SR2-win32-x86_64
Next Topic:Lauching failed on Debian 7
Goto Forum:
  


Current Time: Fri Oct 18 08:27:06 GMT 2019

Powered by FUDForum. Page generated in 0.03028 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top