Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Jubula:Oracle database problem(Testexec throwing error while rnning testjobs)
Jubula:Oracle database problem [message #1397759] Thu, 10 July 2014 05:50 Go to next message
Ranjeet Gupta is currently offline Ranjeet GuptaFriend
Messages: 10
Registered: July 2014
Junior Member
Hi,
I was using jubula default database for my project.Now I want to switch my database to Oracle.I am using window 7 64 bits.So i have downloaded "OracleXE112_Win64" database and installed to my system.this database working perfect..Now I have added this database in jubula window/preferences/Database connections as name-Oracle type-Oracle and SID-XE.
Now In jubula,i had gone to test/select database and I provided username and password,then I opened the database and imported my project.my project got imported.
I had created testexec for default database its working perfectly for default Embedded(H2).Now i changed -dbscheme "Oracle" -dbuser "system" -dbpw "...."Now i am trying to run this testexec,it is showing "No database connection available for name "Oracle".Available name:Default Embedded(H2)".
Here oracle is my scheme name which i created in preferenec of jubula.please have a look at the screensots which attached with this one.
Again i used this script to run oracle database-"sqlpls / nolog
connect / as sysdba
alter system set sessions=100 scope=spfile;
alter system set processes=100 scope=spfile;
quit"

its working perfectly.
But again I started my testexec to run it is still showing the same error.

please let me know how to rectify this issue.

Thanks and Regards,
Ranjeet Gupta
  • Attachment: Capture.PNG
    (Size: 25.46KB, Downloaded 37 times)
Re: Jubula:Oracle database problem [message #1401342 is a reply to message #1397759] Tue, 15 July 2014 13:11 Go to previous message
Oliver Goetz is currently offline Oliver GoetzFriend
Messages: 115
Registered: May 2011
Senior Member
Have you tried using the parameter "-dburl" instead of "-dbscheme"? If you use "-dbscheme" you have to use "-data" as well.
Regards
Oliver
Previous Topic:Object mapping : Highlight in AUT not working
Next Topic:How to custom parameters??
Goto Forum:
  


Current Time: Wed May 06 03:31:07 GMT 2015

Powered by FUDForum. Page generated in 0.03603 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software