Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [XCORE] The required library 'org.eclipse.emf.xcore.lib' isn't on the classpath
[XCORE] The required library 'org.eclipse.emf.xcore.lib' isn't on the classpath [message #1392047] Tue, 01 July 2014 20:15 Go to next message
Theo Weiß is currently offline Theo WeißFriend
Messages: 9
Registered: January 2014
Junior Member
Hi,

I'm working on a project based on a *juno* target platform. When I try to use Luna as IDE I get the following error: "The required library 'org.eclipse.emf.xcore.lib' isn't on the class path". Is there a way to fix this without upgrading the target platform?

Regards,
Theo
Re: [XCORE] The required library 'org.eclipse.emf.xcore.lib' isn't on the classpath [message #1392253 is a reply to message #1392047] Wed, 02 July 2014 04:07 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30351
Registered: July 2009
Senior Member
Theo,

If you're Xcore doesn't contain block expressions you don't strictly
need that dependency in your project's MANIFEST.MF. See the recent titled

[XCore] org.eclipse.emf.ecore.xcore.lib cannot be resolved

Otherwise, yes, you need it in the target platform.


On 01/07/2014 10:15 PM, Theo Weiß wrote:
> Hi,
>
> I'm working on a project based on a *juno* target platform. When I try
> to use Luna as IDE I get the following error: "The required library
> 'org.eclipse.emf.xcore.lib' isn't on the class path". Is there a way
> to fix this without upgrading the target platform?
>
> Regards,
> Theo
>
Re: [XCORE] The required library 'org.eclipse.emf.xcore.lib' isn't on the classpath [message #1392757 is a reply to message #1392253] Wed, 02 July 2014 20:18 Go to previous messageGo to next message
Theo Weiß is currently offline Theo WeißFriend
Messages: 9
Registered: January 2014
Junior Member
Ed,

I don't use block expressions. Therefore I tried this:
annotation "http://www.eclipse.org/emf/2002/GenModel" as GenModel

@GenModel(updateClasspath="false", runtimeVersion="2.8",literalsInterface="true", loadInitialization="false")
package org.openhab.binding.tinkerforge.internal.model


but the editor complains about:
Quote:

Multiple markers at this line
- The namespace prefix 'null' is not well formed
- mismatched input 'annotation' expecting 'package'
- The namespace URI 'null' is not well formed

If I move the annotation statement below the import block it doesn't complain anymore about @GenModel but I still get the error message about the missing library.

Any hints?
Re: [XCORE] The required library 'org.eclipse.emf.xcore.lib' isn't on the classpath [message #1392958 is a reply to message #1392757] Thu, 03 July 2014 03:32 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30351
Registered: July 2009
Senior Member
Theo,

Yes annotation declarations must come after the package declaration and
once you use updateClasspath="false" you are responsible for maintaining
the contents of the MANIFEST.MF, so if you remove the dependency from
the MANIFEST.MF, it should stay removed.


On 02/07/2014 10:18 PM, Theo Weiß wrote:
> Ed,
>
> I don't use block expressions. Therefore I tried this:
>
> annotation "http://www.eclipse.org/emf/2002/GenModel" as GenModel
>
> @GenModel(updateClasspath="false",
> runtimeVersion="2.8",literalsInterface="true",
> loadInitialization="false")
> package org.openhab.binding.tinkerforge.internal.model
>
>
> but the editor complains about:
> Quote:
>> Multiple markers at this line
>> - The namespace prefix 'null' is not well formed
>> - mismatched input 'annotation' expecting 'package'
>> - The namespace URI 'null' is not well formed
>
> If I move the annotation statement below the import block it doesn't
> complain anymore about @GenModel but I still get the error message
> about the missing library.
>
> Any hints?
Re: [XCORE] The required library 'org.eclipse.emf.xcore.lib' isn't on the classpath [message #1393803 is a reply to message #1392047] Fri, 04 July 2014 09:37 Go to previous message
Felix Dorner is currently offline Felix DornerFriend
Messages: 295
Registered: March 2012
Senior Member
On 01/07/2014 22:15, Theo Weiß wrote:
> Hi,
>
> I'm working on a project based on a *juno* target platform. When I try
> to use Luna as IDE I get the following error: "The required library
> 'org.eclipse.emf.xcore.lib' isn't on the class path". Is there a way to
> fix this without upgrading the target platform?

I ran into the same issue a while ago, when opening Xtend files, you get
the compiler error: 'Couldn't find the mandatory library
'org.eclipse.xtext.xbase.lib' 2.4.0 or higher on the project's
classpath"'. I asked the TMF group, and it seems impossible to remove
this error without upgrading the target or downgrading the development
IDE :(
Previous Topic:XMI id attributes not being exported
Next Topic:XMLProcessor.load(inpustream,map) throwing IOWrapped Exception
Goto Forum:
  


Current Time: Sun Aug 18 22:08:34 GMT 2019

Powered by FUDForum. Page generated in 0.02241 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top