Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] IllegalValueException
[Acceleo] IllegalValueException [message #1386624] Wed, 18 June 2014 20:02 Go to next message
Luís de Sousa is currently offline Luís de SousaFriend
Messages: 214
Registered: July 2009
Senior Member
Hello everyone,

I am getting the exception below when I try to run a template on a class diagram with a few stereotypes applied on (both developed with Papyrus):

Quote:
An internal error occurred during: "Launching Main".
org.eclipse.emf.ecore.xmi.IllegalValueException: Value 'org.eclipse.uml2.uml.internal.impl.PropertyImpl@6ad0019 (name: sprawl, visibility: <unset>) (isLeaf: false) (isStatic: false) (isOrdered: false, isUnique: true, isReadOnly: false) (aggregation: none, isDerived: false, isDerivedUnion: false, isID: false)' is not legal.


Any idea what may be causing it?

Thank you.
Re: [Acceleo] IllegalValueException [message #1386628 is a reply to message #1386624] Wed, 18 June 2014 20:13 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7265
Registered: July 2009
Senior Member
Hi

There is probably something wrong with your model . Did you Validate it?

Regards

Ed Willink

On 18/06/2014 21:02, Luís de Sousa wrote:
> Hello everyone,
>
> I am getting the exception below when I try to run a template on a
> class diagram with a few stereotypes applied on (both developed with
> Papyrus):
>
> Quote:
>> An internal error occurred during: "Launching Main".
>> org.eclipse.emf.ecore.xmi.IllegalValueException: Value
>> 'org.eclipse.uml2.uml.internal.impl.PropertyImpl@6ad0019 (name:
>> sprawl, visibility: <unset>) (isLeaf: false) (isStatic: false)
>> (isOrdered: false, isUnique: true, isReadOnly: false) (aggregation:
>> none, isDerived: false, isDerivedUnion: false, isID: false)' is not
>> legal.
>
>
> Any idea what may be causing it?
>
> Thank you.
Re: [Acceleo] IllegalValueException [message #1386850 is a reply to message #1386628] Sat, 21 June 2014 14:59 Go to previous messageGo to next message
Luís de Sousa is currently offline Luís de SousaFriend
Messages: 214
Registered: July 2009
Senior Member
Hi Ed, just a quick update on this.

This model is not new and had been validated a good time ago. Following your suggestion I run the validator again and got a series of "Unreferenceable element:" errors. I have been trying to track the cause of this error but so far I haven't found any information.

Thank you in any case.
Re: [Acceleo] IllegalValueException [message #1394401 is a reply to message #1386850] Sat, 05 July 2014 07:48 Go to previous message
Luís de Sousa is currently offline Luís de SousaFriend
Messages: 214
Registered: July 2009
Senior Member
Just a final follow up. This seems to be a bug with Papyrus, the model went invalid after re-applying a profile. Reported here:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=438955

Cheers.
Previous Topic:Acceleo installation in Luna Modeling Tools
Next Topic:[Xpand] Accessing enum name values
Goto Forum:
  


Current Time: Mon Sep 20 00:00:43 GMT 2021

Powered by FUDForum. Page generated in 0.02145 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top