Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Dependencies of same plugin with different versions
Dependencies of same plugin with different versions [message #1385092] Wed, 04 June 2014 09:55 Go to next message
Jonathan Dumont is currently offline Jonathan DumontFriend
Messages: 58
Registered: March 2011
Location: Laval
Member
Hi all,

We try to migrate an Eclipse RCP product, based on features, to Eclipse 4 using the compatibility layer.

This changed our plugins dependencies as some of the tools integrated to our product have evolved. The problem is that we now depends of some plugins with several versions. For example, we need org.apache.batik.css but for both versions [1.6.0, 1.7.0) and [1.7.0, 1.8.0).

We have built a target platform and a repository with the both versions. The first one is used for our development Eclipse instance, the second one is referenced by our Tycho build.

With Tycho, we managed to build our product with the both versions of the plugin. Our .product definition is based on features and has not been changed.
In the Eclipse instance used for development, we managed to build a launch configuration based on plugins, and manually include the both versions, and it works. But we didn't managed to build a launch configuration based on features, which includes and starts the both versions of the needed plugin...

How can I define in my features that they depends of a plugin, with several versions ? It seems that if I specify the both dependencies, only one is respected.

Thanks for your advices.






Re: Dependencies of same plugin with different versions [message #1385225 is a reply to message #1385092] Thu, 05 June 2014 04:40 Go to previous messageGo to next message
Velganesh Subramanian is currently offline Velganesh SubramanianFriend
Messages: 67
Registered: July 2009
Member
In my experience, the latest version is picked up unless you define a strict dependency. We ran into such problems when using Guava through XText.
Re: Dependencies of same plugin with different versions [message #1385245 is a reply to message #1385225] Thu, 05 June 2014 07:26 Go to previous message
Jonathan Dumont is currently offline Jonathan DumontFriend
Messages: 58
Registered: March 2011
Location: Laval
Member
And have you defined your strict dependancies in your plugin dependancies, or in your feature content ?

[Updated on: Thu, 05 June 2014 07:27]

Report message to a moderator

Previous Topic:Goodies from o.e.ui.workbench
Next Topic:IHandlerService with Compatibility-Layer
Goto Forum:
  


Current Time: Tue Jun 30 08:43:03 GMT 2015

Powered by FUDForum. Page generated in 0.02420 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software