Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse not running on Linux Mint 17(starting but not loading gui)
Eclipse not running on Linux Mint 17 [message #1384887] Mon, 02 June 2014 19:19 Go to next message
Bul Satar is currently offline Bul SatarFriend
Messages: 7
Registered: June 2014
Junior Member
Afternoon Everyone,

I asked the question first over at the Linux Mint forums (title is Eclipse not working - mint 17. would post link but site won't let me since new to forums) but has been a day with no answers so thought I would try at the source. If you don't want to hop over to that forum, here is what my problem is:

When I start eclipse, the initial popup comes on with the logo and version number, turns gray then does nothing. I can't even kill the process with xkill. I have to use ctrl+alt+backspace!!

What I have tried so far:
have openjre and openjdk installed (7)
installed ia32-libs-multiarch since I am on 64 bit
installed eclipse version from Software Manager (3.8 )
downloaded and extracted the newest stable Kepler version from the eclipse website

All of this has resulted in exactly the same gray popup that doesn't do anything. The UI never loads, it is just stuck. Since it never loads, there are no error logs generated (at least none I could find).

Any and all help greatly appreciated!!!!

~~Edit~~
For more information:
output from java -version
java version "1.7.0_55"
OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1)
OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)

Anything else I can provide to help??? Would really like to get back to some programming Smile

[Updated on: Mon, 02 June 2014 22:43]

Report message to a moderator

Re: Eclipse not running on Linux Mint 17 [message #1385048 is a reply to message #1384887] Wed, 04 June 2014 00:21 Go to previous messageGo to next message
Bul Satar is currently offline Bul SatarFriend
Messages: 7
Registered: June 2014
Junior Member
No ideas? no "this might work?" No one else having problems on mint 17?
Re: Eclipse not running on Linux Mint 17 [message #1385137 is a reply to message #1385048] Wed, 04 June 2014 14:05 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
First recommendation: don't install any Eclipse that is provided by a linux package manager; just download directly from www.eclipse.org. Experience has shown again and again that this will avoid lots of headaches.
Second recommendation: Use the Oracle JDK instead of OpenJDK, and specify it according to these instructions.
Re: Eclipse not running on Linux Mint 17 [message #1385200 is a reply to message #1385137] Thu, 05 June 2014 00:21 Go to previous messageGo to next message
Bul Satar is currently offline Bul SatarFriend
Messages: 7
Registered: June 2014
Junior Member
I installed the jdk via the ppa for the installer. also downloaded the automatic variable installer. I downloaded the eclipse directly from the download site and extracted but left in place (which shouldn't matter since the rest of the moving and such is just setup for ease of use). I also added this line to the eclipse.ini
-vm
/usr/lib/jvm/java-7-oracle/bin

The results were exactly the same. The initial loading pop up showed up with the logo then turned gray and completely locked up, same as the other versions/ways I have tried. Anything else I can try??
Re: Eclipse not running on Linux Mint 17 [message #1385201 is a reply to message #1385137] Thu, 05 June 2014 00:20 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/04/2014 08:05 AM, Eric Rizzo wrote:
> First recommendation: don't install any Eclipse that is provided by a
> linux package manager; just download directly from www.eclipse.org.
> Experience has shown again and again that this will avoid lots of
> headaches.
> Second recommendation: Use the Oracle JDK instead of OpenJDK, and
> specify it according to https://wiki.eclipse.org/Eclipse.ini.

Sorry we didn't respond quickly enough. Yes, it's not possible to
over-emphasize that it's a bad idea to obtain Eclipse from anywhere but
eclipse.org.

I have no problem using openJDK, but the Sun JDK is obviously the stallion.
Re: Eclipse not running on Linux Mint 17 [message #1385204 is a reply to message #1385200] Thu, 05 June 2014 00:39 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/04/2014 06:21 PM, Bul Satar wrote:
> I installed the jdk via the ppa for the installer. also downloaded the
> automatic variable installer. I downloaded the eclipse directly from
> the download site and extracted but left in place (which shouldn't
> matter since the rest of the moving and such is just setup for ease of
> use). I also added this line to the eclipse.ini
> -vm
> /usr/lib/jvm/java-7-oracle/bin
>
> The results were exactly the same. The initial loading pop up showed up
> with the logo then turned gray and completely locked up, same as the
> other versions/ways I have tried. Anything else I can try??

It might work if you add "/java" to the end of your configuration
statement here.

I'm waiting myself to upgrade to Mint 17 LTS. I'm a little surprised
you're having trouble. This said, let me explain exactly how I set up
Eclipse (under Mint 13 LTS).

1. Download latest JDK 7 from java.sun.com. Explode on a private path
like /home/russ/dev/jdk1.7.0_45.

2. Download Eclipse JEE (in my case) from eclipse.org. Explode on a
private path like /home/russ/dev/eclipse.

3. Edit eclipse.ini pointing (just as you did above) to my private JDK:

-vm
/home/russ/dev/jdk7.0.1_45/bin/java

I like to use my own, private copy of Java. That way, no upgrade is
going to come along to change anything on me. The rest of my host uses
the installed Java; I develop in Eclipse on one that won't change until
I change it.

Maybe saying this is useful to someone Googling for answers.

Cheers

Russ
Re: Eclipse not running on Linux Mint 17 [message #1385206 is a reply to message #1385204] Thu, 05 June 2014 01:45 Go to previous messageGo to next message
Bul Satar is currently offline Bul SatarFriend
Messages: 7
Registered: June 2014
Junior Member
Just tried your way Russell, with having everything separate and pointing to the individual extracted downloaded files. Same result.

I had a working version on 13 lts also and had been going thru the coursera courses to learn android programming. was going to expand on that and start working up programs on my server so I could learn how to do some automation and communication between phone and server (not for anything practical yet, just for fun). At least I am not experiencing these problems in a production environment. That would be horrible!

Still, problem exists and I have no clue how to fix it. Here is my whole eclipse.ini file:

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140116-2212
-product
org.eclipse.epp.package.standard.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
/media/Private/Storage/Chrome Downloads/jdk1.8.0_05/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.6
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m
Re: Eclipse not running on Linux Mint 17 [message #1385208 is a reply to message #1385206] Thu, 05 June 2014 01:57 Go to previous messageGo to next message
Bul Satar is currently offline Bul SatarFriend
Messages: 7
Registered: June 2014
Junior Member
Just did a quick video to show everyone what is happening. Can't close it, stays stuck even if I use various kill commands via cli. Only thing that fixes the gray box is logging out and logging back in. Starting to think it is a flaw with 17...

idk if everyone caught it before but I am on 64 bit 17 and have downloaded the 64 bit of all versions of eclipse and java jdk.

youtube dot com watch?v=vt3TYOtnINU&feature=youtu.be
Re: Eclipse not running on Linux Mint 17 [message #1385209 is a reply to message #1385206] Thu, 05 June 2014 01:59 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/04/2014 07:45 PM, Bul Satar wrote:
> Just tried your way Russell, with having everything separate and
> pointing to the individual extracted downloaded files. Same result.
> I had a working version on 13 lts also and had been going thru the
> coursera courses to learn android programming. was going to expand on
> that and start working up programs on my server so I could learn how to
> do some automation and communication between phone and server (not for
> anything practical yet, just for fun). At least I am not experiencing
> these problems in a production environment. That would be horrible!
>
> Still, problem exists and I have no clue how to fix it. Here is my
> whole eclipse.ini file:
>
> -startup
> plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
> --launcher.library
> plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140116-2212
>
> -product
> org.eclipse.epp.package.standard.product
> --launcher.defaultAction
> openFile
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> --launcher.defaultAction
> openFile
> --launcher.appendVmargs
> -vm
> /media/Private/Storage/Chrome Downloads/jdk1.8.0_05/bin/java
> -vmargs
> -Dosgi.requiredJavaVersion=1.6
> -XX:MaxPermSize=256m
> -Xms40m
> -Xmx512m

Don't know what version of Eclipse you're running, but I think only
Kepler will handle it. I have not so far run Java 8 underneath though I
have added it for use as an alternative JRE. You mention Android,
otherwise I'd assume you're trying to use Kepler.
Re: Eclipse not running on Linux Mint 17 [message #1385211 is a reply to message #1385209] Thu, 05 June 2014 02:02 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/04/2014 07:59 PM, Russell Bateman wrote:
> On 06/04/2014 07:45 PM, Bul Satar wrote:
>> Just tried your way Russell, with having everything separate and
>> pointing to the individual extracted downloaded files. Same result.
>> I had a working version on 13 lts also and had been going thru the
>> coursera courses to learn android programming. was going to expand on
>> that and start working up programs on my server so I could learn how to
>> do some automation and communication between phone and server (not for
>> anything practical yet, just for fun). At least I am not experiencing
>> these problems in a production environment. That would be horrible!
>>
>> Still, problem exists and I have no clue how to fix it. Here is my
>> whole eclipse.ini file:
>>
>> -startup
>> plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
>> --launcher.library
>> plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140116-2212
>>
>>
>> -product
>> org.eclipse.epp.package.standard.product
>> --launcher.defaultAction
>> openFile
>> -showsplash
>> org.eclipse.platform
>> --launcher.XXMaxPermSize
>> 256m
>> --launcher.defaultAction
>> openFile
>> --launcher.appendVmargs
>> -vm
>> /media/Private/Storage/Chrome Downloads/jdk1.8.0_05/bin/java
>> -vmargs
>> -Dosgi.requiredJavaVersion=1.6
>> -XX:MaxPermSize=256m
>> -Xms40m
>> -Xmx512m
>
> Don't know what version of Eclipse you're running, but I think only
> Kepler will handle it. I have not so far run Java 8 underneath though I
> have added it for use as an alternative JRE. You mention Android,
> otherwise I'd assume you're trying to use Kepler.

I see you are using Kepler, but my comments stand because of my
experience. Java 8 hasn't been a priority yet, in fact, at work, Java 6
as the required runtime is only just coming to an end. I personally have
been on Java 7, even at work, for a couple of years, but there's little
impetus for me other than experimentation to move forward.

Try with Java 7 and see.

Cheers
Re: Eclipse not running on Linux Mint 17 [message #1385212 is a reply to message #1385211] Thu, 05 June 2014 02:32 Go to previous messageGo to next message
Bul Satar is currently offline Bul SatarFriend
Messages: 7
Registered: June 2014
Junior Member
Tried java 7. same result. I also downloaded the 32 bit versions of both just to see if that made a difference. same result.

ggrrrrr
Re: Eclipse not running on Linux Mint 17 [message #1385309 is a reply to message #1385212] Thu, 05 June 2014 14:15 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 360
Registered: July 2009
Location: Japan
Senior Member
No such problem here, Linux Mint 17 Cinnamon 64-bit(almost vanilla installation), preinstalled java(
>java version "1.7.0_55"
>OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1)
>OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)
) and eclipse-standard-kepler-SR2-linux-gtk-x86_64.tar.gz(other packages as well).
Since I've never experienced such a problem, I have no idea.
How about "./eclipse -data workspace" (or "./eclipse -nosplash -data workspace") ?
Re: Eclipse not running on Linux Mint 17 [message #1385371 is a reply to message #1385212] Thu, 05 June 2014 22:03 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/04/2014 08:32 PM, Bul Satar wrote:
> Tried java 7. same result. I also downloaded the 32 bit versions of
> both just to see if that made a difference. same result.
>
> ggrrrrr


Guess I won't be moving to Mint 17 until I hear more and better.
Re: Eclipse not running on Linux Mint 17 [message #1385380 is a reply to message #1385371] Fri, 06 June 2014 03:08 Go to previous message
Bul Satar is currently offline Bul SatarFriend
Messages: 7
Registered: June 2014
Junior Member
GOT IT!! And it was complete user error. I feel like a moron. I completely reinstalled mint 17 and when I started it up, the exact same thing happened. However, this time I hadn't even altered my display setup. I am running dual monitors but the second is in another room. The workspace selection popped up on the SECOND monitor and locked everything up when I didn't select one because I couldn't see it. This time around, I saw it, smacked my head extremely hard.

I am extremely sorry to everyone but thanks for trying to help an idiot....
Previous Topic:multiple IDEs
Next Topic:eclipse(or ADT) versions/setting generating different template code
Goto Forum:
  


Current Time: Thu Oct 22 21:58:44 GMT 2020

Powered by FUDForum. Page generated in 0.03757 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top