Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Dynamic Languages Toolkit (DLTK) » Debugging Ruby(Cannot debug Ruby scripts)
Debugging Ruby [message #1384638] Thu, 29 May 2014 19:46 Go to next message
Dennis Duggan is currently offline Dennis DugganFriend
Messages: 2
Registered: May 2014
Junior Member
I am running Kepler 64 bit on Windows 7 and have the following installed:
Dynamic Languages Toolkit - Core Frameworks 2.0.0.v20100518-1923-7L--EAAoOVMSMc4AWEvJ org.eclipse.dltk.core.feature.group Eclipse.org
Dynamic Languages Toolkit - Core Frameworks SDK 2.0.0.v20090730-1127-5--90U45SFRujYToYq6KvGxbBBpP org.eclipse.dltk.core.sdk.feature.group Eclipse.org
Dynamic Languages Toolkit - Ruby Development Tools 2.0.0.v20100505-1154-7G--E_EkMU3NHhvAUo0G org.eclipse.dltk.ruby.feature.group Eclipse.org
Dynamic Languages Toolkit - Ruby Development Tools SDK 2.0.0.v20090730-1127-4--84L23HCMnUW7RPoxKoq2YAFlN org.eclipse.dltk.ruby.sdk.feature.group Eclipse.org

I have installed Ruby run time and I am able to run Ruby scripts but I cannot debug Ruby scripts. No matter how I configure the preference Ruby>debug>engine. I keep getting the runtime error:
/AppData/Local/Temp/dltk3590.tmp/debugger/common/Logger.rb:27:in `logException': uninitialized class variable @@logger in XoredDebugger::Logger (NameError)
from C:/Users/dduggan/AppData/Local/Temp/dltk3590.tmp/debugger/AbstractRunner.rb:60:in `rescue in run'
from C:/Users/dduggan/AppData/Local/Temp/dltk3590.tmp/debugger/AbstractRunner.rb:15:in `run'
from C:/Users/dduggan/AppData/Local/Temp/dltk3590.tmp/debugger/BasicRunner.rb:20:in `<module:XoredDebugger>'
from C:/Users/dduggan/AppData/Local/Temp/dltk3590.tmp/debugger/BasicRunner.rb:12:in `<top (required)>'
from C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'


Am I missing some other package that I need?

Thanks!
Dennis

[Updated on: Thu, 29 May 2014 19:47]

Report message to a moderator

Re: Debugging Ruby [message #1758359 is a reply to message #1384638] Tue, 28 March 2017 05:21 Go to previous message
Binh Minh Nguyen is currently offline Binh Minh NguyenFriend
Messages: 2
Registered: March 2017
Junior Member
I got the same error with ruby2.3 but for ruby2.2 it work OK. After upgrade DTLK from 5.5 to 5.7 it still have problem but don't show the error detail in console windows any more. Any one can help pls
Previous Topic:ShellEd did not recognise variables with leading underscore
Next Topic:Cannot get code assistance/ completion for ruby
Goto Forum:
  


Current Time: Tue Jun 27 14:18:52 GMT 2017

Powered by FUDForum. Page generated in 0.03388 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software