Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Deployment problems with RAP 2.3 M3
Deployment problems with RAP 2.3 M3 [message #1369815] Tue, 20 May 2014 19:09 Go to next message
Ulrike Freitag is currently offline Ulrike FreitagFriend
Messages: 5
Registered: May 2014
Junior Member
Hello,

we used RAP 2.2 M2 for out rap appliation with java 1.7 on win7 x64.
After the firefox update to 29, I try to change our rap target from 2.2M2 to rap 2.3 M3 .

It's run fine under eclipse with rap launcher, but if I deploy the war-File to my tomcat7, I could not access to our application - error 404.

WIth the manager the directory for our application is visible.

In the osgi console via telnet I can see the bundles for our application is active. There is not any error message in all tomcat logfiles.

I try also to deploy the eclipse rap.demo application and I have the same problem.

I have a target with rap 2.3 M§, equinox-sdk-kepler.zip an emf-xsd.

I don't have any idea what I can do to analyse the problem.

Thanks for any help.

Ulrike
Re: Deployment problems with RAP 2.3 M3 [message #1370954 is a reply to message #1369815] Wed, 21 May 2014 06:40 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
could you provide the output of osgi "ss" command? Do you see all needed
plugins listed there?
Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Deployment problems with RAP 2.3 M3 [message #1370955 is a reply to message #1369815] Wed, 21 May 2014 06:43 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
.... I just built a WAR with maven (our Controls Demo) and it works fine
under Tomcat 8.0.3. How did you create your WAR?
Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Deployment problems with RAP 2.3 M3 [message #1371254 is a reply to message #1370955] Wed, 21 May 2014 09:34 Go to previous messageGo to next message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 152
Registered: July 2009
Senior Member

Yes, as Ivan suggested, please send us the output of the 'ss' command on the OSGi console.

One possible cause of this issue: RAP 2.3 is based on the latest Equinox from Luna, including the latest Equinox servlet bridge. You mention in your description that you are using a Kepler-target. My guess is that you are running a mix between these two versions and that this leads to unexpected results. That would be what I suggest to check next.

Thanks,
Markus
Re: Deployment problems with RAP 2.3 M3 [message #1384147 is a reply to message #1371254] Wed, 28 May 2014 08:44 Go to previous messageGo to next message
Ulrike Freitag is currently offline Ulrike FreitagFriend
Messages: 5
Registered: May 2014
Junior Member
Thank you for your answers.

I attach 3 ss logs from the osgi console.
- one from the running version via eclipse directly for our smsclient (SmartMediaStudioClient)
- one for the same bundle which is not running in Tomcat, there is only the 404 response

- one of the rap demo example. I build the war file with the same functions of eclipse like in our application and depley it on tomcat7

Re: Deployment problems with RAP 2.3 M3 [message #1384149 is a reply to message #1384147] Wed, 28 May 2014 08:48 Go to previous messageGo to next message
Ulrike Freitag is currently offline Ulrike FreitagFriend
Messages: 5
Registered: May 2014
Junior Member
now the other both ss outputs
Re: Deployment problems with RAP 2.3 M3 [message #1384252 is a reply to message #1384149] Wed, 28 May 2014 14:20 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
are you using the same URL from Eclipse and Tomcat for launching your
app? Did you respect the WAR name as context path when starting the app
in Tomcat?
Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Deployment problems with RAP 2.3 M3 [message #1384305 is a reply to message #1384252] Wed, 28 May 2014 17:10 Go to previous messageGo to next message
Ulrike Freitag is currently offline Ulrike FreitagFriend
Messages: 5
Registered: May 2014
Junior Member
Hallo Ivan,
naturally I use different links

from eclipse
"http...127.0.0.1:10090/csmeClient/csmeClient" (where ... = ://)

from tomcat

"http...127.0.0.1:8080/smsclient/csmeClient"

Where smsclient.war is the name from the war file which I deploy.

csmeClient is the name of an entrypoint for our client.

With the older version this was running in such way.

For the rapdemo I have build an rapdemo.war. Deply this in the webapps directory from tomcat and start the server again.

The url was "http...127.0.0.1:8080/demo/fancy"

the url from eclipse "http...127.0.0.1:63941/workbench/fancy"

I can upload my rapdemo.war, if you think, that it can help.

Thanks for answer,
Ulrike
Re: Deployment problems with RAP 2.3 M3 [message #1384310 is a reply to message #1384305] Wed, 28 May 2014 17:26 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
how did you build your WAR - maven or Libra WAR Products? Please attach
RAP demo WAR that does not work. In case of WAR product, please upload
"warproduct" config file and WEB-INF folder too.
Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Deployment problems with RAP 2.3 M3 [message #1384321 is a reply to message #1384310] Wed, 28 May 2014 18:08 Go to previous messageGo to next message
Ulrike Freitag is currently offline Ulrike FreitagFriend
Messages: 5
Registered: May 2014
Junior Member
Hello,
i build it by Libra WAR Products
  • Attachment: web.xml
    (Size: 1.33KB, Downloaded 180 times)
  • Attachment: rapdemo.warproduct
    (Size: 5.60KB, Downloaded 88 times)
Re: Deployment problems with RAP 2.3 M3 [message #1384514 is a reply to message #1384321] Thu, 29 May 2014 07:16 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
your "warproduct" points to non-existing files:
<warConfiguration webXml="/org.eclipse.rap.demo/WEB-INF/web.xml"
launchIni="/org.eclipse.rap.demo/WEB-INF/launch.ini">
Are you sure that your target is 2.3M3?
Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Deployment problems with RAP 2.3 M3 [message #1384519 is a reply to message #1384321] Thu, 29 May 2014 07:36 Go to previous message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
.... and this is slightly modified "warproduct" file (removed source and
missing plugins, only workbench demo) that works for me under Tomcat
8.0.3 and RAP from master.
HTH,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:Massive problems with RAP 2.3 M3
Next Topic:Nebula CompositeTable support
Goto Forum:
  


Current Time: Tue Feb 18 19:00:14 GMT 2020

Powered by FUDForum. Page generated in 0.03832 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top