Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Massive problems with RAP 2.3 M3
Massive problems with RAP 2.3 M3 [message #1369538] Tue, 20 May 2014 16:33 Go to next message
Lothar Werzinger is currently offline Lothar WerzingerFriend
Messages: 153
Registered: July 2009
Location: Bay Area
Senior Member
Hi,

We have an application based on Kepler (RAP 2.1) and we are experiencing the browser display problems
https://bugs.eclipse.org/bugs/show_bug.cgi?id=433179
and
https://bugs.eclipse.org/bugs/show_bug.cgi?id=428717

To address these we tried to build our application with RAP 2.3 M3.

Unfortunately we are experiencing massive problems.

After bringing up the app


  • Context menus (right mouse button) do not work
  • Switching (tabed) views and editors does not work.
  • Some views show no content.


After several minutes of running the app (without touching it) the problems seem to disappear and it works as expected.

Displaying the app on Firefox seems to have the fastest recovery time.
Chrome/Chromium takes much longer.

We are not seeing any log output / exceptions on the console.

Does anyone experience similar problems with RAP 2.3 M3?

Any help is highly appreciated.
Re: Massive problems with RAP 2.3 M3 [message #1369555 is a reply to message #1369538] Tue, 20 May 2014 16:43 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
I could say that this is a browser caching issue. Try to clear the
browser cache. Such "massive" problems are unknown to us.
HTH,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Massive problems with RAP 2.3 M3 [message #1375084 is a reply to message #1369555] Thu, 22 May 2014 23:03 Go to previous messageGo to next message
Martin Lynch is currently offline Martin LynchFriend
Messages: 3
Registered: May 2014
Junior Member
ISSUES: failed enabling of widgets, and failed population of content panes.
BEHAVIOR: Navigation within the page could induce desired behavior

Some widgets that were not enabled, as well as content panes that were not populated, could be induced to do so if: The page was navigated in certain ways.

Ways to induce expected behavior:
1) exercising a menu drop down
2) use widgets min/restore/max panes
3) view another object of the same type in an editor pane

An mp4 video capture is attached: Tradescape_RAP_2.3_Issues.mp4

CASES demonstrated in the mp4 video:
1) Tree Pane widgets not all enabled
2) right-click menu not presented
3) A Tab's 'x' for close no longer functions
4) Editor pane calendar widget stops functioning after another editor is shown and then return to the editor pane with previously functioning calendar widget
Re: Massive problems with RAP 2.3 M3 [message #1384016 is a reply to message #1369555] Tue, 27 May 2014 20:11 Go to previous messageGo to next message
Martin Lynch is currently offline Martin LynchFriend
Messages: 3
Registered: May 2014
Junior Member
Browser Cache cleared but the issues persist

Firefox 29.0.1: Tools > Options > Advanced > Network tab
Cached Web Content: Clear Now > 0 bytes
Offline Web Content and User data: Clear Nw > 0 bytes

Chrome 34.0.1847.137 m > Customize (3 horizontal lines) > Tools > Clear browsing data
Obliterate the following items from: 'the beginning of time'
Browsing history
Download history
Cookies and other site and plug-in data
Cached images and files

IE 11: Tools > Internet options > General tab > Browsing history section > Delete
un-check: Preserve Favorites website data
check: Temporary Internet files and website data
check: History
check: Download History


Re: Massive problems with RAP 2.3 M3 [message #1384125 is a reply to message #1384016] Wed, 28 May 2014 07:38 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
please try upcoming RAP RC2. We fixed one Menu issue:
[Menu] Application lockup when hovering over disabled item
https://bugs.eclipse.org/bugs/show_bug.cgi?id=435361
Please open bugzillas about your issue (with a snippets to reproduce)
and we will address them as soon as possible.
Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Massive problems with RAP 2.3 M3 [message #1384286 is a reply to message #1384125] Wed, 28 May 2014 16:07 Go to previous message
Lothar Werzinger is currently offline Lothar WerzingerFriend
Messages: 153
Registered: July 2009
Location: Bay Area
Senior Member
Ivan Furnadjiev wrote on Wed, 28 May 2014 00:38
Hi,
please try upcoming RAP RC2. We fixed one Menu issue:
[Menu] Application lockup when hovering over disabled item
https://bugs.eclipse.org/bugs/show_bug.cgi?id=435361
Please open bugzillas about your issue (with a snippets to reproduce)
and we will address them as soon as possible.
Best,
Ivan


We did not have an easy way to reproduce the problem. That's why we provided the video of the behavior.

We tried RAP 2.3 RC1 (org.eclipse.rap.rwt_2.3.0.20140520-1615.jar) and initial tests look like the application is behaving normally again.
More tests will follow.
We'll consider using RC2 as soon as it's available.
Previous Topic:JFace Data Binding and SWT.Modify
Next Topic:Deployment problems with RAP 2.3 M3
Goto Forum:
  


Current Time: Sat Feb 22 23:56:07 GMT 2020

Powered by FUDForum. Page generated in 0.02189 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top