Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Label on canvas does not display after upgrade
Label on canvas does not display after upgrade [message #223774] Tue, 31 March 2009 20:16 Go to next message
JSP  is currently offline JSP Friend
Messages: 18
Registered: July 2009
Junior Member
I upgraded from Eclipse 3.4.1 to Eclipse 3.4.2 and now some labels in my
GMF editor do not show up initially. If you click where the label is
supposed to be, it will show up or if you somehow float over the text, the
area that was floated over shows up.

I believe this might be specific to gmf_1.1.3 as I reverted
org.eclipse.draw2d_3.4.2 back to the previous version and also
org.eclipse.gef_3.4.2 to its previous version and the problem persisted.
After reverting gmf_1.1.3 back to its previous version my labels started
appearing again.

Has anyone else experienced this problem? I can provide more information
about the setup of my EditParts and figures but I wanted to see if this is
a known issue - I wasn't able to find an issue that sounded like this.
Re: Label on canvas does not display after upgrade [message #223852 is a reply to message #223774] Wed, 01 April 2009 11:30 Go to previous messageGo to next message
Alexander Shatalin is currently offline Alexander ShatalinFriend
Messages: 2928
Registered: July 2009
Senior Member
Hello JSP,

Consider using GMF 2.1.3 with Eclipse 3.2.4 - older versions of GMF were
released based on older eclipse versions and can be working incorrectly with
later eclipses..

-----------------
Alex Shatalin
Re: Label on canvas does not display after upgrade [message #223938 is a reply to message #223852] Wed, 01 April 2009 17:22 Go to previous messageGo to next message
JSP  is currently offline JSP Friend
Messages: 18
Registered: July 2009
Junior Member
Sorry, I think I am using GMF 2.1.3. The versioning is kind of confusing
to me because the feature is called org.eclipse.gmf_1.1.3.v20090122. The
SDK however is called 2.1.3. I believe I am using the latest.

Anyway, I tracked down the change that is causing my problem.

The layout() method of the BorderedNodeFigure changed from this:
protected void layout() {
if (!this.getBounds().equals(getMainFigure().getBounds())) {
getMainFigure().setBounds(this.getBounds().getCopy());
}
// When parent resizes, cause the border items to be relocated.
getBorderItemContainer().invalidateTree();
erase();
}

To this:
protected void layout() {
if (!this.getBounds().equals(getMainFigure().getBounds())) {
getMainFigure().setBounds(this.getBounds().getCopy());
getBorderItemContainer().invalidateTree();
erase();
}
}

Because my main figure was the same size as my bordered node figure, the
invalidateTree() and erase() method were never being called.

Do you think this is a bug?
Re: Label on canvas does not display after upgrade [message #224011 is a reply to message #223938] Thu, 02 April 2009 09:58 Go to previous messageGo to next message
Alexander Shatalin is currently offline Alexander ShatalinFriend
Messages: 2928
Registered: July 2009
Senior Member
Hello JSP,

> Do you think this is a bug?
Looks like. Please file a bugzilla for it.

-----------------
Alex Shatalin
Re: Label on canvas does not display after upgrade [message #227091 is a reply to message #224011] Thu, 23 April 2009 09:16 Go to previous messageGo to next message
vincent pucheux is currently offline vincent pucheuxFriend
Messages: 15
Registered: July 2009
Junior Member
Hi, we're having this trouble on our application due to upgrade too.

I don't manage to find the relative bugzilla,
is anyone having the bug number?
thx

v.


Alex Shatalin a écrit :
> Hello JSP,
>
>> Do you think this is a bug?
> Looks like. Please file a bugzilla for it.
>
> -----------------
> Alex Shatalin
>
>
Re: Label on canvas does not display after upgrade [message #227163 is a reply to message #227091] Thu, 23 April 2009 13:39 Go to previous messageGo to next message
Alexander Shatalin is currently offline Alexander ShatalinFriend
Messages: 2928
Registered: July 2009
Senior Member
Hello Vincent,

See https://bugs.eclipse.org/bugs/show_bug.cgi?id=270962

-----------------
Alex Shatalin
Re: Label on canvas does not display after upgrade [message #227170 is a reply to message #227163] Thu, 23 April 2009 14:04 Go to previous message
vincent pucheux is currently offline vincent pucheuxFriend
Messages: 15
Registered: July 2009
Junior Member
Thank you alex.


> Hello Vincent,
>
> See https://bugs.eclipse.org/bugs/show_bug.cgi?id=270962
>
> -----------------
> Alex Shatalin
>
>
Previous Topic:DIFFERENT TYPES OF RELATIONSHIPS (CONNECTIONS)
Next Topic:Problem to use old models with GMF 2.2
Goto Forum:
  


Current Time: Thu Nov 23 15:10:20 GMT 2017

Powered by FUDForum. Page generated in 0.02083 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software